Teq's Minor Assembly Shenanigans

What exactly do you mean by ‘magic weapon equipped before entering’’? I tried to replicate it by:

  1. Having Marcus wield a light brand when entering the arena (unsurprisingly, this works fine).
  2. Give the iron sword the ‘is magic’ weapon ability (0x2), wield light brand, and enter arena (using the sword as a weapon). Also worked fine.
  3. Have Marcus equip the iron sword (still magical) and use it as a weapon. Also worked fine.

Better tech support than people would ever get on a Microsoft support forum.

Or, should I say… Teq support?


Here’s the data of the sword (and every magic weapon in my hack):

The only item equipped:

The result:

And it happens with any class/character

I suspect something else is interfering somewhere, because it all works fine on my end. Can you shoot me a patch for your rom and a save, please?

Problem has been finally resolved.

Explanation: The battle struct has, amongst other things, your currently used weapon. 99.99% of the time, this corresponds to the equipped weapon (the one that gets the little E on the inventory screen). The one glaring exception to this rule is, of course, the arena.
The game wants to know what kind of animation it should display, so it checks the equipped weapon, rather than the used weapon, to check whether weapon ability 0x2 (magic) is set. Usually, this works fine, since they’re the same thing. However, if the equipped weapon is a magical wind sword, and the used weapon is a decidedly un-magical iron sword… well, I think you can guess what happens.
This problem would exist in vanilla FE as well if hybrid classes existed by having a unit wield a tome but have a higher physical weapon rank. Then again, I guess the melee/magic fix wouldn’t be necessary if this were the case, would it…
TL;DR: IntSys sucks.

Something I’ve wanted for some time is to know battle statistics without having to have combat animations on. I took a leaf from FEXNA’s book and implemented this:

Pics, 'cause it happened


Download here.

Major thanks to Eliwan for doing the stat name graphics.


  • If you weren’t aware, AS stands for attack speed. If you’re using a staff, AS doesn’t matter, so it’ll show --.
  • If you see one or the other character get completely covered by the box, let me know. It’d be extremely helpful if you have the y coordinates of both characters relative to the camera, not the map (ie, top left corner is 0,0). If you don’t know how to do this, get me a screenshot.
  • Likewise, if I forgot any interactions (for instance, I haven’t tested scripted fights at all), let me know.

Fixed a couple of glitches with the above hack; now healing from terrain and taking poison damage will not show the extra stats. In addition, I’ve added a catch-all to ensure the box always appears somewhere on the screen; the possibility of having it completely cover one or both of the combatants is just something that will have to be dealt with, alas.

EDIT: Also fixed a glitch in the Stat Colors hack that made the game hang in the link arena while looking for chapter data that doesn’t exist.


Regarding FE7’s Str-Mag Split:

When I try to apply a stat bonus pointer to a weapon to increase a unit’s magic when holding the item, the game shows the stat has increased but still treats the stat as though it hasn’t. The other stat boosts are applied just fine, and the magic booster (item 0x98) is operating as intended. I applied the split to a clean ROM to see if I messed up something, but I still get the same results. Any idea what the problem could be?

Just to clarify, are you saying that you have a weapon with a magic bonus, and the display works fine on the stat screen, but the boost doesn’t seem to be added in the combat calculations?

Yes, that is correct. The +Stat is shown on the Mag bar in the Personal data screen, but the stat change is not read on the items screen or in damage calculations.

Good catch. Go ahead and redownload; it should be fixed.

Wonderful! The magic bonus is working just fine! Thank you very much, Tequila!

Hi Tequila, I’ve been using your FE8 Capture ASM in a hack, and I’ve noticed three issues.

First, attempting to trade with a rescued blue unit causes the screen to glitch and eventually softlock.

Second, I don’t know if this is being caused by a conflict with another ASM I’m using but sometimes a unit will get random stat bonuses on their status screen; attempting to attack in this state softlocks the game, but this can be avoided by having the unit equip a different weapon.

Third, one of my chapters is set to have infinite reinforcements until the player clears the map, but with the Capture ASM installed they eventually stop spawning even if the enemy cap hasn’t been hit yet.

If you need more information let me know. Your capture ASM is excellent and I’d love to keep using it.


Not sure if i’m just being derp and forgetting something but when i try to patch your talk and growths master patch it gives me this error:
1 errors encountered:
File Display Growths EA.txt, Line 27, Column 2: No code named callHack_r1 found.

Fixed. Thanks for finding this.

Pretty sure that’s not me, especially if the stat bonuses are random. Send me a patch and I’ll try to debug if this continues.

Pretty sure that’s not me either.

Do you have the newest version of EA? callHack_r1 should be defined in Extensions/Hack Installation.txt.

1 Like

Another QoL hack. This one displays the weapon level when your rank increases.

The text is modifiable (edit the file 0x2.txt), but the rank letter and period will be tacked onto the end. Don’t forget to terminate with [X]!

Download here.


Fucking noice.

The ‘show new rank when increasing weapon rank’ patch now works with animations on. I should have known that IntSys believes consistency is for scrubs.


So, Teq, this is a personal request, no rush. Could I get you to make a display growths version for FE6 and 7? Now that I’ve got a guy working on a randomizer update, this would be very useful for people so that they don’t have to scroll through an exported file to see character stats/use nightmare. I don’t usually ask for ports to fe7, and certainly not fe6, but the display growths hack is extremely useful these days and I’m hoping it wouldn’t be ultra challenging to export it to the other games.

If no, that’s cool.

Also, if possible, I’d like to see a version that lets you see growths for enemies and NPC’s.

1 Like

Just a note on the Slayer/Effectiveness rework, there are a few discrepancies in weaknesses from the normal game:

  • Thief, Rogue, and Assassin are also weak to swordslayer in FE8 (in FE7 they weren’t, which I presume is why they are missing here), and also the Eirika Lord/Great Lord classes are weak to swordslayer as well.
  • The Manakete class (the one right above Manakete_F) is the class used by zombified Morva in Ch20, so should be considered a monster in addition to flier/dragon.

On an unrelated note, I was wondering if you had any interest in looking into the >= 64 HP situation where any character HP stats that are 64 or above are wrapped around back to 0 when the game is reset (so 68 HP becomes 4 HP when reset). >64 HP does work fine for characters during leveling up and proceeding through the game (I’m not sure if the vanilla game can even do that or if that was a hack, it’s been so long), and suspend/resume has no problem, it’s only when “Restart Chapter” is used that the stat overflows, so I guess it just has to do with the process of saving/loading the stats from cold storage. The same is true of the other stats like Str and Skill except they overflow at 32 instead of 64, though I’m not as concerned with those personally.

I’ve done a lot of Googling and mostly any discussions just end with “this would probably require ASM to do”, but haven’t found any indication of someone who can actually do ASM hacks trying to tackle it.

EDIT: Also, maybe I’m doing something wrong but it seems like the Slayer Effectiveness mod and the Show Heal Amount mods conflict with each other. Everything works fine when I have either of them applied alone, but if I apply them both, the game locks up when selecting the Staff option and then pressing A on a healing staff (and, on my mod, also when pressing A on the “Talk” option). I tested it also on a clean vanilla ROM, all I did was add the “->[X]” text at 0D4C and changed the ID in the Show heal amount EA file to match, and then applied both it and the Slayer patch with Event Assembler 10.1. It still locks up in the same way when attempting to use a healing staff (although the Talk option works again for some reason).