Help Needed. Can't get "Show Battle Stats with Anims Off" mod to work


#1

It’s about Tequila’s hack to show the various battle stats
even when having the battle animations not display:

I’ve been trying to apply this on a CLEAN rom
but it doesn’t work; game crashes as soon as combat initiates.

Tried EA,
tried changing Free_Space with FreeSpace,
tried having the rom in the same folder with the mod.

Can someone help?


#2

Can you show step by step what you did and whatnot?
Or share what you used for freespace, or any details.


#3

Do you use a buildfile, and if not, what’s your freespace set to and it’s what it look like in ROM


#4

Just run the main EA text file through EA.
Then tried to change the definition for “Free_Space” to “FreeSpace”. Doesn’t matter.

No but really don’t think that’s the problem.

It’s on a clean vanilla ROM. It doesn’t matter what the offset is.
(It’s what the mod originally has defined which points to empty area)


#5

Don’t change the name of the definition, change what it’s defined to, the number.
If you change the name you’ll just run into issues, unless you change it everywhere.
Shouldn’t matter either way if your ROM is clean.

What settings did you use in EA?
What changes did you make to the files?

Just to be clear, what the freespace definition is actually called means nothing, it could be called FriedChicken and it would still work the same as long as it’s used properly.


#6

Just set the EA to “FE8” on the main panel and just run the main text on a clean rom.
Nothing more.

None. Didn’t touch anything else other than 1 definition which is meaningless anyway.

Can you guys do a quick check? Just run it through a clean rom yourselves.


#7

It works perfectly fine.
I did no changes, none at all.
No crashes, the hack works as expected.

Are you sure you are using the right ROM?
Also just redownload the thing, don’t change the definitions.


#8

No doesn’t work. Even re-downloaded it.

Ok here we go through the basics:

The Mod Folder has these:
BattleStats1

The EA looks like this:
BattleStats2

What Emulator did you use? VisualBoy?

BattleStats3


#9

Does EA not give you any errors?
Is your EA up to date?
Again, are you sure the ROM is clean, and are the files unchanged?

The emulator isn’t going to make a difference for this.


#10

Just downloaded VisualBoyAdvance and just run the rom through it:

BattleStats4

Yep. The hack isn’t compatible with No$GBA.


#11

We all use no$gba debugger when making these.

You might just have a very old version.
Either way, it would be no$'s fault, not the hack’s


#12

The EA says “I’m awesome”…the message when no errors are detected
Yes, it’s 1.11
Yes absolutely sure about this.

Do me a last favor please
and run it through No@GBA and tell me your No$GBA’s version.
Mine is the v2.6

True. That’s why do me the above favor if possible.


#13

I have no$gba debugger 2.8c
I know this hack works on it because I’ve done many other things while that hack was active and there were never any issues.


#14

I see that explains it.

I need to get the 2.8 version then.

Thank you for your time and effort.