Tactile - SRPG Game Engine (and FEXNA)

Tags: #<Tag:0x00007f22d0113768>

I don’t really have time for a detailed writeup or fancy screenshots or whatever right now, it’s late and I’ve been working on getting this ready for release since the leak.
It’s the engine FE7x uses. This is the public beta. Have fun.

The core engine and more information are available at http://bwdyeti.com/tactile/.
However, I expect that what you actually want is

FEXNA
FEXNA is now a content pack for Tactile, a collection of GBAFE assets that have been ported into the engine, for use when generating a new project. While Tactile is an original engine I have the rights to, FEXNA has been split off to play it safe. Use at your own risk of course, like with hacking.

The FEXNA links are available in this Google doc. If you just want one simple download, you can get FEXNA and Tactile in one package. Otherwise if you’re interested in trying Tactile on its own, you can get just the FEXNA Content Pack separately. Copy it into Tactile Editor/srccontent/ so the editor can find it.

Source Control
The engine and content are all on GitHub, if that is a thing that interests you. FEXNA can be found separately on GitLab.

Setup
Installation instructions can be found at bwdyeti.com/tactile/install/, while a more detailed guide explaining creating a new project and getting started with Git can be found in the FEXNA download.

License
There are detailed license files in the download and on GitHub. The tldr is you can do whatever you want with Tactile other than sell it, and for now you can use the FE7x content that’s in FEXNA for educational purposes, but don’t distribute it as part of your own game. We’ll sort out making much of the 7x content available at some point.

Patreon
If you read all that and thought “wow that guy made a whole game engine for free, I sure wish I could support him somehow”, I made a Patreon I guess. Tactile will always be free to use, as well as all kinds of other stuff I made, but I appreciate the consideration.

65 Likes

I’ve read all of this and wow this guy sure does seem pretty cool.

8 Likes

I love you Yeti please have my babies

Edit: I have no idea how to use it but I’m sure it’s great in theory

10 Likes

Awesome! Looking forward to learning how to use it!

1 Like

Just a heads up to LITERALLY EVERYONE.

READ THE GUIDE. READ EVERY PART OF THE GUIDE AND FOLLOW EVERY STEP.

Skip nothing. Follow every single step in order.

If you say to yourself, “Eh, I have XY program installed already, I can just skip this step-” NO! BAD!

Do not skip any steps. Reinstall things in the exact order specified. Tactile is a finicky editor to set up, and if you skip anything, you are almost certain to have bugs. The editor won’t launch, or when it does launch, it will look broken and ugly, or the content libraries won’t work properly… and so on!

I swear, 100/100 people who say “I can’t get the editor to launch” always get the editor working in perfect order by restarting and following the guide from step one and making sure to skip nothing. Everyone starts off with that mentality of “I can just install the things I don’t have and I’ll be good,” but if you do this, you are almost certain to end up with a borked editor.

Yes, even I fell prey to this mentality when I first installed Tactile, as have many others.

So, for your own mental well-being, read and follow the bloody guide without skipping a single thing!

This is a PSA from Grandfather Klok.

23 Likes

this should have been the icon frfr
image

anyway, time to get back into the swing of things

9 Likes

This PSA won’t stop me since I never learnt how to read, only hack.

3 Likes

FEXNA released on my birthday? Thanks for the gift, Yeti!

2 Likes

Wow this great news!! :relaxed: BwdYeti thank you so much for all the work you put into this! And again for your amazing decision to share your work now!! I also want to thank everybody who contributed to this (Myke etc.)! This is the best way to close this year and go into the new!!

Congratulations on this achievement! I really hope that many will use this engine!

I already created a topic to collect legal assets to use with this engine:
A New Beginning - F2U Toolbox

The goal there is to create a “standard package” with 100% legal assets. A bit like the FEXNA package – but just without intellectual property infringement. It will still be a long way to go, but you all are most invited to contribute and to use this.

Happy New Year! Have a great 2021!!

4 Likes

The time has finally come and the vibration is maximum. :running_man:t2:

3 Likes

Congrats, this is a huge moment for the FE community! I’m shocked that this day is finally here!

For TL;DR clarity purposes, this includes battle and map sprites?

FEXNA 2020!

5 Likes

Thank you, I followed the instructions and everything worked well up until trying to do File > Compile Content, the following happened:
2. pop-up said I had to go to editors > text data
3. went to editors > text editor, pop-up appeared asking to save text data, clicked yes
4. tried to compile content again
5. pop-up “animation texture is out of date”
go to “battlers > battler formatting” and process all textures before compiling content
6. went to battlers > battler formatting, clicked “process outdated sprites”, “229 spritesheets processed”, clicked on actors, “do you want to save sprite data before changing sheets?”, clicked yes
7. tried to compile content again, this time it worked
8. test battle works. attacked with some guys on new game it works.
Am I good to go or did I mess something up?

FEXNA 2020 IS REAL

3 Likes

Hi!
I reluctantly write this post, but it seems that I cannot install everything correctly…
These are the errors I get:

Errors

20


The thing I don’t understand, that immediately afterwards automatically starts the editor
I try to follow the other part of the guide regarding creating a new project, but I get this new error:
22
23

Instead this is the procedure I performed to install everything:

My SetUp

1
It says I have already installed this package, because I am running on Windows 10
2
3
Do I think I have completed the pass number one correctly?



The Installation folder file leads me to install Visual Studio (2019) v.16.8.3, it’s correct?

6
7
8
up to this point I think everything has been installed correctly?

“This extension is already installed” is the meaning of the error, (the first time he gave me the guide message, but now he gives me this message)


instead here I think I have copied the files correctly to the correct destinations?



14
15

This extension is already installed, but immediately afterwards it gives me an error:


22 23

I hope someone has the patience to help me, I have already tried the procedure several times, but unfortunately I cannot install it correctly

Will there be a discord?

Yeah, any of the original classes for example. The edited vanilla classes (Wizard, Thief, Berserker, Corsair, Swordmaster, Vanguard, etc) are fine to use, and of course anything unedited from GBAFE isn’t mine to decide

If test battle worked everything sounds good to go, have fun

@Dancer_A reported a similar problem, I’m looking into it now. Will figure out a fix as soon as possible.

idk maybe, not right now at least. I need some time off

7 Likes

Just curious: Has anyone successfully built and used Tactile yet? Note that I am not referring to the leaked 4chan thing, I mean Yeti’s build posted above.

I’m curious to see if everyone is having problems, or only some people.

Perhaps feu discord should add a channel for tactile somewhere down the line. I am hoping it sees some use! :slightly_smiling_face:

2 Likes

I got stuck at the gacutil part, which I presume means I did something wrong in the previous steps and I need to start over (when I have time)

Edit: In case anyone else is having the same issue - in retrospect, it’s probably because I already had Visual Studio installed, and thus wasn’t presented with the same install screen as in the tutorial.

1 Like