Fire Emblem - Sealed in Light BETA

#1

Hello, I am Arid and I’ve been a long time reader in this
forum. I would like to thank everybody for the useful
information that I used to create my ROM hack.

This is Fire Emblem - Sealed in Light a story based around
the popular SRPG series, using its mechanics, but having
a unique story of my own making.

This game takes place on the continent of Ceratamine in a
time of peace. 15 Years earlier one of many wars took place.
Nihil, Vandal and Marcene fought over their holy given territory
carved out by the first 3 royals. 2 Nobles will be caught in the
cycle of war when tensions arise anew. Join Silvester and Marx
on their journey to end the conflict that threaten those they love!

Features custom music, custom maps, custom portraits, skill system,
custom personal skills, weapon edits, new and edited classes!

silvester_attc oldbeard_stats
milan_defend percy_battle

This is a FE8 hack.
Ends on chapter 12, more coming
BETA Version 2.0:

BETA Version 1.03:

Credits:
Skill System and buildFile method: Circles
FE10 Fighter: MageKnight404
Armour axe/sword: The Blind Archer
Soldier: Alusq
Halberdier: The Blind Archer
Hatless Mage: GabrielKnight
Dark Knight: Teraspark
Griffin Knight: BlueDruid
Axe Dragon Knight: eCut, Dancer_A
Axe Dragon Lord: The Blind Archer
Master Knight / Argonaut: Kenpuhu, Aruka, Nuramon
Hat Sniper: Nuramon, Swain, Temp
Archer, Archer (F): DerTheVaporeon
Pirate Recolor: Wan
Monk Repallet: Eldritch Abomination
Jacket Myrmidon: Pikmin1211, Jubby, fuzz94

7 Likes
[WIP][Please add your own hacks!] The Fire Emblem Hack Directory
#2

Decided to try the hack on a whim. It’s been ages since I did that. Screenshots would probably make it more enticing for people!

Quick thing I just noticed (more feedback coming soon): the map sprite for Silvester has weird artifact when you hover the cursor over him. I think this is an @Agro map sprite?

Notice the little bit of pixels hovering above the archer.

#3

I think there was a glitch when inserting the map sprite. I really don’t know why, but the sprite is custom made by me so maybe that has something to do with it? Also I really Didn’t expect somebody seeing this already

#4

Hmm. I thought it was a sprite you downloaded from the map sprite repository. So, I’m not super familiar with map sprite formatting. You can join the Discord and see if any of the FEU’ers can help you fix it! It’s a fairly small glitch, so it’s not the biggest issue :slight_smile:

#5

Cool, didn’t know there was a discord for this forum.
Thanks again for taking a look out of the blue.
I had this hack stewing for a while and it feels good to get
involved with the community.

#6

I have had a similar issue with map sprites but figured out what the issue is; it has nothing to do with the sprite itself. Located with the table for moving map sprite pointer data is the map sprite’s AP (Animation Pointer, I think). If a small sprite uses an AP that allows for larger or taller map sprites, it will use [leftover] data from RAM to fill in the extra space above the sprite if that sprite does not have its own data for that section of the spritesheet(example would be the swordmaster whose sword goes above the normal limit)
Duo%20Genocide%20Escape-%20President%20Mugaybe_01
To fix this, if you are using FEBuilder, in the “Moving Map Anime” module, change the “AP” to a more appropriate one. The map sprite looks to be of an archer, so you could likely just copy the archer’s and replace that (custom?) class’s AP.

4 Likes
#7

Actually, it’s a cavalier, not an archer, so copy the cav’s AP.

#8

Oh, I see it now. The artifact was above the archer, so I assumed it was the archer. Guess I am not paying enough attention.
Yeah, copy the cavalier’s instead.

#9

i cant patch it on fe8 neither with nups nor with tsukuyomi

#10

image
Try changing that to Ask/Notify/Ignore instead of Abort in NUPS and see if that lets you patch it.

#11

was already on abort mode when i did it

#12

He’s telling you to change to something other than abort. Set it to Ignore and see if it works or not. Don’t forget to apply the patch to FE8 and extract the rom from the zip file.

#13

When applying the patch ignore worked just fine for me with no missing content. Abort failed for me on other ups hacks.

#14

i didnt read the reply well enough but i edited my reply that i changed to ignore and it worked fine but apparently i didnt save it so all good now

#15

Thank you sage, it worked perfectly. I replaced that field with
the cavalier’s values and no artifacts!

#16

that’s because the program is set to automatically abort the operation if the abort box is ticked

#17

this looks nice arid. i’m no hacker, but i’ll certainly have fun playing! by the way, maybe you could add where the current beta ends in the OP? and update with some more screenshots as well :slight_smile: