FE8 kaitou patch (All 64 Chapters + 2 village JP/EN)

What rom do I need to patch this to?

Edit: Got it working now.

Changed all characters minimug.
I think it has more characterization.

Of course, there is a nice minimug of enemies as well.

When creating this minimug, I found that It can create a better image by cropping the image so that the lower lip is the lower limit and the chin is not outlined, but on the contrary, more of the hair is included.
Also, a slight modification of the cropped picture will make it look even better.

Another small improvement is that the warning function for the number of times remaining on a weapon has been adapted to MapBattle.
When a weapon’s durability drops below a certain number, the color of the weapon’s name changes.

I would like to add this feature to the normal battle screen as well, but the battle screen has its own palette structure, making it difficult to implement this feature…


Same thing happened to me and when I tried buying from the armory in the prologue. I even installed VBA-M and the issue is still happening. Tried playing a new clean version and just the UPS file through febuilder and its still crashing. I dont know what the issue is but I was looking forward to seeing all the stuff in this hack

Does it happen with newer versions?
In order to reproduce it, please tell me the following

Which version are you using?
As you can see, the version number is given by a date in YYYYYMMDD format.
In this case, it indicates 20230208, i.e., 2023/02/08 (February 08, 2023).

Are you using the JP version or the EN version?

What emulator are you using?

To make reproduction easier, please send us sav data if possible.
Or, if it also occurs in prologue, please give us details of the reproduction procedure.

I am using VBA-M and have not set up any problems so far.

I found the cause.
The culprit is MinimugPalette Patch.

The patch uses the bottom 0x200 of the text buffer, which seems to be incompatible with the translated patch.
Therefore, the translated version crashes.
For now, assign the sound room buffer (0x201F148) instead.
This should solve the problem.

ver 20230209 or later should be fine.

Benefits of AutoFeedback
If you press the F5 key in FEBuilderGBA and enable AutoFeedback to play the game, you will get one additional Master Seal as a benefit at the start of the game.





If you are playing in FEBuilderGBA and it does not work, please UPDATE FEbuilderGBA.
Because older versions are not supported.

Enough Master Seals go into the game, but may be useful in the early stages as they are worth 1000 gold if sold.
This is a gift for those who play with AutoFeedback enabled.
For specific specifications, please click here.

If you would like to use Auto Feedback in your work, please click here

Will this F.E. Hack be able to run on real hardware (GBA, NDS) via flashcard? I highly doubt it. Has anyone tried it there? In the meantime, testing it on my smartphone via MyBoy (accurate gba emulator for Android), the game crashed at the first battle animation, and even froze my phone, so much so that I had to restart it; how come? Sadly I have little hope that it will work on the original console. What a pity, it showed great promise. :sob:

I have never had it work on an actual device, so I don’t know about that.
However, it works on the VBA-M, mGBA so I don’t think it is that serious of a problem.

I would like to know more about it and what I did to cause it to freeze.
The version you downloaded.
Whether it is the Japanese or English version.
With whom was the battle fought?
Is the battle animation on or off?

What happens with other android emulators?
MyBoy seems to be a paid software.
And it seems to support Android 9 or later.
I have a very old Android machine and have no way to verify if what you are saying is true.

1 Like

I used the latest English patch applied to the fe8 Japanese rom, of course. The initial dialogues worked perfectly, with no problems, but when I attacked with the character riding the wyvern the battle animation did not start and crashed the phone. I also noticed that the characters on the map move fast, and there is no option to make it move at normal speed.
However, I decided to try it on DS Lite via Supercard SD to see how it works, and then I will post a picture here, if there are any anomalies, of where it crashes. Okay? :wink:

The initial dialogues worked perfectly, with no problems, but when I attacked with the character riding the wyvern the battle

You say that the problem occurred when you attacked with Lee.
So, if Estelle, the unit not on the dragon, attacked, would the same thing happen?

Also, if you turn off the battle animation, does the problem occur as well?

Also, at what part of the battle animation does it freeze?
I think in the battle animation the units load, the background appears, and then the attack takes place.
Then, after the animation ends, the process of returning to the map takes place.

What part of this process causes the problem?

I also noticed that the characters on the map move fast, and there is no option to make it move at normal speed.

The lack of options for speed settings is a specification.
Unit are moving at the fastest speed to cut down on extra work.
There is no reason to slow down the setting, so the selector is erased from the options as well.

However, I decided to try it on DS Lite via Supercard SD to see how it works, and then I will post a picture here, if there are any anomalies, of where it crashes. Okay?


However, I would like to know more about how to reproduce the problem when I have it.
Please tell me how you burn the ROM to SD and test it on the actual device.
Because if I can’t reproduce it, I can’t fix it.

If it were not so expensive, I would purchase the same device and test it.

If it doesn’t work on the actual device, then it’s not much of a reproduction of the mGBA.
Kaitou has a huge number of improvements in various areas with various optimizations and new features.
I use VBA-M, but I also try to check the novel new features with mGBA for confirmation.
By checking on two emulators, I had confirmed that the new features work stably, but that may not be enough.

1 Like

As for MyBoy for Android, before that unit’s battle animation appears, the game crashes to black screen, and freezes the entire smartphone, no longer being able to close the application. In any case, I don’t want to risk damaging the phone, and I would never play it on this device anyway. I hope others will test it on MyBoy and I would be glad if they prove me wrong.

On DS lite through Supercard things are worse; the initial title appears but if I start the game only a black screen with croaking sounds in the background occurs, and I cannot continue.
In my experience, it would seem to exceed the basic RAM available to the console, but I could be wrong.
I will try to attach a video if possible.

All the other full English F.E. Hacks on this site work, at least considering the early maps of each.
To copy the rom to the SD I use the Supercard SD’s own client software, which creates the files needed to save.
Perhaps other users can test it on this same flashcard or on ez-flash or gba-everdrive.

I see.
I am not sure of the cause, but I understand that there is a problem.
In the meantime, I will see if I can confirm a similar problem with other minor emulators.
At least with VBA-M, mGBA, and no$gba the problem does not occur.

I don’t remember exceeding the RAM limit.
However, we are moving the 0x0E000000 area quite aggressively to achieve sound room1000, so there may be some problem here.

1 Like

ver 20230327
I changed the no$gba debugger’s Xecpt setting to something tougher and fixed it until the guy stopped complaining.
I think stability has improved.

Does this version work on android MyBoy?

1 Like

Would the one complaining be me, then? :sob:
To say that is not very polite. I only reported a fact to help improve the game, nothing more. Anyway you could have left it as is, since no one else has complained and it works on other emulators.
In any case I will only be able to try it tomorrow on the DS console, the only one I use to play GBA roms: MyBoy honestly doesn’t interest me but I will still venture to try it later, as long as it doesn’t blow up my phone…:rofl:

That’s just a figurative expression by anthropomorphism. I hope you don’t mind.
Anyway, I fixed it until no$gba debugger stops complaining about it, so please try it later.

If this is still a problem, then the no$gba debugger’s Xecpt feature is not much help either.
This time, we know that the accuracy of mGBA is NOT at all trustworthy.
If it turns out that the no$gba debugger Xecpt is not to be trusted on top of this, I don’t know what we are supposed to live with.

1 Like

Good news. On MyBoy now the battle animations work properly, and during the first map everything seems to work excellently. It’s shaping up to be a F.E. Hack of epic proportions! Hopefully it will work on my dear handheld, one day. :+1:

Edit: Sorry, I misunderstood. I thought by “the guy” you were referring to me, instead you were pointing to that software. :rofl:

1 Like

Glad to hear it worked correctly.
The no$gba debugger Xcept seems to be more reliable than mGBA.

1 Like

Hi chief. Forgive yet another trouble of mine. Also this version does not work on DS console and crashes if I press start or if the demo starts. Maybe I have spotted the problem: once patched with my flashcard software the rom (English version of F.E.Kaitou) exceeds the maximum allowed size of 32Mb (in this case about 32.8Mb). To work on Supercard it should originally be at least 1Mb smaller, and then be patched and inserted into the micro SD. This is just a guess, maybe the problem is something else…
It is a pity that only this one does not work on real hardware, it would be interesting to understand why.
It would be helpful if other users would test it with this or other flashcards.

Kaitou does not exceed 32MB (0x02000000).


This is because windows explorer calculates 1kb as 1000, not 1024.
Therefore, I don’t think the ROM capacity is a reason for it not working.

I don’t know what the problem is at the moment.
Vanilla also does a lot of dangerous processing such as writing to null and references, so I can’t raise the level of Xcept any higher.
At any rate, in ver 20230328, I fixed two vanilla bugs writing to null.
I also fixed a little bit of string handling.
I don’t think this is why it doesn’t work on the actual device.

1 Like

Blade is too heavy to be used, so I removed Blade and created Mage Killer, InfantryKiller, and Devil Sword.
I don’t know yet if this will work, but I hope it will.

Mage Killer:


Devil Sword: