FE_Builder_GBA -- If you have any questions, attach report7z

Tags: #<Tag:0x00007f0e4366b7e8> #<Tag:0x00007f0e4366b6a8> #<Tag:0x00007f0e4366b5e0> #<Tag:0x00007f0e4366b4a0>

So I’ve just randomly found out that any killed unit on chapter 1 is revived for chapter 2. I don’t want this to happen obviously. Along with that, this is the only chapter this occurrs in (doesn’t occur in the chapters after_.

In the meantime, I recommend that you display the preparation screen on ch2, as that will solve the problem.

Your ROM is strange.
The normally does not remove the hidden flag when you LOAD1 a dead unit.
However, in your ROM, LOAD1 will remove the dead unit’s hide flag.
When you display the preparation screen, the dead are again set to the hidden flag and disappear.
I am not sure why it behaves in such a strange way.

However, if you write preparation at the very end of StartEvent of ch2, it will be solved, so it is recommended to use it.

I actually managed to figure out a solution, heck.
Turns out swapping it to LOAD2 will no longer allow the dead unit to spawn in.
I tested this by killing Allen in Chapter 1 and in the following cutscene in Chapter 2, he no longer appears.

Hi. I’m still learning about using this great program while I advance my hack. Is there a way to edit the kingdom names in Fire Emblem 8 in the very first opening sequence where they are shown briefly on the map? The names glow.

Just lookin through the questions thread as you do and saw this, figured I could answer it and give 7743 a break! (hopefully that’s allowed, not sure why it wouldn’t though)

first you go to image editor (don’t mind me using an edited rom as an example, it’s the same method)


next you click on world map image

then you go to ‘border’ from there you can see the different images used for the cutscene

then you just import your own image and that’ll be what shows up (do be aware of the size restriction and color limit though)

2 Likes

So the names are actually on the map itself? Ok, thanks for replying. This is gonna be helpful. I can just insert my own map with the names already written on it.

1 Like

if you need any more information on specifically world map stuff I highly recommend PentV’s amazing tutorial on the traversable world map, as a general rule of thumb when looking at general questions like how to do something, there’s probably a great guide on it or it’s been asked in a question thread before, checking those can save both you and 7743 time.

1 Like

Gotcha, I’ll search for those before I put up a question.

1 Like

Hello, I have an issue with class 01. When battling, it softlocks the game for some time, then it proceeds to battle normally with animations turned off. I’ve never encountered this error before, why does it happen? Can this problem be fixed?

The conclusion is that the Custom Animation Patch is corrupt.
Please set this data to null.
That should fix the problem for now.

Fix:

Didn’t you rebuild before?
The data structure in your ROM appeared to be the rebuilt data.

I think the data with the invalid pointers may have interfered with the rebuild.
I think the data in the list has been torn off.

As a result, invalid data was written, and that data was accidentally registered as the Custom Animation setting for class 0x01.
However, this data does not work because it has an invalid pointer.
Therefore, the game will freeze.

Here is the proof:

So the countermeasure is to scrape the data and put clear terminated null data in the list.

If the problem was caused by rebuilding, it is strange that this was not found in the test play.
Was this unit not there at the time?

1 Like

What…? No, I don’t remember rebuilding this specific ROM. I have rebuilt another ROM, but I scrapped that project due to badly managed memory space, this is not a rebuilt rom, I swear!
Now I’m going to check if I can replicate what you just did.
Also, this unit was the second one I created, this problem literally came out of nowhere.

If so, it’s just my imagination.
Don’t worry about it.
Anyway, the problem is that this Custom Animation Patch is broken.

1 Like

Thank you, you were right. I uninstalled the old version and everything went back to normal. You’re the best.

Hello - I have a quick question that I am hoping has a simple answer. I want to press Select to show Growth Rates like in the SkillSystems patch, but I don’t want to install this patch as I don’t want to use skills in my FE Hack and this patch is quite extensive on that. Is there a simpler patch/method to get this done? I don’t need fancy colors or anything (though that’d be nice also), I just am looking for the most basic method to display Growth Rates when pressing Select. Thank you for your time.

Probably it impossible.
MSS is part of Skill Systems, so I don’t think it’s separated.

This is the original growth display patch for FE8:

Install with event assembler.

2 Likes

Thank you so much!

I’m having an issue where Morva cannot equip his ‘Wretched Air’
I’ve changed very little about Morva or this item, so I expect a patch (or my incompetence) is to blame
Thank you for any assistance

Report.7z

EDIT: Solved, thank you knabepicer.

Having not looked at your report, I would guess that you installed skillsys. In vanilla, Wretched Air requires A rank in monster, and the monster weapon lock has hardcoding to ignore this restriction. Installing skillsys removes this, so the weapon becomes unequippable. Simply reduce the weapon’s rank.

4 Likes

Aha, thank you! When comparing with other monster-type weapons I only saw that they too display an ‘A’ requirement but didn’t notice they all have a 0 value. That indeed fixed it.

Hey bro, I want the enemy to appear every turn, what should I do bro
I know each of these ways but it’s not very optimized.
sorry about my grammar because i use google translate it seems confusing.


If set from turn 1-255 it doesn’t work.