FE_Builder_GBA -- If you have any questions, attach report7z

Hello, I’m back here again lol
So I’m working on a new project of making FE6 in the FE8 engine and I’m just having an issue with the world map. Basically, completing the first chapter (Breath of Destiny), the game intro plays even though I believe I fixed it. I know I had this problem before but I wasn’t able to figure it out.
Another issue occurs as well which I hadn’t seen before where finishing the intro from the problem before, pulls up I believe a transition between Chapter 1 and Castle Frelia from the base game, which I had never seen before. It randomly stops at the end and can only be skipped to move on. After skipping it, it places you in chapter 1, not the prologue. Completing this then puts you on a black screen, which is fixed by going into the unit menu.
How can I go about fixing this?
Also as usual, here is the 7z report.

How about using MNC2 instead of MNCH?
World maps are difficult and should not be used by beginners.

I’ll try that out then!
Already been trying out a World Map and it was somewhat confusing

Hello, 7743! hope your doing great! I’m new here, this is my fist time here, so Hello! Uh, I was hacking FE8, and I was messing with the world map event’s, and When I get to chapter 6 and click on Jehanna hall on the world map, it take’s me to a skirmish instead of the chapter 6 I set up! I’m very new to how Febuilder work’s (For about two Month’s.) But I know how all of the basic/advance stuff there. Is this where I put the report 7z file?

I don’t know where to put it. Sorry if that’s a dumb question, I’m new here. :slight_smile:
Oh and, thank you soooo much for crafting Febuilder 7743! it’s the whole reason I’m here!

I like the portrait on the left Ent! Nice!
Is it Free To Use? Am I asking the wrong way? I don’t know, I’m new here!

Check out https://feuniverse.us/t/ultimate-graphics-repository-new-update-now-using-github/3326/3658 for F2U mugs, animations and other cool stuff.

1 Like

Thank you! You guy’s and gal’s, making amazing work’s of art for a random guy on the internet like me, is, wow!

Glad to meet all you btw, I hope we can be friend’s…

1 Like

how do i delete the animation added
My English is not good, so I use google translate so please understand

I don’t know the details without report7z.
However, it may be improved by changing the setting of that chapter in “map loading process” of the detail menu.

Basically, it cannot be erased.
You can only overwrite it.

If there is not enough space, rebuild will collect the fragmented free space.
Rebuild is risky, so consider if the ROM exceeds 30MB.
Please refer to the Help for more information.

1 Like

my hack is over 30mb so i cant add animations so i want to remove it
anyway thanks bro

1 Like

Is there anything that reduces the size of the rom bro?

1 Like

In that case, please be prepared to REBUILD.

That dangerous feature is located in the bottom right corner of the advanced menu.

Be sure to get a backup before you rebuild.
After rebuilding, run the game from start to finish to make sure everything is OK.
Please note that rebuild cannot fix broken ROMs.
If you have added a weird ASM, the rebuild may fail.
In that case, reinstalling the added asm after rebuild may work.

It is recommended that you submit report7z before rebuilding.

My hacked version just finished chapter 1, so is it ok to play only chapter 1 bro

If it’s over 30MB in that situation, it may be faster to start over.
If you’re only making one chapter and it’s over 30MB, you’re doing a lot of wrong things.
I think it’s faster to rebuild from vanilla ROM than to take the risk and rebuild.

1 Like

Mostly I add a bunch of animations
because it’s my first time so i don’t know rom is limited so i just add animation =)

1 Like

Ok, will try that, i got the report7z file here so if it does not work, then i’ll send it!

Thank you SOOOOOOO MUCH!!!

It worked! Thank you thank you! thank you times 100!

1 Like

Hi! It’s me again! Uh, another bug, when I beat chapter 6 of my FE8 romhack.
It takes me to the save screen then when i save, it skip’s chapter 7 to chapter 8 instead!

Then, right when the save screen is gone, it freezes.

I’m sort of a noob at the world map, (since it’s causing me all of my problem’s) I was only learning from reading PentV’s traversable world map guide.

You would get an answer much faster if you asked in the discord. There’s a link that i think is pinned on the main page.