FE_Builder_GBA -- If you have any questions, attach report7z

Ok, will try that, i got the report7z file here so if it does not work, then i’ll send it!

Thank you SOOOOOOO MUCH!!!

It worked! Thank you thank you! thank you times 100!

1 Like

Hi! It’s me again! Uh, another bug, when I beat chapter 6 of my FE8 romhack.
It takes me to the save screen then when i save, it skip’s chapter 7 to chapter 8 instead!

Then, right when the save screen is gone, it freezes.

I’m sort of a noob at the world map, (since it’s causing me all of my problem’s) I was only learning from reading PentV’s traversable world map guide.

You would get an answer much faster if you asked in the discord. There’s a link that i think is pinned on the main page.

Sorry for the late response, um, I’ve never used discord.

So uh, yeah. :neutral_face:

When I beat chapter 6 and the save screen show’s up.
it skip’s to chapter 8, then freezes.
I might of messed something up in the world map event’s.

As it turns out, you need to change the Chapter ID of Worldmap Node14 Castle Renais from 9 to 8.


Here is the explanation.

World maps are difficult.
Apparently, the problem hangs when you try to make a monster or some other sprite appear on the world map.
This is not a problem with MNCH, but with MNC2, so it is definitely a world map problem.
When I installed a patch to disable the monsters, it managed to work but did not show the way to the next chapter.
Therefore, we have determined that the problem is in the WorldmapNode settings.

So, I took a look at your ROM settings and noticed the above mistake.

First, look at the current Node, Node 0x06 Jehana Hall.
The Next World Map Node ID is defined to be 0x14.

Now let’s look at the settings for Node 0x14.
If we look at the Chapter ID of Node 0x14 Castle Renais, it says Chapter ID 0x9.

Now we are at MapID 0x07 and the next map should be MapID 0x08.
Therefore, the Chapter ID 0x09 is wrong.

Changing it to the correct ChapterID, 0x08, solves the problem.


I’m not sure why that would cause this hangup.
It could be that I’m running a WorldmapEvent with ChapterID 0x09, or it could be that I referenced an unrelated node and read some weird data.
Either way, this fix will fix the problem.

As I said before, Worldmap is very difficult because of the multiple settings that depend on each other.

1 Like

Thank you sooo much man!

You’ve been a lifesaver!!

Now I have the energy to make my romhack again!!


Edit: Can I take down the Report 7z file now?

1 Like

Edit: Can I take down the Report 7z file now?

yes, you can delete it.


Thank you for confirmation!

I already deleted it!

Thank you so much!

1 Like

Hello! Once again! a problem! not as major as the the two other one’s but I do have a problem!

As you know, classes a little icon next to the weapon.

But for my knew class, Hvy. cavalier, normal enemies aren’t equiping there weapon’s!

I set there battle animation’s, nothing! I set there weapon level’s on there class, nothing!

If you already have the report 7z file, use that one!

I did not make any change’s that would effect this problem.

1 Like

Hi 7743,

I would like to use the Rebuild ROM feature to reduce the file size as it’s near the limit. However, when I do I get an error: ‘Routine Pointer is missing. Number of rows: 4342’

Here is a link to the report7z:

Thank you for help.

1 Like

The error was not reproduced.
For the time being, I was able to rebuild.

//To be on the safe side, the free space in the lower area is not used.
//If you use it, it may be about 1 or 2MB smaller.

However, a lot of error logs were output in the rebuild log.
But the game seems to be working.
I’m not sure.

But the game seems to be working.


In order to accept this rebuild result, you need to play the game from start to finish and make sure everything is fine.
If there is a problem and you cannot fix it, then you need to discard this result.
So please think carefully about whether you want to live with this result or not.

Please attach report7z.
You need to advance the game to where the problem can be identified and then create report7z.
This is because the report7z will contain the save data at the same time.

If you have any concerns about reproducibility, please send your save data at the same time.

Oh, that’s strange. But thank you for Rebuilding the ROM!

I’ve been play testing and the game runs fine- the only error I can really find is the Drums have been replaced with pitched instruments on most of the imported songs. However I can’t seem to fix that. I’ve tried reinstalling the drum fix, All Instruments, Native Map, etc.
Any ideas?

Thank you again. You’ve been wonderfully helpful.

Specifically, which SongID and what track number’s drum is the problem?

In this case, you need to be specific so that we can help you.
This is like calling an ambulance without giving an address.
I can’t help you because I don’t know where to go to rescue you.

Ah very sorry. I should have known better.

There’s a lot of them. I’ve gone through the list and tried to identify them all. These all had working drums before, so I’m hoping it’s a simple fix that I’ve overlooked. You can find examples of the drums being a pitched instrument in these song IDs:

5E, 5F, 92, 93, AE, C6 , E9 , 116, 12E, 166, 167, 13A, 1B5, 1B6, 1B7, 1BE, 1BF, 1C0,. 1C1, 1C8 , 1C9, 1CA, 1CB, 1D2, 1D3, 1D4, 1D5, 1DD, 1DF, 1E6, 1E7, 1E8 , 1E9 , 1F0, 1F1, 1F2, 1F3, 1FA, 1FB, 1FC, 1FD, 204, 205

I tried rebuilding.


This is due to the fact that ALL instruments are corrupted in the ROM before rebuild.
Because of the presence of strange instrument data at 123 and 124 of the data, it was determined that this was the end of the line, and the list of instruments was torn off in the middle.

For now, I fixed this problem by adding appropriate data.
However, to do so, I had to redo the rebuild.

I redid the rebuild, but I don’t know if it works properly.
For now, I have confirmed that the combat works correctly in the beginning chapters.

You will need to test again.

1 Like

Hey man, can you help me with this problem?

The error means that the files that make up the EA cannot be read.
I recommend that you reinstall the EA using the InitSetup Wizard.
MENU->Settings->Init Setup Wizard

If that doesn’t work, try reinstalling the EA manually.

Thanks bro, it seems the EA link is a bug so it’s wrong
I chose a new EA path and it worked
Thank you so much bro