Weird Glitch in a hack I'm making

So just for fun I was working on a side project where I replace the FE8 cast with the FE9 cast, and I can’t figure out what I did wrong but it keeps giving player units random skills even when none appear there in FEbuilder. And even weirder, if I look at a characters’ skills in and then leave that page and come back, the skills change. I’ve tried undoing pretty much everything I did the past two days but I can’t seem to fix it. Does anyone know what’s causing this and how to stop it?

Try the diff debug tool, and if that doesn’t work, revert to automatic backup.

However, since you probably don’t care to read the help and instructions, I think it is easier to restore from automatic backup.
The backup 7z is made in the same directory as the ROM.

If you use the diff debug tool, I think you can solve that kind of problem in 10-30 minutes.
but you will need to learn how to use it a little bit, so it is better to restore from automatic backup.

If you are willing to read the manual, there is help here, so please read it properly and attach report7z next time.

Help TOP


diff debug tool

This is a common glitch related to WeaponrankEX patch, did you install/uninstall that?

I used the debug tool and it worked thank you

1 Like

I had something related to weapon ranks installed but the diff debug tool worked. thank you tho.