Walking Sounds


So, what determines which walking sound is used?
I’m trying to make a custom Black Pegasus class for Schwarz in 0x8D. I’ve copied everything in the Class Editor from the standard Pegasus Knight class, but instead it uses a horse rider walking sound (the one for cavaliers, etc.). So, what should I do in order for it to sound like a peg knight?
I’ve also applied Nintenlord’s patch back in the day, btw.

Reading the source, I would guess that you need to go to offset be4b4 and write a pointer to a the table provided, which presumably has pointers to all the sound effects for walking. I would imagine that this table is organised by class ID such that the first pointer is class 0x00, etc.

Oh geez. Someone should make a Nightmare module for that D:
It’s not exactly handy…

–Nothing stopping you from doing it, Freddy!–

Nightmare modules aren’t exactly my thing… XD
Oh well.

Lazy bastards. I’ll make the module for you.
Reminder to pronounce the L in walk.


Sweeeet~ <3
Thank you so much, Lisandra! ^^
Now I just need to make an FE8 version when I have the time.

All you have to do is change line 3 from 0xD70000 to wherever the table is in the FE8 version (by default, according to the source, pointerTable=0x01000000). Or, if you feel like a wizard, you can plonk the table anywhere you have 400 bytes of consecutive free space.

1 Like

so i just tried to insert this aaaand now every walking sound in the game is Athos’s battle theme.


I have no idea how to fix that.

But that sounds awesome.

lol but seriously

NUPS wasn’t letting me patch it properly either. it said the patch didn’t match the file…

because the patch was designed for a vanilla ROM?

i was told that was the case. what should i do then? I tried patching + checking ignore or whatever. all the walking sounds got mixed up/ athosified

where does it say the pointer table gets written to in the patch description?

patch description… like a readme? There isn’t one

but if i open the source in notepad it says this stuff



.org 0x6caf8
push {r4,r7,lr}
add sp, #-0x14
mov r7, sp

str r0, [r7, #0x0]
ldr r1, [r7, #0x0]
add r0, r1, #0x0
add r1, #0x41
ldrb r2, [r1, #0x0]				@loads Class ID
ldr r1, =pointerList+0x8000000	@at offset 6CB70
lsl r2, r2, #2
ldr r0, [r1, r2]
str r0, [r7, #8]


idk if that’s helpful :s

soooo why don’t you try following the pointer trail? what do you think D70000 means, especially having read my earlier post? what do YOU have written at D70000?

i zero’d out everything at d70000 (it was just events) and then applied the patch/ checked ignore.

the data got written there.

then i tried giving the reinserted Wyvern rider the wyvern walk with lisandra’s module.

can you screenshot the data written to D70000?

and it’s still playing athos’ theme? I’m pretty much at the end of the line here without my desktop, maybe someone like @CT075 wants to help?