UltraxBlade's #febuilder-help FAQ

Is it OK to use this asset I found in someone else’s hack? (ANSWER: Not without permission!)

See here for the full FEU credits policy.

See here for the full FEU usage permissions and plagiarism policy.

To rip assets from someone else’s hack, whether it be art, music, maps, code, anything, without their permission is art theft and violates FEU’s plagiarism policy. If you see something in someone else’s hack that you want to use, check the Resource Repository. Anything in the Repo is Free to Use (F2U) so long as you credit its creator. If it is not in the Repo, you can try asking the artist/the creator of the hack, but until you receive permission to use it, all assets you see must be assumed not allowed.

Is it OK to edit this asset I found in the Repo? (ANSWER: It depends.)

See here for the full FEU credits policy.

See here for the full FEU usage permissions and plagiarism policy.

All assets in the Repo are Free to Use (F2U), but cannot be assumed Free to Edit (F2E). There are, however, exceptions:

  • A F2U asset that is not F2E can still be freely recolored, so long as you are not making changes beyond the colors.
  • All Animations in the Repo are Free to Edit by default.

For other resources, as before, ask the artists. Many are, in fact, openly F2E or willing to give permission by request, but simply aren’t labeled. You just can’t assume as such without asking.

How should I credit the creators of art and code assets in my WIP project? I don’t have end credits yet!

See here for the full FEU credits policy.

See here for the full FEU usage permissions and plagiarism policy.

Don’t worry, you don’t need to add credits in your hack itself before the end credits are reached. A credits document linked from your hack’s page alongside the download link is perfectly sufficient. The important part is that you credit everyone whose work you used. It’s also nice to credit people who helped you with the process, even if they didn’t directly make things. Like someone who helped you with a design issue, or who showed you how to do basic ASM. Or maybe the guy who answered all those FEBuilder questions for you on Discord, he seems pretty cool.

How do I check what patches I have installed in FEBuilder? I realized I’ve been forgetting to credit their creators!

See here for the full FEU credits policy.

See here for the full FEU usage permissions and plagiarism policy.

While people give more attention to crediting art, code assets should be credited too, including all of the many patches you install through FEBuilder. I highly recommend keeping your credits document up to date as you go, so you don’t need to go back and dig up every patch you’ve installed to compile it later. But if you’ve been forgetting, typing an exclamation point ! in the patch list search bar will show all the patches you’ve installed.

Do note: FEBuilder’s check for whether a patch is installed searches for a particular signature at a certain place in the code of your ROM. That signature is often the same for different versions of the same patch, so all the versions read as “installed” even though you only installed one of them. So don’t be surprised if you see multiple versions of the same patch pop up as “installed” when searching this way.

5 Likes

My character’s portrait is getting cut off at the edges when I import it.

Your portrait is likely getting cut off by what’s known as the hackbox, an area of the portrait image that isn’t actually usable normally. Here’s some standard templates that show it:

correct portrait alignments image portrait template

Those areas in the upper-left and upper-right of the portrait box can’t actually be used in vanilla. But if needed, there is a patch to allow you to exceed the hackbox by a bit:

Patch Name:Exceed The Portrait Hackbox By 4 Tiles @FE8U
Author / Source:tiki [FE7] Exceed the Portrait Hackbox Compatability:aera

How does the Exceed Portrait Hackbox patch work?

The exceed hackbox patch doesn’t fully eliminate the hackbox, but it allows you to go a bit outside of it. Specifically, it gives you two extra 16x16 squares you can position outside its bounds. Here’s how you set it up, using an example from my hack.

(Note: installing this patch does not have any negative effects on preexisting portraits, nor does it require making any changes to their settings. There is a field you have to enable on a given portrait for it to use the exceed tiles in the first place, which defaults to off.)

You have to break the area that clips out of the hackbox into two 16x16 tiles aligning to an 8x8 grid, much like how mouth and eye frames do. You know how there’s an unused space in the bottom-right of a portrait image? You put those two tiles there.

image

Once you import the portrait, set “mug_exceed” to 1 to make them appear and access the settings to move them around. Set the coordinates so they align as needed.


And there you go! Your portrait now fits where it previously couldn’t.

Worth noting: you can extend a portrait to the right with this! It won’t show in Builder’s preview, but you can place the tiles out of bounds to extend a portrait to the right of the hackbox.

Also, an exciting piece of tech: the coordinates the patch uses are actually read as signed values in 2’s complement. What that means is 255 is -1, 254 is -2, 253 is -3, and so on. This means you can actually extend up and left too!


Hair extension added with two tiles at Y=254, aka Y=-2

7 Likes

Thank you so so much for this. I could kiss you right now. This is a godsend.

3 Likes

I’m having trouble understanding the AI settings in the Unit Placer. How do I make an enemy rush you, wait until you’re in range, not move at all, steal treasure, run to escape, etc.?

In the Unit Placer, you’ve probably noticed how each unit has multiple different components to their AI.
AI1 and AI2 define how a unit will attack and move. Usually, AI1 controls attacking, and AI2 controls moving. AI1 will always take priority over AI2, so if you have AI1 set such that the unit will attack anything in their range, they will move to attack something in their range even if AI2 says “do not move”. If AI1 does nothing, the game then defaults to AI2.
AI3 has two components: healing AI, which controls when an enemy will switch to healing mode and seek out healing, and targeting AI, which determines how a unit chooses who to attack.
AI4 has to do with whether or not enemies are fully stationary, and determines whether a unit in healing mode will run away or not.

Now, I won’t go over every single AI setting here, but generally speaking, the important ones are:

AI1
“chance of action 100%” means they’ll move to attack anything in their range, or take other actions available like using staves. This is the most common AI1 setting.
“chance of action 100% attack only if adjacent” means they’ll only attack if they can do so without moving. This is mainly used for stationary enemies. If you put it on an enemy with a moving AI2, the result will be that they either move OR attack, but not both.
“do not act (move only)” means they won’t attack at all. Use this for units who are moving towards objectives without attacking, like running thieves.

Anything with chance of action less than 100% and greater than 0% should probably be avoided, it causes the enemy to have a random chance to do something or not do something and is very frustrating to the player as a result. (“Why did that enemy not attack me last turn but attack me this turn?!”)

For the love of Naga do not use “attack if in half range”, it’s extremely deceptive. Enemies on this AI will only attack if there is a target reachable within half their movement range – HOWEVER, if there is such a target, they will move to attack anyone within their full movement, not just the unit(s) within half range. There is no way for a player to naturally tell that an enemy will only move once you’re within half their range, and even if they know that, they likely won’t know that getting within that range will cause the enemy to move full move to attack.

AI2
“move towards enemy” is aggressive AI, and will rush towards you.
“do not move” is “wait in place until AI1 tells me to do something”. Combining it with attack-only-when-adjacent AI1 is how you make stationary enemies, while pairing it with the normal “chance of action 100%” is how you get enemies that wait until you’re in range.
“if possible to attack in 2 actions, move towards enemy” will cause them to only become aggressive once they can reach a target in 2 turns from their starting position.
“wait one turn, then set AI2 to 00” will stand still for one turn (unless AI1 says to do something), then switch to rushing the player.
Most of the rest here are self-explanatory – go after villages and chests, move to destroy walls and snags, run to the escape point, etc. Remember that AI1 takes priority, so an enemy set to attack will prioritize attacking the player over breaking walls or stealing treasure.

A note on “move to escape point”: this obviously requires an escape point on the map. Escape points for enemy units and NPCs are set separately on a per-chapter basis. You can find the escape points editor linked from the Chapter Editor, in the bottom-left corner.

AI3 Healing AI
The thresholds you set here determine when healing AI activates and deactivating. Each setting has an recovery mode activation threshold and a return/deactivation threshold, with healing mode activating once a unit falls below the activation threshold and deactivating once they’ve regained enough HP to be above the deactivation threshold. Enemy healers will only heal targets who have activated their healing AI, and enemies will only use Vulneraries if their own healing AI is activated. Enemies with activated healing AI will run away towards sources of healing, or run away to use their healing items, only if they can get out of the player’s range while doing so.

AI3 Target AI
These change how the enemy prioritizes who to target when they have multiple targets in range. The parameters can be tweaked if you know what you’re doing, but my honest recommendation if you don’t have a specific reason for messing with this to just use the standard one, setting 08 “PrioritizeLowHP” (formerly labeled as “PrioritizeDamage (Standard)”), which is the typical “target the unit I can do the most damage to” behavior you’re used to in the GBA games. There’s more detailed documentation out there if you want to get into the details.

AI4
In short: use “Retreat” if the enemy can move, use “Don’t Retreat/Boss AI” if the enemy can’t move.

“Retreat” is used for normally-moving enemies, and will cause them to retreat towards healing when AI3 healing AI activates. They will retreat towards healing tiles or enemy healers, or simply run away while trying to use a vuln. However, they only retreat if they can get out of the player’s range while doing so, hence why you don’t see enemies constantly running away when on low health.

“Don’t Retreat/Boss AI” is for stationary enemies ONLY. It causes enemies to not retreat towards healing when their healing AI activates, but still be targeted by healers and use healing items without running away. It’s also what’s used to nullify movement range display with SkillSys – setting AI4 to this setting with SkillSys installed makes an enemy entirely unable to move or be moved, and will display as such when checking their range. Without SkillSys, it doesn’t fully prevent moving, but setting it for a moving enemy has weird and unpredictable results including not attacking, so you should not to set it for an enemy that isn’t stationary.

Common combinations:
“Rush the player”: AI1 chance of action 100%, AI2 move towards enemy, AI4 retreat
“Wait until something’s in my range”: AI1 chance of action 100%, AI2 do not move, AI4 retreat
“Stationary, never move, attack things that get close”: AI1 chance of action 100% attack only if adjacent, AI2 do not move, AI4 Boss AI
“Steal treasure then run away, no attacking”: AI1 do not act, AI2 attack villages/treasure then move to escape, AI4 retreat
“Attempt to destroy villages, but attack if there’s a target”: AI1 chance of action 100%, AI2 attack villages/treasure then move towards enemy, AI4 retreat
“Escape without doing anything”: AI1 do not act, AI2 move to escape point, AI4 retreat
“Stand still and do nothing”: AI1 do not act, AI2 do not move, AI4 Boss AI

5 Likes

The text box in this conversation is glitching out. It’s extending off the edge of the screen and wrapping around, and the text isn’t all showing up. What’s wrong?

This kind of error is usually caused by exceeding the maximum text width. Usually, Builder will give you a warning when your text is getting too long, so please, as with any warning Builder gives you, listen to those warnings when they show up. However, actually exceeding the maximum width on one line isn’t the only way to exceed the maximum width. My most likely guess for what’s actually happening for you is that you have a character talking twice back to back from the same position, without closing the text box in between. What does that mean? Here’s an example:


In this edited version of FE8’s opening, Seth speaks twice in a row from the same portrait position in two separate “character talks” commands, resulting in the screenshot above. The game doesn’t actually close the text box in between, and instead tries to continue the next text right where it left off, exceeding the maximum width in the process. The game looks ahead to calculate the text box width based on the longest line before it closes, and this doubled-up line spills over.

You may be thinking “well, I don’t have anything like that going on. Why would I ever split it into two text blocks like that?” Well, it’s a little trickier than that. These all produce the same result:


Gilliam’s portrait here is being loaded in the same position as Seth’s.

None of these actually close the active text box. Only having a different position speak or erasing the active position’s portrait (not moving to a different position, not loading a new portrait in that slot, specifically erasing that position with the erase command) will do it inherently. However, there is something you can do to tell the game to close the text box: [CloseSpeechSlow]. The [CloseSpeechSlow] command can be inserted in text, usually at the end after the [A] wait for button press, to close the active text box, like so:

And now it works properly!

4 Likes

How do I make weapons only usable by one unit/class? How do vanilla weapon locks work?

There are two methods of making weapons restricted to specific characters and/or classes: the vanilla weapon locks, and the WeaponLockArray patch included with SkillSys. Let’s start with the vanilla method.

On every weapon, unit, and class, you’ll find checkboxes at the bottom for various “locks”. Eirika lock, Ephraim lock, etc. You can check any number of these for a given item, unit, or class. There are seven of them in total:

  • Eirika Lock, which by default is used for the Rapier and Sieglinde, and for Eirika’s Lord and Great Lord classes
  • Ephraim Lock, which by default is used for the Reginleif and Siegmund, and for Ephraim’s Lord and Great Lord classes
  • Lyn Lock, which is unused in vanilla FE8 but fully functional
  • Athos Lock, which is unused in vanilla FE8 but fully functional
  • Weapon Lock 1, which is unused in vanilla FE8 but fully functional
  • Myrmidon/Swordmaster Lock, which by default is used for the Shamshir, and for the Myrmidon, Swordmaster, and Assassin classes.
  • Monster Lock, which by default is is used for monster weapons and monster classes.

Monster Lock has additional hardcoding to it, however. First of all, it hides weapon stat displays, which can be fixed with this patch:

Patch Name:Monster Weapon display fix @FE8U
Author / Source:Brendor FE8 Monster Weapon Display Fix

It also, however, disables Hammerne use, regardless of whether the “disable Hammerne” checkbox is checked, and WEXP gain, regardless of the weapon type or set WEXP value.

Any weapon with one or more locks checked can only be used by a unit that has those same locks set somewhere between their unit data and their class.

So, for example, here I have the Twilight tome with the Eirika Lock and Ephraim Lock checked. It can only be used by a unit who has both Eirika Lock and Ephraim Lock checked on either their unit data, class, or both. (Can also be one of the locks set on the unit and the other set on the class, I think, so long as they have both when combined.)


Here, this unit, Elys, has no locks set to her character data. However, her Lord class has both the Eirika Lock and Ephraim Lock checked. Therefore, as long as she is in that class, she can use the Twilight Tome.

Usually you’ll only need to use one lock at a time. Ex. vanilla just has Eirika’s prfs locked to Eirika Lock, with the lock set for her classes. But if you need a lot of different prfs, you can combine the different locks to get more different combinations (I currently use two at a time in my hack, so Eirika-Ephraim, Eirika-Lyn, Ephraim-Lyn, and so on). If you need even more than that is where the patches come in.

I need more weapon locks. How does SkillSys WeaponLockArray work?

The SkillSystem includes a function called WeaponLockArray, which can be accessed from the patches list. It allows you to create as many different weapon locks as you could possibly need, with the ability to define locks for character sets or class sets, as well as “hard” variants (only the specified characters/classes can use it) and “soft” variants (other units can use them but require a weapon rank, while the specified characters/classes can use the weapon as if it were rank E).

Be warned that WeaponLockArray is broken in some older versions of SkillSys. If you’re using an older version it may not work at all, and soft weapon locks may still be nonfunctional even in the current Builder SkillSys version. The multiple locks method described above always works and should give enough locks for most hacks.

NOTE: The “Show Prf only” checkbox in the Item Editor must NOT be checked when using WeaponLockArray to lock a weapon, otherwise the weapon will be unusable. Don’t ask me why, I don’t know.

To lock a weapon with WeaponLockArray, you first have to create data for a weapon lock. With SKillSys instealled, find “WeaponLockArray SkillSystems” in the patches list to bring up the editor. Choose one of the “EMPTY” slots in the array and click “Allocate New” to create new data. Once data has been created, you can click “WeaponLock” next to the address to get to the editor for that entry.


Within that editor is where you set the specifics. The first entry defines what type of lock this is. Enter a 0 for soft character lock, 1 for hard character lock, 2 for soft class lock, or 3 for hard class lock.

The rest of the entries in the list are the IDs of the units or classes you want to be able to use this weapon.

Finally, back in the Item Editor, in the bottom-right, you’ll find a field to set the ID of which WeaponLockArray entry to use.

If you have a version of SkillSys with functioning WeaponLockArray, the weapon will now behave according to the lock data you set up.

Can I apply weapon locks to items and staves as well?

Yes, with this patch:

Patch Name:Enable Locked Weapon Prf constraints on staffs and items as well. @FE8U
Author / Source:7734 Originally by Tequila, jjl2357

Do note that this will not work for Lockpicks, and by extension it may not work for keys. But it does work for staves, dancer rings, and standard items used with the Use command. I also do not know if this works with WeaponLockArray or only with vanilla weapon locks.

7 Likes

My custom class is playing the wrong sound when it moves, how do I fix it?

In the Advanced Editors window, you’ll find the Movement Sounds editor, which has a list where you can change the footstep sounds of each class. However, vanilla doesn’t actually read from this list in a way that’s easily understandable and editable. Apply the following patch to fix it:

Patch Name:Fix PlaySoundStepByClass HardCode @FE8U
Author / Source:7743

Once you do that, go to the Movement Sounds editor, click Data Expansion to expand the list, and set the footstep sounds for each class accordingly. Beware: some of the vanilla classes will be set incorrectly in the list after applying the patch, so double-check to make sure it’s all set right!

5 Likes

I’m having trouble finding a patch in the patches list. What’s the name of the patch? (Tips for using Builder’s search function.)

Please. I don’t have patch names memorized. No one does. When I give you the exact name of a patch, I’m using the search function to find it, which means you could just use the search function yourself. But since people seem to struggle with this frequently, here’s some tips:

  • Search for relevant keywords, like “support”, “supply”, “event”, “background”, or “heal”. The search function in the patches list searches both names and descriptions, so you don’t need to match the exact name. Focus on using words that you know will appear in it.
  • Keep your search phrases short. The search function looks for things that match everything you tell it, and it doesn’t necessarily recognize synonyms. If you can’t find a conditional support-preventing patch with a search like “prevent support”, cut the word “prevent” and just search “support”. A less-restrictive search will find more results, while still narrowing the list down to a length you can scroll through. (You’ll find that the patch in question is called “prohibit support”, in this case.)
  • Try a few times with different keywords. Just because it doesn’t come up the first time doesn’t mean it’s not there, it might just mean you searched for the wrong keyword. Try different words related to what you want. (Of note: a good amount of FEBuilder was translated from Japanese to English through machine translation, hence some oddly-phrased names that can take a few tries to hit.)
  • As you get more familiar with the patches, you may start to notice patterns in how they’re named, such as anything that adds an event command having “Add Event” at the start of the name, or all of the patches that fix spell animation sound effects starting with “fix sound”. You can use those as search terms.

Additionally, next to the search bar is a button labeled “Filter”, which allows you to filter the list to only show patches with certain tags. You can also run these searches by typing the tags manually as part of your search.

The tags are:

  • ! for already-installed patches.
  • #IMAGE for images, like the stat screen background. Certain standalone images are accessed and inserted from the patches list instead of other editors.
  • #SOUND for audio, like setting the background music for various parts of the game.
  • #ENGINE for patches that modify the game engine – this one’s not too useful as a search because it applies to so many things.
  • #EVENT for patches that add event commands.
  • #ESSENTIAL or #ESSENTIALFIXES for patches that apply important bug fixes and the like, most of these are things you should just install in general.

If you really can’t find a patch that you know exists, ask and someone can probably help you find it, but it saves everyone’s time if you can find it yourself.

5 Likes

I hear certain flags have special effects when enabled with SkillSys. Which flags do what? Which are safe for me to use?

Global Flag 0xEE disables pop-up damage numbers in battle animations.
Global Flag 0xEF enables Fixed Growths Mode, which removes randomness from player leveling.

While not included in all versions of Builder’s default SkillSys, one version of the Casual Mode patch uses Global Flag 0xB0 to enable Casual Mode, and I hear the GitHub version of SkillSys bundles this in.

Also not a SkillSys function, but there is a patch that uses Temporary Flag 0x27 to make green units hostile to the player, so if you’re considering wanting that functionality in your hack, avoid Temporary Flag 0x27 as well.

Aside from that, any flag named “Temporary Flag XX” or “Global Flag XX” is unused in vanilla, and I can’t remember any other major patch conflicts – but of course, make sure to check patch descriptions.

5 Likes

How do I change chapter titles? I changed the chapter title, but it’s still showing the vanilla title in the chapter intro.

The vanilla chapter titles are stored and displayed as image files, so whatever you type as the “chapter name” in the Chapter Editor is not actually used for them by default. You could edit those images if you want to do something fancy… but if you don’t want to take forever and don’t mind using the vanilla chapter title font, there’s the Convert Chapter Titles to Text patch.

There are two versions of the patch. Version 1 will just display whatever you’ve set for “chapter title” in the Chapter Editor and only whatever you’ve set there, meaning if you want chapter numbers you have to include that there. Version 2/2.1 will also add in the chapter numbers, with an editor in the patches list where you can designate specific chapters to display something else in place of the numbers (ex. “Prologue” or “Final”).

How do I change the prologue to instead say chapter 1? I’m using chapter titles as text but it won’t show the number.

Chapter titles as text v2/2.1 has an editor where you set alternative displays instead of numbers for specific chapters. By default, it starts with entries for prologue and final. Find the patch’s editor in the patches list to change/remove these entries.

5 Likes

What do the different unit load commands do?

As you may have noticed, there are quite a few different unit load commands in the event editor, and they all do slightly different things. Most of these commands use one of three different load types: LOAD1, LOAD2, or LOAD3, which you’ll see in parentheses at the end of the command description.

LOAD1 commands are generally used for loading units who are actively involved in gameplay. It’s used for loading player units who join the party, and enemy/NPC units who start on the map. The primary LOAD1 command is “Load units and move. If player unit, join party (LOAD1+ENUN)”.

LOAD2 commands are generally used for loading specific units in cutscenes. Player units loaded with LOAD2 will not join the party (though of course, it won’t remove units who are already in the party), so it’s useful for when you need to show blue NPCs. The primary LOAD2 command is “Load units and move (LOAD2+ENUN)”.

LOAD3 is a bit different, and its name in FEBuilder, “load player units for cutscenes”, is a bit misleading. Like the other LOAD commands, LOAD3 takes in a unit group, but the units loaded will not actually be the ones shown in the Unit Placer. Instead, LOAD3 will load the first X units of the player’s current party, based on recent deployment order, in order of the slots in the Unit Placer list. This can be useful for cutscenes where you need to show a large group of the player’s units but don’t need to specify which ones in particular.

In most cases, you will use variants of LOAD1 and LOAD2 to load groups of specific units. If you are loading units to appear on the map in gameplay, or if you want units appearing in a cutscene to join the player’s party as new recruits, use LOAD1. If you are loading units purely for cutscene purposes, use LOAD2.

The one other load command to be aware of (which probably uses one of LOAD1 or LOAD2 internally, but I don’t know the specifics) is the “Load reinforcements” and “Load reinforcements (Hard mode only)” macros. These commands should be used in all cases where you load enemy reinforcements during a map. The big thing that sets them apart from the other load commands is that, as units load in with these macros, the camera will automatically pan to show where they’re loading. This may seem like a minor detail, but it’s extremely important to do for the player to be made aware of reinforcements showing up. If you’re thinking “haha I’ll not do that to make it a surprise”, no. Stop. Don’t. That is simply bad design. The reinforcements are visible information anyway, don’t make your game intentionally obstructive to the player’s ability to play.

How do I make the camera pan to show reinforcements as they appear?

See paragraph above.

How do I make a unit appear in map events even if they died?

There’s a table you can find in the patches list called the “IsSethLArachelMyrrhInnes Table”. Any unit included in this table will be loaded with LOAD2 even if dead. It got the name because those four units – Seth, L’Arachel, Myrrh, and Innes – are the units in vanilla FE8 who display this behavior.

(For dialogue-only scenes, nothing in the text engine checks the living status of the unit a portrait belongs to, so you don’t need to do anything special there unless you want a unit to not show up when dead, in which case you’d need a CHECK_ALIVE conditional and alternate text entries.)

4 Likes

FEBuilder got stuck on the wrong language, how do I change it back?

The buttons are still in the same place even if you can’t ready them, so follow along with these images.

  1. Open FEBuilder and open a ROM. If you’ve already done this before, you know which button to press even if you can’t read it, but if this is your first time you’ll want the second button on the launch screen, which will prompt you to choose the ROM file with your computer’s file explorer (which should already be in your language):

  2. On FEBuilder’s main menu, navigate to the Options window from the Settings dropdown. Settings is the last of the four menus at the top of the screen, above the top row of buttons, and Options is the first choice in it:

  3. In Options, go to the final tab, Function 3, where you’ll find the setting for FEBuilder’s display language as the first choice in the bottom section. Change it to your preferred language, then click the save button at the bottom:

  4. Close and reopen Builder for the change to take effect.

5 Likes

Is there a place to see all the commands I can use in text/dialogue?

Yes, right-click in the Text Editor and click “Script Notation”. It’ll bring up a searchable and categorized commands list much like the one for the Event Editor.


10 Likes

How do I create and edit Tile Changes on a map?

To create a new tile change, click “expand tile changes” and then “assign new tile change” in the Map Editor, above the tileset:


To edit it, you select the tile change you want to edit in the dropdown above the “expand tile changes” and “edit palette” buttons:

Once you’ve selected the tile change to edit, you’ll see the changed tiles shown on your map, with the rest of the map grayed out. You can move and resize the tile change by clicking “resize” above the map while the tile change is selected, and you can edit how the tiles change by placing tiles within the highlighted tile change area:

Warning: You should basically never click this button in this process without knowing what you’re doing:

4 Likes

The game’s triggering the wrong tile change.

First of all, be careful of overlapping tile changes. Make sure you’re not trying to trigger a tile change based on coordinates that overlap another one, use the ID-based tile change command instead.

Already checked that? Or it’s a village close vs destruction tile change showing the wrong one?

…Alright. Time to open up the dangerous menu. Click “Expand Tile Changes” in the Map Editor, then go here:


I do not like this editor. It is very easy to break things here. I strongly advise against using this editor to create or edit tile changes unless you know what you’re doing. Follow the steps in the post above for normal tile change editing instead. That said, for this, we’ll need it, so follow along carefully.

Open this editor from the map that’s giving you the issue. First, go through all the tile changes in the list for the chapter and make sure that their ID value matches their position in the list:

If the issue was a tile change command in an event triggering the wrong tile change, this is probably the issue, check if it’s fixed.

If the issue involved a village triggering the destruction tile change instead of the door close tile change, you’ll need to reorder the tile changes in the list. Village destruction tile changes need to be placed higher in the list than their village closed counterpart.

Reordering the tile change list will not automatically update the IDs to match. Once you reorder the list, make sure to check and fix the ID values accordinly, or issues will arise.

5 Likes

I have a chapter without preps, and there’s an issue. Turns won’t automatically end, the cursor is getting stuck off-screen and breaking the game, and I can see units in the stat screen who aren’t on the map.

These issues all come about as a result of having a no-preps chapter without the full party deployed. When a unit is not deployed in the preps screen, it is marked with the undeployed state. However, without the preps screen, the game doesn’t know to make units who aren’t on the map as undeployed. As a result, it thinks every unit in your party is deployed, even those that aren’t on the map, leading to all these issues – the turn isn’t ending because there are “deployed units” who haven’t moved, the cursor’s getting stuck off-screen because it’s trying to find a unit that isn’t on the map, etc.

The solution to this is simple, if a bit tedious: before the chapter starts, use the REMU command to temporarily remove each unit from the party that isn’t involved in that chapter. Then, at the end of the chapter, use its counterpart REVEAL to make them rejoin.

While I have not seen it firsthand, I’ve heard that large blocks of consecutive calls to vanilla REMU and REVEAL can sometimes cause issues, so it is advised to use the “silent” versions from this patch for this purpose. (Note that this is specifically meant for start- and end-of-chapter processing, the commands in this patch will not work if you need to REMU a unit on the map mid-chapter.)

Patch Name:AddEvent: Silently change the unit’s status flag @FE8U
Author / Source:7743

So, you’d have something like this in your start event:

And something like this in your end event:

If the lord is one of the units not involved in the chapter, you’ll also want an autocursor fix patch. There’s a version that makes autocursor just jump to the first deployed unit instead of the hardcoded lord, and a version that lets you specify who the autocursor jumps to on a per-chapter basis. I find the “first deployed unit” Autocursor Fix works for most use cases with less setup required, but the other version is more directly controllable for some edge cases.

Patch Name:Autocursor Fix @FE8U
Author / Source:credit Venno Venno's small ASM hacks and notes - #66 by Venno

Patch Name:Change to have multiple main characters selected by auto cursor 20200302(Install) @FE8U
Author / Source:7743

I have a unit who left the party rejoin after preps. I can’t see them in the unit list, and the game ended my turn before moving them!

If a player unit existed during preps but not deployed in preps, the preps screen will mark them as undeployed. This includes units removed from the party with REMU – they’re not actually gone from your party, they’re just hidden. When the unit rejoins, they still have the undeployed state, so the game won’t count them when checking if all your units have moved. Luckily, there’s an easy fix: remove the undeployed state when they rejoin. This is done with the UNCR command, added by this patch:

Patch Name:Add Event: Set Unit State Conditions (UNCM) @FE8U
Author / Source:Tequila Teq's Minor Assembly Shenanigans - #80 by Tequila

Example:

7 Likes

How do I edit the stats of characters?

Character Editor

Select the unit you want to edit and set their base stats and growth rates:

Note that these base stats are added to the base stats of their class. The Stat Calculator field can show you a unit’s average stats at a given level using the class base stats of their “Support Class” (set in the top-right), so if you set the level to view as their starting level, it will show you their base stats.

How do I edit the stats of classes?

Class Editor

Select the class you want to edit in the list and set its base stats, max stats, and enemy growths (see here for an explanation of how enemy stats work):

How do I edit the stats of weapons?

Item Editor

Select the weapon you want to edit in the list and change its stats:

2 Likes

How do I edit maps?

Select the chapter you want to edit in the list on the main screen, then go to the Map Editor:

Click a tile in the tileset on the left, then click on your map on the right to place it:

To change the tileset you’re using to a different one in the ROM, click the “Tileset Palette” dropdown:

To change the size of your map, click Resize, then input how much to change it by. Note that you can add or remove space from the top, bottom, left, or right. To shrink, set a negative number for the change:


Some people prefer doing their map editing in programs outside of FEBuilder. I won’t go into those here, but if you use one of them, you can insert the resulting map configuration file by clicking Import From File. Note that this must be an insertable tile map configuration, such as a .tmx file, that matches the tileset, not just an image of the map.

How do I edit player/enemy unit placements on maps?

Unit Placer: (Alternatively, click on one of the units shown on the map)

In the Unit Placer, you can find all the unit groups that exist in the chapter. Select the one you want to edit, and you can see all the units in that group and edit their level, class, allegiance, starting inventory, and placement. (Units who are already in the player’s party will use their current level, class, and inventory instead.) Note that you can move units around on the map by simply clicking on them on the map, then clicking where you want them to go – you don’t have to enter the coordinates manually.

To add new units to a group, click Data Expansion, and expand the list to the total number of units you want. This can also be used to remove units, by “expanding” to a size smaller than you currently have. A new unit group defined here will not automatically appear in the chapter. You must then load it in an Event. See here for a discussion of loading enemy reinforcements, and here for more in-depth details on how the different unit load commands work and which you should use when.

Note: Units can be set to move as they appear, instead of simply manifesting on their starting square. To do this, and to edit units already set to do this, there’s a list of coordinate positions at the bottom of the Unit Placer. The bottom coordinate in the list is the one they end at. Select the entry in the coordinate list you want to edit before moving the unit on the map. You can add new entries in this movement specification by selecting a row in the coordinate list and hitting enter, and delete them by selecting a row and hitting delete/backspace.

How do I make an enemy drop an item?

To make a unit drop or not drop the last item in their inventory, click where it says “Item Drop”.

How do I set the player’s starting position with the preps screen?

The player’s available positions during preps are determined by the size and placements of the unit group labeled Player Placement in the Unit Placer. For this purpose, it does not actually matter what units are specified in this group, only how many and where – you’ll notice the vanilla game likes to just spam duplicates of Seth. Force-deployed units will be forced in the positions of the first units in the list.

How do I change which units are force-deployed?

Forced Deployment editor, under Advanced Editors.

Each entry in the list contains a unit, a route specification (“tutorial mode” is pre-routesplit), and a chapter specification. Setting the chapter ID to FF means the unit will be forced in ALL chapters so long as you’re in the specified route. Setting the route to FF=Unconditional means the unit will be forced in the specified chapter regardless of route.

Ex. This unit is forced in every pre-routesplit chapter:

While this unit is forced only in Chapter 4:

To add more entries to the list, click Data Expansion, and expand the list to the total number of entries you want. This can also be used to remove entries, by “expanding” to a size smaller than you currently have.

5 Likes

Where do I edit events?

Events are what control cutscenes, reinforcements, recruitments, getting items in villages, and so much more. This post will cover how to get to and use the event editors in FEBuilder. The intricacies of how to actually write events is covered in various other posts in this FAQ – there’s a whole “Eventing” section in the first post’s table of contents – and in more dedicated guides like this one: FE8 EA Eventing Guide

To edit a chapter’s start and end events, those that run at the start and end of the chapter, select the chapter you want to edit on the main screen, then click where it says “Start Event” or “End Event” on the right side:

To find and properly edit all other events, click where it says Event above that:

This editor has multiple categories, which you can select from the dropdown at the top. The most commonly-used are:

  • Turn Conditions, or turn-based events, which play at the start of a specified phase on a specified turn
  • Talk Conditions, or talk events, the events triggered by talking to a unit (ex. recruiting an enemy)
  • Map Objects, which encompass things like chests, doors, villages, and sieze points
  • Always Conditions, which include range events (area triggers), events triggered by specific Flags turning on, and events that just run after every single action (usually conditionals of some sort).

What basically all of these will have in common is a pointer to the event you want to trigger. You can click where it says “Event” to open that event in the event editor.

There will also be a field for a Completion Flag. See here for an explanation of Flags and Completion Flags.

Beyond that, there will be fields specific to the event category – the turn(s) the turn-based event runs on, the unit who initiates the talk and who they talk to, the type of map object, the corners of the range event’s area, etc.

To add more entries to one of the lists, click Data Expansion, and expand the list to the total number of entries you want. This can also be used to remove entries, by “expanding” to a size smaller than you currently have. When creating a new entry, or if you set the event pointer to 0, you should see a “New Event” button appear next to the event pointer, allowing you to create a new event from scratch. When you do so, FEBuilder will prompt you with a set of relevant starting templates for common use cases, in addition to the “create an empty event” option.

In the Event Editor itself, you’ll see all the commands making up the event. Double-click on a line to open the editor for that line, in which you can change its parameters, insert a new command after it, or replace it with a different command. To choose the command to replace it with or insert, click the Command button to open the commands list. There’s also a Template button to open a list of multi-command templates you can insert for common use cases.

The command list is well-categorized and searchable. You can select categories to only show commands in that category. While your cursor is hovering over a command, you’ll see a description of that command at the bottom of the screen. Double-click on a command to select it and be sent back the the Event Editor.

How do I make reinforcements appear?

Reinforcements are loaded by Events, most commonly Turn-Based Events at the start of player phase on a given turn. When creating a new Turn-Based Event, there are default templates for loading reinforcements:

The basic template for loading enemy reinforcements is quite simple:
image

Double-click on that Load Reinforcements command to open the editing window, then double-click where it says “please set the unit to be read” to be taken to the Unit Placer.

In the Unit Placer, double-click on the unit group you want to load as reinforcements. If you want to load a new unit group, click “Alloc New Space” below the list of unit groups, then double-click on the resulting NEW entry.

Once the unit group is selected, you can go back to the Unit Placer to edit it. You can jump straight to the relevant group from the Event Editor by clicking where it shows the preview of the units while editing the load command:

4 Likes

How do I change a character’s portrait? How do I import custom portraits?

In the Character Editor, click on the character’s portrait to open the portrait editor:

You can import a new portrait here by clicking the import button at the bottom. Make sure to adjust the eye and mouth positions appropriately after import.

To select a different portrait in the list to use, you can double-click on an entry in the portraits list after opening the portrait editor from that character’s character editor, or you can set the ID of the portrait to use in the Character Editor (the ID is the position in the portraits list).

How do I set a character’s personal battle animation color palette?

In the Character Editor, click “Jump to Unit Palette” to open the unit palette assignment editor.

On the bottom half of the screen, you put the IDs of the classes to use. In the corresponding slots on the top half of the screen, you put the IDs of the palettes to use. Click the label next to any of the top half’s palette slots to be taken to the actual palette editor, where you can edit the colors of the palette and expand space for new palettes.


3 Likes