Turn Events Not Functioning [RESOLVED]

So my friend are I are working on a Fire Emblem hack and we’ve been working on our first chapter, and all of our turn events that occur after Turn 1 seem to not be functioning. He’s the one who’s been writing all of the events for the hack so far (I’m the artistic director, you might say) but he doesn’t have access to assistance websites and stuff, hence why I’m here to request assistance.

So all of our turn events are not functioning in the slightest, I’ve gone ahead and copy-pasted some of the event code that he’s written (Note that some of the stuff is set up intentionally to not work right now because he was testing stuff, we’re currently focused on the first set of reinforcements)

TURN 0x0 (Opening_event) [1,1] 0x0 0x0
TURN 0x0 (HeroFortReinforce) [2,5] 0x0 0x0

CAM1 [4,1]
LOU1 HeroFort

UNIT [0x67] [Hero] [0x34] Level(20,Enemy,True) [4,1] [4,1] [SilverAxe,SilverSword] [0]

Here’s a list of things he’s tried:
Altering event IDs
Changing simple syntax (parentheses…)
Moving around chapter data
Not loading opening events
Having them start in the enemy phase
Trying it in a clean ROM
Using some conditions
Trying it with other turn events.

Thank you tons for any help, and I’m really sorry if I put this where it’s not supposed to be I’m new to this website

I don’t seem to see what turn you want your event to go on?

Turns 2, 3, 4, 5, it seems. Unless I read the events wrong.

When I do turn events, I usually do not have parentheses around the event pointer. Unless you already tried removing them, I would start with that(Unless that is how the new event assembler reads events/pointers). I usually do not have ENUN and ENDA after unit lists either, would that be the cause? [I would comment on the square brackets around the character ID, class ID, and leader ID, but I have no idea if that is supposed to be there because I am assuming you are using the latest Event Assembler, and I have no idea how the events for that works]
And what happens when those events are supposed to trigger? Does absolutely nothing happen? Does part of it work? Does the game freeze?

Try this instead of what you have up there in Turn_events.

I don’t do my turn events like that, so I didn’t recognize them right away. ¯_(ツ)_/¯

I’m the fool that wrote these events. This is the strangest thing.
I can get turn events to work in other chapters just like this, but not in this one. It’s as if the game stopped counting turns. I don’t think it’s a syntax issue. I’m thinking it’s something with some previous code in the opening events, but I’m not sure. There aren’t any weird codes there.

I gladly appreciate any help.

Never mind!
I got them to work. I just changed around the order of my map data and chapter data.
Thank you to who tried to help.