Trouble Inserting VASM Battle Frame[Resolved?]

I found this package:

For this frame here:
It has instructions, and I followed them directly, but when I open the ROM, all I get is a white screen. Nothing else. Can anyone help me solve this error?

We need more info than “I tried to do something and it didn’t work.” Also, with the instructions, how many times have you tried following them? If you only tried once do it a couple more times to make sure there wasn’t a simple mistake made.

Well after it did not work the first time, I downloaded fresh ROMS and tried several times, all with the same error. The process itself does not pop up any errors. Which is why I thought it would work. But it didn’t.
Just a blank white screen shows up.

have you considered telling us what you did other than “i tried it and it doesn’t work”

the problem is clearly not on our end, as others have successfully managed to insert that frame

Well, here’s your “press ‘apply’ to win” option. Lucky you that this is still sitting on my dropbox.

These are the two relevant authorities if you want to give it a whirl again yourself, as the patch provided doesn’t have the entire custom battle frame inserted (not quite so fancy with the unit name boxes, but eh).


Thanks Arch, but I wish I could figure out my error and fix it.
Okay let me tell you what I did exactly. Here are the instructions in the package:
Steps for insertion:

  1. Open your ROM and the TSA and palettes.bin in a hex editor.
  2. Copy the entire .bin file.
  3. Paste-write it at offset 0x1D8C34, and it will overwrite original palette and TSA.
  4. Insert & repoint the images at their proper offsets in GBAGE, and enjoy!

I downloaded a fresh FE7 ROM, then I extracted the file. Then using HxD, I opened the ROM and the TSA and palette in two different tabs. Then I copied the entire TSA file, and paste-wrote it at the offset. Then I hit save, and exited HxD. Then I opened GBAGE, and I open the pics, and write them at the offsets, then I click save. Then I open the ROM, and I have a white screen. That is where I am.

Sorry for not providing enough information.
This is everything I did.

If you’re just pasting (ctrl+v) instead of paste-writing (ctrl+b in HxD), that would be the only thing I could think of that’d cause white screen of death glitches like that. The difference is that pasting inserts that exact number of bytes, thus breaking pointers to everything in the ROM after that location, while paste-writing inserts over the bytes and preserves file size.

1 Like

You fuckin troll haha

I followed your advice and made sure I used paste-write. :slight_smile:
But same problem. I think my problem is with GBAGE.
Can you easily explain that part to me please?

I feel like the tutorials I’ve linked you to would offer a better explanation of the process than I can provide. I’ve never actually inserted a battle frame myself. It seems to me like a simple matter of importing the bitmap, changing the offset to write to a location in free space, and saving the ROM. Just inserting a graphic shouldn’t break anything critical so long as you aren’t inadvertently writing over crucial data.

The game should at least wait until a battle sequence is called to crash on a faulty battle frame insertion, so I’m not quite sure what would cause a white screen on boot unless you’re severely fucking up the ROM somehow in GBAFE. Paste instead of paste-write is the only thing I can think of to cause that.

Did you uncheck “import palette” when inserting the image with GBAGE?


Okay I tried it again, but same white screen. :frowning:
Just to clarify, after I paste-write, I open the ROM in GBAGE, then I go to image control, and once I am there I just change the pointer, input the necessary one, and I go on ‘Import File’ then I uncheck ‘import palette’ and I click Browse, find the necessary file, and then do this for all I have to insert then click save?
Am I doing the right thing? Do I need to change the size or something?

Try opening the file after you change the TSA/palette but before inserting the images. That might help you isolate which step is responsible for breaking the game.

Ok. This is how the battle screen ingame looks like after I do the paste-writing in HxD:

And when I am in GBAGE, I change the size to 8x8, (Saw that somewhere), and after I insert the files using Import Bitmap, and the ROM opens now, but the battle screen looks like:
Any suggestions? IN HxD, I just leave the stuff when I press Ctrl+G right? Or do I need to change something there?

Where exactly are you writing each piece?

To clarify further, the README gives you the default offsets in FE7. You should not be writing the graphics there. That’s why it asks for a repointing after insertion.

1 Like

I was writing the pieces to the default offsets in FE7. Thats where the problem is. My bad.
So how and where exactly do I repoint and write these pieces?

You have to invert the pointers given to you: 0x1D88B4 is given for the battle frame, so we break that down into individual bytes 00 1D 88 B4. For pointers, you add 0x8000000, so that makes it 08 1D 88 B4. Then reverse the bytes, like so: B4 88 1D 08. Run a “replace all” on those hex values, and do the same process for every pointer given.

There’s a lovely topic that’ll come up when you type “free space” in the search bar.

So if you just import the battle frame to 0xD00000, you’d run that replace all function and replace with 00 00 D0 08. After importing the first piece, go to that offset to see how long the data runs and pick up at the next available offset (when it goes back to being 00s and FFs primarily is when the free space starts again).

Additionally there’s a tutorial further explaining repointing (you could’ve found it by typing “repoint” into the search bar).

Did you manage to pull off the insertion? I’d love to see a picture as a token of your success.

1 Like

I have not pull it off as yet, when I do, I will be sure to post it here Arch! :smiley:

1 Like