Tilechange without ID (Even though there is an ID)

Perhaps using Tiled is a bit outdated with FEBuilder, but personally I like it more. However, the problem depicted in my picture and title are my exact issue. As you can see, I do have a tilechange ID, and all the other information is written correctly. I did use FEBuider to import this tileset into FE7. But I don’t see how that should be a problem since I imported the tileconfig no problem. Furthermore, the map inserts (and functions) without a problem if I keep it at one layer.

Using Tiled is not what’s outdated, using Tiled map inserter is. I don’t know if you’ll find many people that can help you. Either way if you want help you should upload the map or give some more info, just showing what you think is already correct isn’t going to be of much help.

Also your offsets look… pretty weird. Why are you writting the pointer to the middle of nowhere? did you repoint the event pointer table or something?

I did repoint the event pointer table. In fact, all the offsets I used are a copy&paste from Markyjoe’s Tiled tutorial.

Here is the map. Honestly, I have no idea what is going wrong. Literally yesterday I inserted a map with tile changes without a single problem. Its possible I overlooked something, but I’ve more than triple checked and I just don’t have a clue what is causing this error. My only guess is that its stemmed from importing the tile set (maybe?)

That’s not what I meant, this is just an image of the map, what I wanted you to share is the file itself, which is of course going to have all the info anybody could need.

Sorry about that, here is my .tmx file;

Without taking a deep look into the file, I believe that that error occurs when there are tile(s) on one or more layers/maps that lack data, meaning that there is empty space. One or more of your maps are not completely filled in with some tile.

If my memory serves correctly, that message is actually misleading in what the error actually is.

Thanks for the response! Could you please expand on that? At least I don’t think thats the problem since I’ve experimented by trying to make any possible tileschanges, and always it gives me this error. The moment I have more than 1 layer, the inserter gives me this error. But I must be missing something, I just haven’t a clue what it is.

All of your tilechanges must be perfect rectangles without any spaces in between.
For exampe, this is an illegal tilechange:
What you can do to remedy this is fill in your blank spaces to make all of your tilechanges perfect rectangles like so:
In your tileset, there’s this funky tile in the top left corner.
If you put this tile in a tilechange, the game will interpret this to mean that this tile should not be changed.


I actually did not know about the perfect rectangle thing, so thanks for informing me. Unfortunately, that does not seem to be my issue. As far as I can tell, the moment I add a second layer the inserter gives me that error (seemingly no matter what I do). Could the problem be that I inserted this tileset through FEbuilder? The map other wise functions just fine, its only when I try to add tile changes that I get errors.

Anyway, just to confirm that I have been following proper procedure for tile changes. One of the tile changes I tried was getting these doors to open. I don’t think I broke any of the rules with this change. And I had it appropriately labeled
Height = 1
ID = 0
Width = 2
X = 18
Y = 20



Edit: The change in size between the images is because I enlargened them at different rates by accident on paint.

Can you post images of what your tilechange IDs look like (along with height, width, etc)? I tried downloading your .tmx file, but the site gave me a 504 error. Alternatively, could you upload your .tmx to Dropbox or perhaps Google Drive?

Sorry that the link didn’t work. Let me know if this does:

Also, here is another image of what things look like on my end to give a rough idea:

You need to add the “Main” property to your base tile layer whenever you have multiple layers. This tells the inserter that this layer is your base map.
I tried inserting it with Tiled Inserter (been awhile lol), and I got no errors. If you do that, you should be good to go.

1 Like

Thank you so much! In the back of my head I knew I had to be over looking something simple. By I was rechecking and rechecking my file to the point where I wasn’t really looking at it. Thanks so much, and sorry that it ended up being such a noob mistake.

Btw, what are the more up-to-date map insertion methods everyone is alluding to. Are you talking about mapping through FEbuilder, or would this inserting the map through build files?

1 Like

I think both.
If you are building a work with buildfile, you should insert it with the buildfile method.
If you are building a work with FEBuilderGBA, it is easier to insert with FEBuilderGBA.


To insert tmx files with buildfiles, use this:

It can convert a large number of tmx files to a .event (EA-insertable) format very easily, and it makes it easy to write tileset-related things (Object type, palette ID, etc) and to the event pointer table.

1 Like