Sound Effects issues

#1

So I am using an Apocalypse animation but the sounds aren’t working correctly even though I set it up, and after I imported to another rom, any idea why the effects are not working? Also, how do I change the map walking SFE for a class? My lord is mounted but it has the infantry SFE instead of cavalry, I need to know how to change and fix these SFE problems if I run into them in the future.

#2

Footstep SoundEffect can be changed in the detail menu.

You can be set for each class.

However, since some classes are hard-coded, apply this patch if you want to set all the classes.

#3

I cannot find that feature in the menu

#4

Am I missing a patch or something, or am I just not seeing it? Can’t find

#5

Is your FEBuilder updated? Sometimes people can’t find the feature because they’re using an outdated version.

#6

what is the current version?

#7

Recent%20version

#8

even with the update, it is still not there

#9

Hm… that’s strange. I checked on mine, and it’s there.

#10

is there a patch for this or no?

#11

As far as I can see, no.

#12

do you know the possible reason for this?

#13

is it because it’s FE7?

#14

Ohhh, I was assuming you were using FE8 x3

I’m unsure if there is one for FE7, since I primarily hack using FE8, and I know it better.

#15

Ah, well, shoot, Do you know the first issue I have then? About Apocalypse?

#16

My guess that If the sounds aren’t working(like they don’t play) is because the script is trying to call sound effects that FE7 doesn’t have. Just a guess though, I have a small amount of experience with importing spell animations, and then fixing sound effects in the script.

#17

I’m pretty sure I put the SFE in the same slot though, and I imported it into the game using import from another game option

#18

also, only the second SFE file actually worked 100% of the time, first one never worked, but the third one only sometimes works, is it the priority or no?

#19

I’m unsure unfortunately. FE7 may do things differently then FE8.

#20

Well, I appreciate you help nonetheless