[SOLVED] Indexed palette wtf-ery

Hello to all; to all hello. I’ve got a problem with inserting my custom world map.

I have the dimensions all correct, and the graphics are inserted almost without hitch, but there’s one small problem…

As you can see, each segment appears to have their palettes in the wrong order, with the exception of the first image, which you can just make out in the top left corner. They should be using the same palette. But if you look in Usenti…

They appear to have the same palette? I did this by making 12 copies of the original image, and then cropping them into the 12 segments. I thought that this would keep the palettes correct, but apparently I was wrong? Is anyone able to tell me what might have gone wrong, or how they fixed this issue?

Edit: Perhaps @Primefusion can help me?

GBAGE sometimes rearranges the palette weirdly if you only have 1 palette line. Try exporting the one that works properly and C/P your other graphics there, then reinsert them, that should fix it.

My world map has less detail so I just put the palette in the upper left of each segment, inserted them, then manually adjusted the segment in a hex editor to get rid of the upper left corner palette.

I’ve tried doing this a more general way that @Jubby talked about here but didn’t get the results I needed. Though in my case I think it’s because not every segment uses every color of the palette so I when I go to insert, GBAGE “consolidates” the image’s palette, causing it to screw up like yours.

EDIT: …Or at least I thought that was the case. I guess it’s because i was using .png instead of .bmp? Dammit GBAGE… Thanks @Agro

Ah, this worked! Thank you, thank you, thank you.

You would typically be able to use PNG (I always do in the interests of keeping files smaller) but I think with BMPs indexing is automatic, with PNGs you have to make sure you save it as non-transparent 8-bit and idk it’s easy for stuff to get messed up :confused:

Plus GBAGE does seem to occasionally arbitrarily bollocks it up. :stuck_out_tongue: (Although it’s probably the user’s fault somehow lol)