[Self-Solved] Moving cursor over a certain unit causes game to reset

I’ve got an odd and fairly confusing issue that’s popped up all of a sudden.

I’ve got a new unit being recruited in this chapter, but once he’s recruited, trying to put the cursor on him to use him causes the ROM to reset.

Previously, cursoring over him caused some odd visual glitches with the info boxes on the screen, which changed back on the next turn provided the last unit moved wasn’t the problem unit, but now trying to use him causes a reset.

I’m at a loss as to what’s causing it, as I can cycle through the unit screens and that works, but exiting them when stopped on that unit causes the reset.

If it matters, the unit in question is an axe cavalier, but everything related to that works for generic enemies, so I don’t think it’s the class causing it.

I’m more than likely forgetting other details, but I can’t think of anything else to add, so if more information is needed I’ll provide whatever I can.

Here’s a video showing the resetting issue

that’s… weird.
Did you insert any map sprites at all? One thing you could try is reinserting the cavalier in free space and see if that does anything.

Map sprites? I don’t think we’ve put any of those in yet.

Reinserting the animation or the pointer stuff for it?

If it helps, I tried changing his class as well, but the resetting thing still happens.

Maybe try opening his character data in nightmare and see whether everything looks normal. Something may have accidentally gotten overwritten (although I can’t really think how; I’ve had this issue happen to me before, but it was because of the standing map sprite, which I was editing at the time).

EDIT: Perhaps try turning off the unit information window in settings and see whether the problem still occurs.

Turning off the unit information window solves it, but I still don’t know what it is that’s wrong.

Could it be the mini mug?

EDIT: Setting it to burst also works, this is weird.

I guess there’s something wrong with the chibi; what, I couldn’t begin to tell you.

I’m not the artist (or an art person in general), but here it is in case anybody knows what to look for that could be wrong.

I don’t know why or how, but I had the artists redo the chibi, and it works now

So… Yeah…

aah, yeah

sometimes mugs in feditor will lose their mini mug or the actual full mug for literally no reason when you insert stuff. I don’t know why it happens but it does that occasionally.

I think that was the issue, because when I reinserted it the chibi was missing.

But I would think that it would just show nothing instead of breaking things.

who fuckin’ knows when it comes to feditor


literally this

thank you for existing, feditor, but…

fucking feditor

1 Like