ROMHacking Assembler error

So I made a change to 0815 put it into notepad+ and tried to assemble with event assemble. But I got an error saying that “Line52, Column 9: Didn’t reach end, currently at NewLine (NL) No data written to output” then I tried using something else and it doesn’t make a new txt file. What am I doing wrong?

What’s 0815, and why is it a FEditor error if you’re using Event Assembler?

815 is Lyn meeting Mark for the first time. And sorry I meant it’s an assembler error. I’ll fix that

Are you trying to assemble the text with EA?

that’ll only work if you’re using CrazyColorz’s text parser and follow the instructions for how to do that. Otherwise just edit and insert with FEditor.

I’m trying to assemble an event and put a text scene in the middle of it

Change the text to whatever you’re trying to make it with FEditor, apply and save, etc.

Then in the event do this:

FADI 10 //obligatory fades
BACG backgroundID //displays the background, optional
TEX1 textID //displays the text
REMA //clears the screen

Just do 0x815 instead of textID and it should work.

Yeah, I have it as 0x815. But It says that there’s an error at the above mentioned space. I try to fix it and it doesn’t make a new txt file to apply in assembler

paste a copy of the event file so I can maybe figure out why.

Sorry, I’m away from an Internet source to send you a better pic. Hope this is fine

The error is line 52?

I don’t hack FE7 but it seems correct to me, I dunno what’s set up wrong.

Capital X in the background value


That will fix the error, to edit the actual text you will have to go to that entry using feditor and edit it there

1 Like

You clearly have better sight than me. Lol, thanks so much. BTW, it did fix it. Now if I can figure out music.

Good luck!

1 Like