Problems with FEditor Adv CSA[Solved]

I’m trying to recreate the Crimson Eye animation from FE8 in FE7, but when I load the script it shows me this:

It’s the first time that happens.
All frames have the same dimensions (264x64 for bg, 488x160 for objects) and every frame have 16 colors or less, the object frames have the same palette too.

Here’s the script:

I don’t know what I’m doing wrong, because I’m using the same format for previous animations that I’ve made.
I also tried with older versions of FEditor, but they don’t load the CSA Inserter or show the same “error” with negative frames.
Any ideas?

the script is refusing to load for me; how many frames are there?

24 for bg, 53 for objects, but there are some loops, making 140+ frames…

Aha, that would make sense.

What I assume is that the frame count is getting too large and looping around to a negative value. Try removing a lot of the loops and see what happens? Going below 120 frames should be safe.

127 is the max number of frames per animation, I thought it didn’t had limits.
BTW, it would be good put a note or something in the doc about that.

okay, 127 is exactly what i thought (it’s the point at which an s8 looks back around to being negative)

it’s not an actual limit and more the fact that FEditor was coded somewhat sloppily

i’m not actually sure what would happen if we changed it - maybe there’s a reason it is what it is

1 Like