Problem modding fe6

Hello, im making a romhack of fe 6, and i’ve encountered a snag. Im edititing chapter two, just the text, and I somehow screwed up the event where the 4 mercenarys come in. I’ve skipped the cutscene to check if it was just the cutscene, and it worked fine if i skipped it. After the cutscene, if it plays out, the sprites all mess up, and the game becomes unplayable. Any help would be appreciated, as I am a newbie to hacking fire emblems in general. Thanks for the assist!

Well you’re hacking FE6, it’s very finicky to hack and has little if any support. It’s better if you hack FE8U.

I know its hard to mod fe6, but the rom I’m making has to be fe6, or a remade fe6 in fe8.

How come?

It’s in the same vein as dorcas emblem, its works off the base of the game, so at the core its still the same game, just with a new slap of paint

1 Like


It’s hard to tell what’s wrong without looking at the material itself, but just changing the text shouldn’t be that big of a problem even in FE6.


Since you don’t know where the problem lies, the easiest solution is probably to revert to an earlier version of the rom (FEBuilder automatically saves backups for you) from before you started editing that scene and start over from the beginning, making extra sure not to accidentally delete any [commands] in the process. And to test it regularly so you catch on quickly if something breaks.

(Of course you can also use febuilder’s report creation function and see if someone else can figure out where the problem is, but it’d probably take longer to wait for that.)

1 Like

“Map sprites go glitchy for a second and then the game crashes” usually means the game is trying to move a unit to a place that it can’t get to. Did you change Shanna’s class from pegasus knight to something else? If so, the game will still try to move her over cliffs/peaks/enemies during the cut scene, but if she can’t fly over the cliffs and doesn’t have a space to squeeze through the enemies, the game will get confused and crash because there’s no way to reach the place she’s supposed to go.

I think that might be the issue. In the gif that vilk posted, it shows shanna moving in the cutscene, but in my version, she refuses to move. She’s still a pegasus knight, and i haven’t changed that. Would deleting the section of the event where she moves over there fix it? So that the games not trying to make her move?

Wow, that’s bizarre. I honestly have no idea then. Wouldn’t hurt to try that, I suppose?