NarrowFont problems with Bly Text process

Hi, I am having a bit of a problem with the NarrowFont.
At first I thought I had solved it, because my anti-virus saw that the Text Process was a virus … okay, leaving this strange event alone, I thought I had solved it, beware now when I go to build the rom, everything works how much … more or less

## LanceCavalierName ^
Lance Cavalier[X]

What am I doing wrong? Did I skip any steps? I believe I have installed the NarrowFont correctly, because the text icons come out correctly at least I think so…

## LanceCavalierDesc
Mounted knights with swift movement.[N]
Equip: [Lance][X]

So I entered the text inside the ROM

[Armor] = [0x7C]
[Horse] = [0x7B]
[Flier] = [0x7D]
[Dragon] = [0x7F]
[Sword] = [0xB3]
[Lance] = [0xB4]
[Axe] = [0xB5]
[Bow] = [0xB6]
[Light] = [0xB7]
[Anima] = [0xB8]
[Dark] = [0xB9]
[Staff] = [0xBA]

Inside the “Parse Definition.txt” file I have inserted these definitions, and following this link (Bly’s ASM)

I placed it in the tools folder the new text process

thank in advance all those who read my post, thank you very much

Could we see your entire text assembler file with the issue?
Also did you appropriately edit your build scripts to call the new textprocess?

1 Like

of course! without problems

@echo off

set "textprocess=%~dp0..\Tools\TextProcess\text-process-classic"
set "parsefile=%~dp0..\Event Assembler\Tools\ParseFile.exe"

echo: | ("%textprocess%" "text_buildfile.txt" --parser-exe "%parsefile%")


is the basic one of the SkillSystem (I downloaded it in early September),
if it can help i can also show all my buildfile, I just don’t know how :sweat_smile:

the truth is no, because I don’t know what to touch

That’s your problem, then. You need to call the correct script! Do you have python installed on your computer?

1 Like

Ah ok, perfect!

I don’t want to say bullshit, but I think so, do you know how you can check it?
assuming I have it, what should I change?
EDIT: I did a quick check, and I remembered well, I have pyhton 3.7 installed on the pc (64 bit)


py "%~dp0/../Tools/TextProcess/" "text_buildfile.txt" --parser-exe "%~dp0/../Tools/TextProcess/ParseFile.exe"

1 Like

I did edit the comand script, and entered what you suggest, now when I try to use it to build the text_Buildfile, it reports this:

Honestly, I don’t even understand if it’s an error or a report of something, anyway i went to check the strings he mentioned is are

#0x3A LearnedSkillText
#first text ID in the free block
Learned  [X]

#0xd4c LikesText
#first text ID in the free block

## nameCamus
#for identity problems

## HouseText
#first text ID in the free block
[MidRight][LoadFace][CurrentPortrait]Nothing to see here.[A][X]

it seems to bother the “#”.
the fact that these texts are not mine, but are from the SkillSystem, I don’t think they are wrong

now I see if I build the buildfile entirely and not just the text

EDIT: I gave it a try, and it works :smile: yeah
Now I don’t understand what that “Warning” is … but it doesn’t seem to affect anything in the end, or so it seems

It just wants a different comment style than those text entries are using. It doesn’t not work when it’s done like that (and it also doesn’t give a warning if you use # comments in other files that you include @ bly this is probably a bug) but if you want it to not yell at you you just replace the # on the lines it says with // instead.

1 Like

thank you very much for the help, I suspected it was just comments, but I wasn’t sure, and I preferred not to touch so as not to break everything, once again thank you so much for your help Sme and Snakey1!

1 Like