Map Change Blues

Ok, that’s it, I admit frustrated defeat. For the past week, I have been banging my head against the wall trying to figure why the map change code 0x8 does not work at all. I am trying to toggle a map change in a chapter but no matter what I try, the undo map change code does not work.
I have tried:

-MAC1 0x0 0x8
-MAC1 0x0 0x1
-going to tiled and creating an extra map id with the orginal tile before the change so it can change back only for both the ids to work only once
-Then I got super pissed and ran a undo map change code list to see I would get different results like this MAC1 0x0 0x1 - 0x80
-Then I tried MAC2 and the above tests and got nothing
-Dissembles chapter 26x /28x to see what they did but all I got out of it was they had alternating Map change codes.

So my question is what in the tar-nation am I doing wrong?

That’s because you’re using the macro wrong.

MAC1 ID 0x00

Ta-da :smiley:

Tried that too, Re-tried it just to be sure, nope still nothing x_x

Then it has to do with how you set up your tilechanges.(I manually insert mine, idk what tiled does).

Also you can’t “undo” tilechanges, you have to re-create them and call them again.

tl;dr
mappy > tiled

1 Like

Cries…HARD

Fine, If I want my hack to be as challenging as I am trying to make it. I am going to have to do those map ID’s one fricking one T-T