How to fix midis that are out of sync in FEBuilder?

I’m making a rom hack. I have successfully imported all but a few tracks. Some of the midis are out of sync for some reason. In any other program I open them in they are fine, but once in-game they are out of sync. I have read the music insertion guide, and I looked everywhere for answers. If you could help me that would be nice.

If I did something wrong in this post, my bad I’m new.

Have you tried repairing the MIDIs in whatever program you’re using?
If that doesn’t work, can you post the MIDIs here?

Yes, I’ve tried to make the repairs. I some cases I have made small improvements but the issue is still there.

I tried stuff like lowering down instrument ranges that might be too high, I tried removing unnecessary tempo changes. the changes help but don’t fix the issue.
the link to the midis are here

Thank you so much

These should work now, the loop points are kinda messy for the troll song though. The .s files should be ready to import.


thank you, but how do I get the midi with the edits that you made?

Nevermind I’m stupid. Thank you so much!

1 Like