How to display an imported magic animation at the appropriate range in FEBuilder?

I’ve been working on a hack of FE8 in FEBuilder, and I was making a new magic tome, but when displaying the spell animation in ranged combat, the spell would appear in front of the enemy. How can I change this?

1 Like

For custom spells, you’ll need two different spell animations. One for melee, the other for range. You might also need to install the “Melee/Ranged Different” patch so you can give an item two different anims.

1 Like

I have downloaded the patch and both the ranged and melee animations, but I’m not sure how to give an Item two animations. I have given the item two entries on the magic animations list, one for ranged and one for melee, but that only seems to display the one higher up on the list regardless of combat range.

NAME.en=Melee/Ranged Different - Spell Loader
INFO.en=Patches the ROM to allow classes to have two different animations for magic.\r\nOne for melee range, and the other for ranged attack.\r\n

If this doesn’t work, please send report7z.


Thank you very much. I will try this when I next have the opportunity.

I’m not sure why it was the case, but that option wasn’t displayed before, so I reapplied the patch, and it works now. So, thanks again.