Help with Portrait Pointers

It seems I am starting to understand the hacking better. I get the text, maps, map changes, events, animations. Now that I have all the FE7 Animations in Sacred Stones, I need their portraits for conversations and in game character menus.

Apparently my downloaded mugs aren’t working correctly so I’m going to dump fe7 portraits in feditor and save. Then I try loading portraits into 8. I tried eliwood and I did not want to replace any portraits so I increased the max index. When I do this I’m getting a pointer error?

Strangely I increased max index in animation manager without pointer errors. I bet its something to do with a hex file. Hope I didn’t overwrite game data with the animations.

Increase the number of portrait slots. Save. Close FEditor. Sacrifice a small animal. Re-open FEditor. Try inserting it again.

I tried that I still get an error. AC is normal max. When I go to edit AD whether I close after changing max or not I get this. Error at bottom of screenshot…

Ignore it. It’s telling you that there’s no image data where it’s looking, which is normal when you’ve just expanded the image index. Insert an image, save it, close, re-open, and then it should be in.

Still doesn’t. Do I need to do something in hex editor with offsets?

No you don’t need to do anything in a hex editor.
It seems to be working fine for me when I

  1. open FE8 in FEditor
  2. Save
  3. close and re-open FEditor
  4. go expand the max portrait index
  5. save, then restart FEditor
  6. load the expanded slot, insert portrait
  7. save and reboot FEditor again

Wow that’s picky. It worked thanks a lot.

Welcome to FEditor!