Help with MGBA Save States

So, I was playing Sacred Stones hard on the MGBA emulator and tried to beat the chapter ‘Last Hope’ (19) without cheesing Riev with the Warp Staff. Went wrong. Had to use save states to not lose 1 hour of hard work. When I reset the emulator after the chapter, the ROM had been converted back to as if it was new: there were no more save files on it. The only way I can return to the old things I had is through the save state. Is there any method with which I can regain the ability to save normally again? Note that I don’t have much experience with save states and used them out of desperation mostly.

PS.: The game is also showing tendencies to crash when recording footage.

Before I reset

After I reset

The save file and states should be in the same folder as the rom is?

Yes, but I was afraid to meddle with it without assistance in fear of breaking the files permanently. How can I make a save state into a main save file?

I think it should save as a Sav file in-game as one when you load the save state

So copy them into another folder first and then test

As long as you save stated before you did the chapter, you should be able to load the save state. Because i’ve had it happen on rare occasion.

I changed the .ss3 (the latest save state) into a .sav and then tried to run the game but the saves were still empty
also after i converted it back to .ss3 it corrupted itself

I can load the save state, but any in-game saves I do while in the state don’t actually save; resetting the rom brings me to a ‘New Game’ screen as shown in the image above.

Did you change the save type by any chance? I always leave it on autodetect.

Go to Tools>Game Overrides> then tick autodetect on the six choices, and have the save type set to autodetect.

If that doesn’t do it then I don’t know what to suggest.

never changed it, is already on autodetect. I feel like it simply deleted the .sav file; it by itself is almost a third of the space of a single save state. So, if there is a way to change a .ssx file into a .sav without corrupting it, I think that could fix it.

While playing the game automatically constantly writes to your .SAV file.

Save states are not .SAV files. Load your savestate and then reset the game and it will have whatever data your savestate had.

If you changed your savestate into a .SAV and played the game, you just overwrote the savestate, as the .SAV is constantly overwritten such that it saves your progress. I hope you copied the files into another folder first like I told you to.

Sorry if I’m not doing something obvious, I’m really inexperienced with this, but it appears that no matter what I do the .sav file doesn’t change. I load the state, save, play a skirmish, save again, go to the world map, save AGAIN and yet when I reset the game still goes to the ‘New Game’ screen. I separated backup save states in another folder, even tried to isolate the .sav, but saving or doing any action in-game appears to have no effect on changing any data in the .sav file (I can tell because it always remains at 64 KB).
A thing I noticed however is that the [Save Type] option in game overrides always changes to SRAM whenever I boot the game and the whole Overrides box becomes gray and unclickable; maybe that’s the source of the problem?

Update: I tried to play through the game’s start normally and see if it saved. It did, and when I reset it remembered the new playthrough… When I re-loaded the save state and saved the game, the game reset to the New Game screen, completely overriding the new playthrough but still not remembering the save-state (the save-state i’m using has one save file on it). I have no clue what’s going on though.

Post your savestate / save files here (eg. via dropbox or shared file in google drive) and we’ll take a look at it
the .sav and 3 .ss# files, thanks for the help (the .ss1 is the original one that caused the trouble)


I don’t know what this actually means or the solution. Savestates still work, even though it warns the user. Suspend works, and the save files work until you reset.

I am making a complete guess that it’s something to do with your bios or emulator version. Make sure you are using the latest mGBA and that your ROM is correct, along with the correct GBA bios. Maybe somebody else can chime in with a better answer. Savestates can be tricky as they save the data stored in ram. Perhaps there is an issue stored in the ram causing it to error “BAD MEMORY”. I have no idea.

This isn’t something I’m experienced with, but I figure at least providing the log would be a good starting place for others. Sorry I can’t help more. Gl

It might be because when I used the save states I was using a glitchy old version of mGBA (0.5.0), which might’ve corrupted the save states in some way (I have since updated to 0.8.4 which is the latest). With the save states gone wack and the original .sav long gone, I guess the only way to keep playing would be to either fix the states (which is beyond my abilities) or to keep playing as it is by relying on save-states and suspension (which isn’t that bad except for the fact that I can’t have more than one save file). Thanks for the insight on the nature of the problem even though ngl I can’t understand much so everything I said so far is probably a guess.

That is probably your problem, then. Use the 0.5 version of mGBA, load the save states, save the game ingame, then reset the game (and it should work).

With this .SAV file you should make a copy and then use in the updated version of mGBA.

i tried that before: in fact I had used the 0.5 version of mgba until yesterday and tested both versions in all ways I could think of to no avail