Feditor mystery error is killing me[Solved]

  1. There’s this one cutscene that, if you press start and skip the cutscene, screen just blacks out and you can here the text sound continually going off. The events are like so.

IFCA 0x00 0x0F Lyn
BACG 0x12
TEX1 0x07FF
BACG 0x12
TEX1 0x090F

Any ideas?

  1. The Fem Shaman animation i inserted from Serenes is acting strange. The game will crash if she’s unarmed. So I tried reinserting it but i kept getting an error in feditor about it not being able to insert. Then i tried just going into the Custom Battle Animation Editor and tried to repoint the unarmed animation to just play the armed animation like i usually do. (I replaced guy’s unpromoted anim)

anyway, the game still crashed whenever she was unequipped.

Then i tried just pointing unarmed animation as just a map animation, and for some reason the game still thinks it should try to load animations despite the pointer being set to map animations

these are the last two issues i’ve been having, after these I can release a patch so help ASAP would be much appreciated!

With regard to the female shaman, did you set an animation for when the class is unarmed in the Battle Animation Pointer editor? Or did you just set it up for dark magic?

I’ve never used the ScrollText macro before but is it normal for the REMA to come after it? If anything I’d have thought REMA would come immediately after the TEX1.

pretty sure there’s no REMA
easiest way to solve this would be to look at what the scrolltext macro actually produces

#define ScrollText(textID) "TEX6 7 [0,0] textID; _ASM0x42 $83181; _0x89"

pretty sure that ASM command is clearing the box, so you don’t need the REMA; but I’m not certain because it’s been ages since I rom hacked and I don’t have any actual examples anymore

wait why do you have ScrollText() right after TEX1; you should have a FADI+FADU iirc

i didn’t touch the animation pointer editor… So all i did was just go in the custom battle animation editor xD

hmm, i got rid of the REMA, no success :[

What happens if you get rid of the ScrollText lines?


this is the feditor error, any ideas?

Nothing like a generic error dialogue! Looks like the PCA is having trouble writing your animation into the Animation Array, but I can take a stab at figuring out the issue / solution.

Things that will help:

  1. Version of FEditor
  2. Which version of FEditor was used to package the animation in question


my feditor version is uh… Not really sure how to check for version but
20140801.1 in release info.
2. I don’t know this either, but it was the female shaman animation from the Feditor animations thread on serenes.
Sorry that i was late/ uninformative!

okay now the bear animation got destroyed. Here’s the error when i try to reinsert the animation to the slot it use to be in


what the fuck does this mean like seriously, does anyone know what this is??

right now im just expanding the index, and inserting at the end to see if that fixes the problem.

Did you happen to edit with Nightmare or something else before doing anything? I don’t know for sure if it’s causing your problem, but if you don’t fix the checksum after editing with something other than FEditor, it can cause the program to mess up.

maybe a dumb question but have you tried downloading the latest version of feditor?

@Agro there’s a latest version of feditor?.. the one i have been using lately is the one with the dumb script/frames option.

@HeartlessSeph i’ve never thought of that… Can that sort of problem really just start happening out of no where? Like the femsham and the bear have been animations in the game for months now. I just don’t understand why now feditor is giving me such a hard time

If I remember correctly, not having the correct checksum causes FEditor to write to places where it thinks free memory is available when there is actually data there. So maybe it overwrote data for those animations. I’m probably wrong though, but I think it’s worth a shot to correct the checksum on your rom and run FEditor afterwards.

i can try that… correcting the checksum is just saving and closing feditor right?

so i fixed the animation problem- i just went in hex and followed Alfred’s tutorial and did it that way. But i’m still confused as to what that error means and if anyone knows what it means then holla at ya boi.

thanks for the help everyone!