FEBuilderGBA - Skill System & Gaiden Spell Menu Conflict

#1

I have been using the skill system ever since I downloaded this tool and figured out how to apply patches (which admittedly I only found this tool relatively recently). I discovered something in my tinkering though I wanted to share. I went to patches and looked at FE8 Spell Menu - Gaiden Style since I’ve never personally played Gaiden and I wanted to try out this spell menu.

The strange thing is, it said I already had the Gaiden Spell Menu patched installed…even though the advanced editors “Gaiden-style Spell” said I didn’t. I thought this strange, so I decided to try uninstalling the Gaiden patch (that I never actually installed to begin with), and then “Re-installed it fresh”. Now the spell menu advanced editor works, sweet, everything seems fine. I tinker around with it, get no errors, and then save my game.

When I closed the emulator, opened it again, and opened the rom I had just saved, everything loaded up fine, loaded the save file I had, all was good. But I went to start my turn with a berserk staff use, and selecting the beserk staff made my game do an immediate soft reset. I immediately knew “oh, something isn’t playing nice, it’s probably the Gaiden patch I installed.” so I closed the emulator again, went into my patches, and Removed the Gaiden patch.

I save the rom, load up the emulator again, load up the rom, everything’s running fine, go to use a berserk staff, and soft reset immediately AGAIN. Now I’m thinking “Uh oh, did I screw something up?”, so now I went to patches, and decided to uninstall the most recent skill system patch, and then reinstall it. Doing this did the trick, when I saved the rom, loaded it in the emulator, and used the beserk staff, NOW everything was normal with no soft resetting.

I went and checked in patches again, to the Gaiden spell menu patch, and there it is, sure enough, it says in the patch menu I have it installed when I don’t, and the most recent Skillsystem patch is causing this.

TL DR= Having the latest skill system patch installed makes it think you also have gaiden spell menu installed, even though you don’t, and you can’t access the spell menu. Trying to actually install the spell menu at this point borks things up. Not a big deal, but thought I would post my findings none the less.

#2

Please use more descriptive titles.
I think this is something you should be reporting to 7743, making it a new topic is just making it harder to find for him.

#3

Allright. I wasn’t sure if I should directly port it to him over PM given I’m relatively new here and it mostly deals with the skill system. Thanks, I’ll send him a message. Sorry about the not so informative title.

#4

If you don’t want to PM him just post it on the FEBuilder thread.
Also I don’t think this is what the documentation category is for, documentation is about knowledge of the game and stuff like that.

#5

This issue has been fixed in the latest version.
As I got PM, I fixed it.

This is a problem that occurs because SkillSystems hooks the same place where gaiden style magic is hooked.
There is only one place where gaiden style magic hooks.
And the current skill system hooks the exact same place as well.

There are several ways to determine if a patch is installed, but for patches that hook a specific address, it is easiest to check if that specific address is hooked.

So, I was checking if hooking was done at a specific address to see if gaiden style magic was installed.
However, confusion occurred because SkillSystems hooked to the same address.

I tried to check in another way.
This solves the problem.

When I ask a question in a thread other than FEBuilderGBA, I may not notice the question.
That’s because reading every thread is very time consuming.
I did not notice this time.

Ask a question in the thread of FEBuilderGBA, or, @7743, please mention me.

#6

Allright. will do next time.