FEBuilderGBA. Conversation. Text does not print anymore after [LoadOverworldFaces] + (TEXTCONT) commands

Hello everyone,

I have been working on a chapter end event in which I’d like an enemy shaman to warp in the middle of a conversation.

The current sequence of commands is as follow:

Start dialog (conversation)(TEXTSTART)
Conversation text[ 0x1FDA] Dialog (conversation) with no background (LOW)(TEXTSHOW+TEXTEND) *
Load one Enemy unit Character [ 0x4E CharacterName] with it’s default parameters at X[ 0] Y[ 0] (SPAWN_ENEMY)(LOW)
Character [ 0x4E CharacterName] appears, warp to X[ 9] Y[ 1]
Resume dialog (conversation)(used for BG changes) (TEXTCONT)
Conversation end(REMA)

(*) at some point in the conversation, the [LoadOverworldFaces] command is called.

Problem is that when the conversation is resumed after the warp animation, the text boxes are blank. Text isn’t printed anymore moving forward. The text printing sound effect can still be heard though, the portrait’s mouth also moves along with the supposed text, and the “press A” blue arrow pointing down is also correctly displayed in the text box. Just the letters won’t appear.

I think the problem comes from the (TEXTCONT) command which seem to work fine only with things such as changing background music. I saw it being used in FE8 Ch. 17 River of Regrets but for that specific purpose only. Lyon warps in between two conversations, not in the middle of one.

I could do the same of course (having the warp happening between two separate convs) but I wanted to make sure I am not missing something obvious here.

I saw mentions of a SCRO command here and there on the internet but wasn’t able to find it in FEBuilderGBA.

What are your thoughts?
Thanks a bunch.


Off-handedly I would think it might be that you need an ENUN function, or perhaps a… STAL? I think it was? Just to let the warp play out fully.

1 Like

I think this may fix it yes, as personally I’ve never encountered a [LoadOverworldFaces] command going wrong with the described set up above.

Either let the warp play out fully, or try playing around with an alternative conversation event.

It requires a bit of trial and error to find out what works.

Wow. If adding an X-frame STAL command right after the warp solves this issue, I’d really feel bad for not identifying this on my own. :sweat_smile:

Can’t wait to test it.
Thank you for your support.

1 Like

Pierre, if I’ve learned something about romhacking, it’s that most of the time it’s a simple solution that fixes difficult things. Sometimes you just need a different perspective, so no need to feel bad about not indentifying something simple like this!

I do hope that fixes it though, haha. We’ll be here to help if that’s not it either!


So… I did not work. :smiling_face_with_tear:

Hereafter are the multiple changes I tried:

  1. Inserting a STAL command between the warp and TEXTCONT commands (tried several durations: 30, 60, 90 frames)
  2. Inserting an ENUN command between the warp and TEXTCONT commands
  3. Inserting a STAL command followed by an ENUN command between the warp and TEXTCONT commands
  4. Switching the “Character [ 0x4E CharacterName] appears, warp to X[ 9] Y[ 1]” command by a “Character [ 0x4E CharacterName] warps to coordinates X[ 9] Y[ 1] with Speed [ 60 frame sec( 1sec)] (_WARP+ENUN)” command
  5. Number 4. + inserting a “Display Warp IN effect at coordinates X[ 9] Y[ 1] (SlotB+WARP_IN)” command after the “Load one Enemy unit Character…” command
  6. Number 5. + inserting a “ENDWARP” after the “Character [ 0x4E CharacterName] warps to…” command
  7. Number 5. + inserting a “ENDWARP” after the “Display Warp IN effect…” command

The ONLY thing that led to the text being printed is change number 4.
But using this alternate command implies the warp animation isn’t displayed (the purple-ish pentagram thingy on the floor). That is what led me to try changes 5 to 7.
I have to assume that it is this animation that somehow messes with the text print but I can’t figure out why.

I am clueless so far.

Your ideas are more than welcome.

There must be something wrong with the way I do this. Cause I tried doing a much simpler thing just for the sake of testing things out, and it failed too.

Here is what I did.

In another event, I had a character coming in, talking, moving, talking. I did this with two separate dialogs at that time cause I did not know about [LoadOverworldFaces]. Worked like a charm.

Yesterday I tweaked this event with two different designs:

and B.

The conversation is the following:

Both A. and B. ended up in the text box being messed up:

Then I guess the issue is deeper than just the warp anim.

Ah, that in particular is the text itself, toss in a [ClearText] or [CloseSpeechSlow] or something before the second bit begins.
Alternatively I think you might also just be able to put another line before the second bit of text? Right now it seems to reading the last line of the first bit and the first line of the second bit as a single line.

[ClearText] seems not to be a valid command but I used [CloseSpeechSlow] and it worked fine. Thank you Velvet.

Here is the updated conversation structure:

Unfortunately I reproduced this exact same event and conversation structure in my shaman warp chapter end event and it did not solve the issue. The text still does not print after the shaman warps on the map.

I have no idea what goes wrong here.

On a side note: is there a text control such as [ClearFace] that erases all portraits at once ? Just wondering.

Okay, a bit of a wild guess, but what if you put the shaman appearing and talking in a different conversation all together? Maybe starting a fresh, new conversation could help?

Yes, as touched upon in my first post, structuring the event sequence with dialog → warp → dialog works. The second dialog has its text being printed correctly.

I wanted to understand if I did something obviously wrong using the [LoadOverworldFaces] and TEXTCONT commands as I will most likely re-use them in the future (for other purposes but still).

Yet this was not all for nothing as I learned about [CloseSpeechSlow] and more globally got to explore FEBuilderGBA more in depth through your advice.

I’ll move forward with the two-conv implementation.

Thank you guys.