FEBuilder: Getting "Add Event" patches to work

#1

I am confused by why certain patches (listed under Advance Editor -> patch) within FEBuilder work for me, and some of them end up freezing the game.

Many patches work for me such as Max Range For Support Gains or Attack Miss EXP. However, many do not, such as:

Add Event: Give the unit experience points does not work for me, and freezing the game whenever I try to use the event. I am permitted to add this new event to the ROM, and it appears to write successfully. I can also use the event as an option when creating an Event. However, as soon as that event is run, the hack freezes.

Add Event: Unit_Take_Over is another that I noticed does not work for me. It follows the same trajectory as the above: The patch is written “successfully,” I can use it when creating an event, but as soon as I use the command, the hack freezes.

Is it because the two examples that do not work are Add Event commands? Is there some extra prerequisite steps or additional patch that much be carried out to get these to work?

#2

Please send report7z.
https://dw.ngmansion.xyz/doku.php?id=en:guide:febuildergba:report7z

I can not answer because that there is no data.

#3

I uploaded a report7z file with the example to a Dropbox if that is acceptable.

FE 8 “Add Event” Error Dropbox Link

I am mostly trying to understand why certain patches in FE Builder do not work for me and some do. I am assuming it is because I haven’t done some prerequiste step. Any information that you can provide would be super helpful. Thanks!

#4

A crash has occurred in a place earlier than that.
It is not good to write your event branch.

If you just want to give experience to the unit you are currently operating, just write:
There is no need to create a conditional branch.

#5

I think you are taking the wrong way of development.
Because, if you press F5 to develop this problem, you can see it immediately.

Because 0xC Niime is not at the party, it is causing a freeze.

#6

How to write unit branch of FE8 has a specification that is quite troublesome.
First, you need to issue “CHECK_ALIVE [Unit: 0xC Niime]” first.
You must use this command to confirm that the unit is at the party.
After this, if you do not issue an instruction, it will cause a freeze.

The reason why I worry about your development method is that you have not set up the emulator.

Emu:

If you do not set up the emulator, you can not debug by pressing the F5 key.
If you can not debug with the F5 key, you have to write to ROM every time, so it is very troublesome.
And if you make a mistake, it will cause a nasty problem.

Set up the emulator and press F5 to debug.
It is very convenient to use Menu-> Option-> “Initial Setup wizard” to set up the emulator.
You can set the environment with the click of a button.

  1. After completing the chapter, I would like to change the portrait from young Zephiel to adult Zephiel, but transfer all of the character data using the patched Event: Unit_Take_Over (see screenshot for line in End Event). This also freezes the game.


The way to write this event is not good.

The unit that can be a companion is up to Unit ID 0x45.
It is dangerous to use 0xF3.

If you just want to change Portrait, there is no need to use takeover.
takeover, like FE7 ninian and nils, wants to take over the status.

If you just want to change Portrait, use the patch below.
“Switch Portrait images by class, chapter, flag.”

#8

Thank you for the pointers regarding the debugger.

However, I have tried both the “Switch Portrait images by class, chapter, flag" and “Give experience value to the Unit currently being operated” as you have it in your screenshot with both crashing issues.

In fact, the “Switch Portrait images by class, chapter, flag" crashes as soon as the Chapter is loaded. I am getting this Unsupported BIOS error, and then the game freezes.

unsupportedBIOS

#9

What did you do this time?
Please send report7z.

Just in case, I also made it.
Works without problems.
https://www.mediafire.com/file/5cgsz03v9st35nn/1234.7z/file

#10

Interestingly enough the event that you created was virtually identical to another build that gave me an error. I tried running the the version that you had created and ran into the exact same issue… This made me think that the problem I had was with the emulator itself. I was running on Virtual Boy Advance 1.4.

I downloaded Version 2.0.2 and ran the ROM and did not encounter any error whatsoever on your version as well as my version. Is this actually a thing…? I find it difficult to rationalize how the emulator version can impact the actual events in a hack.

#11

Please try it with mGBA.
https://mgba.io/

If you encounter such a problem, please try other emulators.
Check the operation with an emulator developed with a completely different implementation.