[FE7] Weird glitchiness

I have been stumped for a while, trying to figure out what was causing such an odd glitch. A never-seen-before type glitch for me. Allow me to explain.
It only seems to be occurring in one particular chapter (0x0D, 11H). (That I have noticed)

This is the situation:

(Ignore the gate tile the units are standing on, as it occurs with and without those tiles)
Now, when I attack the mage using my thief, the battle seems to glitch out, resulting in a battle that goes: AttackerHit, AttackerMiss, AttackerHit, even though the battle is a non-scripted normal fight. I tried with the mercenary, and the attack worked just like normal. This seems to always occur on turn five for no apparent reason. This happens several times with different units, resulting in player units attacking only during battles. The game works fine for a while(with these glitches occuring), until another point where when another battle is initiated(by the player), the battle just lasts for a while until the game just simply crashes. I have no idea what causes this. Every battle the enemy or NPC engages in works just fine 100% of the time, meaning that the glitch occurs only when the player attacks.
There is also another incident where a mage at… let’s say [14,14] moves to attack the unit on the right side of the gate(assume that unit is in range). This mage:

(the one left of the cursor)
For some reason, the mage seems to duplicate itself three times, resulting in four different mages that start from the same spot and attack my unit. Only after the fourth mage from that spot does the duplication stop. And it only seems to be that unit.

Seems to do that with all battles involving the thief where the enemy’s attack is skipped and replaced by the thief’s attack, resulting in the thief attacking three times.

Here is a screenshot of the second glitch:

Any ideas on what might be causing this? I have been looking at it for about a week with no success at all.

What’s the character ID of the thief? Also, please post your events.

ID: 0x0B

Link to events:

Are you seeing the issue yet or are you still looking into it?

Apologies, I’ve been a bit busy. Will look into this later tonight.

The second glitch is just me being stupid… I accidentally spawned four units in that one tile… whoops.