[FE7] Inserting Map Sprite keeps crashing ROM

Is it normal for the insertion of map sprites to take up a huge amount of space? The moving and standing map sprites tables are repointed if that matters. I inserted the standing map sprite and it takes up only this much space:


D8F510 is the offset for the female thief standing map sprite.

but when I put in the moving female thief map sprite the resulting data chunks look like this:


it’s all spaced out and keeps going very far. Is this a normal occurence cause it seems to take up a huge amount of space? D8F6B0 is the offset for the female thief moving map sprite. I think you’re suppose to check the compressed box as well(?) but when I enter the offset I want to put the sprites at, the box unchecks itself and is faded ( can’t check it again after inputting the offset).

Is the sprite sheet suppose to look like this as well? Doesn’t matter if I put 2x32, 16x16, etc it still looks cut up like that. And as you can see, GBAGE won’t let me check the compressed graphics box.


I did also change the graphics pointer in nightmare map sprite pointer table. I left the animation pointer alone so far as I’m not too sure what that does. Doesn’t matter if I use a current class, such as the thief_f or make a new one such as 0x67, still it doesn’t work. So in the end, it doesn’t matter what new map sprites I tried to import, the game just crashes/freezes when I hover the cursor over the said unit.

The moving sprites take up a fair amount of space. Though, I guess it depends on what your definition of huge is.[quote=“Rickochet, post:1, topic:1404”]
I think you’re suppose to check the compressed box as well(?) but when I enter the offset I want to put the sprites at, the box unchecks itself and is faded ( can’t check it again after inputting the offset).
Go to the offset of a sprite that uses compressed graphics (the checkbox should check itself). Select ‘Import a bitmap’ and on the import menu enter in the offset where you want stuff to go. Once you import, GBAGE should jump to the offset you imported to and the graphics should be compressed.[quote=“Rickochet, post:1, topic:1404”]
Is the sprite sheet suppose to look like this as well?
No, it shouldn’t. But, I think that’s tied to inserting the graphics uncompressed. See above.

I followed your instructions and it worked, the walking map sprite animates in the game, but the standing map sprites don’t appear at all, even after I change the graphics pointer in standing map sprite module. I left the “unknown” and “size” alone.

i am using different offsets this time for testing so disregard the offsets listed above this post

are we not suppose to use the class slot 0x65 in class editor module? Its the slot immediately after the 4 “create your own custom classes” at the bottom of the class editor. It seems to freeze no matter I do to it. In fact, any attempts to make a custom class outside of editing existing classes will result in the game either freezing, random glitches appearing, or an odd colored light rune appearing in place of standing map sprite.


I double checked to see if I’m overwriting anything and I’m not, there are ample amounts of space between the repointed data arrays.

Despite them saying “make your own custom class” I believe they’re actually used for something. I think one of them comes into play when rescuing. I would steer clear of them to be honest.
Can you make a class like fighter or valkyrie (something standard) use your inserted sprites?

oh i didn’t touch or edit any of the ones that say “create your own custom classes” its the slots under the “create your own custom classes”, the ones you get when you expand the array, that are being wonky. yeah i can make any class use the moving map sprites i inserted but no classes, whether vanilla or custom, can use the standing map sprites i inserted.

What happens if you overwrite the pointers 1 degree up or down from the intended class? So if you’re trying to overwrite 0x67, try writing in that graphics pointer for 0x66 and 0x68 as well

nothing happens when i try with the other expanded slots. it is the same way to insert the standing map sprite as moving ones right? if so, then i’m really stumped.

you haven’t got both GBAGE and Nightmare open at the same time, have you?

no, i don’t have them both open at the same time.

what about this? is this: https://gyazo.com/0a03b3a491281a227e0507150cf650fa

equal to this?: https://gyazo.com/de6ba2ab6027d3087f0cb9f0e394541a

as in, is that standing map sprite slot 0x57 equal to the same 0x57 map sprite class slot in that drop down menu?

also, do you know which notepad file is connected with the standing map sprite editor? the one that has no labels and just numbers in the first image.

so after some more digging, i got to this stage. i did get the standing map sprites to work. although, the moving sprites either don’t appear or freezes up the game still.


if you would direct your attention to the empty moving map sprite, why is this? theres nothing overwriting anything else, and i tried several different animation pointers, but still nada.

the only thing in common is, these problems only pop up with custom classes. does anyone know anything else about map sprites that i could look into?

You’re doing something wrong because it shouldn’t be this hard. Can you link us to the exact graphic it is that you’re inserting? You’re hitting save after inserting with GBAGE, right? It just kind of looks like you’ve pointed to blank space. If you visit that address in a hex editor there is data there, correct?

I’m using the rogue moving map sprite from the map sprite repository here on feuniverse:


and this is the location of the offset in my ROM:


Yeah, I am hitting save after inserting the graphics in GBAGE and making sure to close GBAGE before i edit the classes in nightmare.

It really is supposed to be this simple.

My steps:

  1. Import the graphics to free space (making sure that they’re inserted as compressed graphics), then save.
  2. Go to the NMM and change the pointer of the target class, then apply and save.
  3. Stare at the animation in-game

I did those exact same steps. the only difference is my game either freezes up or nothing appears in the moving map sprite. and this only happens on the custom classes.


0x64 and 0x65 crashes the game when i hover my cursor over them on the map

0x65 no moving map sprite appears

0x67 and beyond: everything else after, just plain crashes the game upon loading the chapter (horrible screeching sound)

none of the problems appear when i edit the vanilla classes


the female sword cavalier and the female thief sprites all work fine but the blue rogue doesn’t. i’m not sure what else to look into.

If 0x67+ crash the game, there’s a decent possibility that you need to re-point the map sprite pointer array if you haven’t done so already.

it is repointed already

https://gyazo.com/7690ab89e6919ed24ebb8e2713b29d77 //top
https://gyazo.com/b6d79d66a2513c396d17dffe96504ef8 //middle
https://gyazo.com/aad6c2426242b3b81f4019375b5ce3a0 //end

D0540F is the bottom of the repointed map sprite pointer table. D055A0 is the beginning of the next area of data/ my imported map sprites

I also made sure that I have the repointed nightmare open when editing and not the default one.

would this solve my problems? it seems to be kind of buggy according to the comments.

the only patches I ever applied to my ROM was the no tutorial patch in the very beginning when i started hacking my ROM.

I honestly have no clue. Give it a go on a copy of your ROM and see what happens.

welp, after tinkering around some more, the above patch only expands the classes past 0x7F and didn’t do anything to solve my problem. man, this is getting frustrating…

just for documentation sake, i managed to fix my problem by going in hexator and zeroing out the area where the repointed map sprite array was and copying and pasting my map sprite array to the same area. then i did a checksum in feditor and everything seems to be working order thus far.