FE Builder Questions!


#1

Hey! I’m quite new to FE hacking so after struggling with EventAssembler I thought I would try out FE Builder. A problem has occurred though and I haven’t the slightest clue on how to fix it…

See, every time I click “Add New Tile Changes” in the Map Editor Menu, I get the Message: “PList = 0 can’t be written. It should always be 0.”

At first I thought this was just my edited patch and that I would just have to restart with a clean ROM; however, even after putting in a completely new ROM, it still produced the same message.

I’m using a FE7 ROM if that helps. If anyone could please teach me how to fix this problem, that would be great. Thanks!


#2

Welcome! Discord is really useful for questions like this b/c people are active and can answer you in real time.

I believe this may be a bug in this case, @7743. I just tried troubleshooting this and I got this error any time I clicked “Added Tile Changes” to a map that doesn’t already have tile changes in it. The button worked on any map that already had 1+ map changes.


#3

It seems that this bug has fixed a long time ago, but it has relapsed.
I will fix it next time.

This problem occurs in FE 7 Prologue and ch 1.
Since there is no map change in these chapters, PLIST used for map change is set to 0.
(In FE 8, the map change PLIST is also assigned to a Prologue without map change).

If there was no PLIST available for map change, it was supposed to automatically display the reallocation screen.
But for some reason this is not working.

I will fix it next time.


#4

I fixed it with the latest version.(20180328.21)


#5

Oh I wasn’t expecting help so fast. Thank you so much, I have it working now!