FE_Builder_GBA -- If you have any questions, attach report7z

I’m experiencing a bug which I don’t know how to fix?

I’m working on an FE8 hack, the rom works fine when I start from the beginning and play through normally, but when I reset or suspend, the chapter fails to load when I want to restart/resume it. I used both Mgba and VBA-M but the same issue occurs.

I’m thinking there’s a patch that fixes this but I don’t know which one it is.

I has been answered by discord.

1 Like

I seem to have a bug on my FE8 hack.
This is sort of hard to explain but when the player unit gets into a battle it seems to never end.
The enemy/player does little to no damage, sometimes they get healed after dealing damage and when they are supposed to die let’s say a critical hit, they do 1 damage and die when their HP Bar isn’t depleted.
But the end result is the same: the enemy dies (fades away) but still attacks dealing no damage while they are invisible.
I can only think that it was a patch bug.

I’m going to save 7743 and other people the trouble of asking. If you have a problem,
please send a report7z.

We can’t help you if we don’t have any reproducible data to work with.

1 Like

Thank you for this amazing piece of software, though it works on Linux?

There are two options to use FEBuilder on Linux.

The first one is to use wine, though it isn’t very reliable with FEBuilder. Sometimes doesn’t work, sometimes it works just fine. I’m not sure about the more advanced tools like the debugger working with wine though.

The second, more reliable option is to use a Windows Virtual Machine. This can easily be done with Oracle VM VirtualBox.
Any Windows version from XP to 10 should work (Windows 11 has been largely untested, but I’ve heard that FEBuilder works on it. Whether or not Vista works is unknown).
FEBuilder is a 32 bit program, so you don’t need to use a 64 bit Operating System that would take up more resources.


It does not work on Linux.
You can use wine to run some parts of the program, but the debugger will not work, so your development efficiency will drop considerably.
If you really want to use Linux, please install a VM and install Windows XP or later.
FEBuilderGBA is written in C# 4.0, so you will need an environment that can run it.

I have two issues I’m not sure about.

  1. Map Standing Animations from “D0” and above do not display correctly.
  2. Narrow Font doesn’t display correctly despite formatting it like this: [_H][_e][_l][_l][_o]

Here is the report:

Thank you in advance for your help. You’ve always been awesome and I appreciate the time you give.

  1. Map Standing Animations from D0 and above do not display correctly.

In which class of which unit can it be confirmed?
In which chapter is it?

  1. Narrow Font doesn’t display correctly despite formatting it like this: [_H][_e][_l][_l][_o]

Which data can confirm it with?

In which class of which unit can it be confirmed?
In which chapter is it?

Class EC, ED, EE in 11 Ch16 Cell Block demonstrate the problem. The problem can be recreated with any class on any map by changing their Standing Animation to D0 and above.

This is what the map sprite should be:

But it loads the helicopter map sprite instead:

Which data can confirm it with?

You can see the narrow font not working in Item ID FB.
Text ID is 113.

Regarding the character string, I think it is because [_m] does not exist.
Try pressing the write string button once.
I think the correct value will be inserted.

It’s probably by design that you can cross D0 in Standing Animation.
This is because GBAFE only sets the lookup table up to 0xD0.

The front and rear RAM is used for other purposes and cannot be expanded.

One possibility is to move to another RAM area.
For example, SoundRoom is one of the screens that does not display Unit.
A vast amount of RAM is reserved here to process the Sound Room.

For example, you can display it by forcibly moving the buffer as shown below.
However, it is necessary to further verify whether or not this side effect is present.

If you want to focus on safety, we recommend that you do not use it after 0xD0.
If you really want to use it, try running the EA below.
You will take risks and take action.

for FE8U

//gSMSGfxIndexLookup 02033F40
//SoundRoom Buffer 0201F148

//standing Animationバッファは0xCFまでしか確保する領域がない!
//The standing Animation buffer has an area to reserve only up to 0xCF!
//I couldn't help it, so I decided to borrow a Sound Room buffer that I wouldn't use at the same time.\r\n
//I won't return it anymore, but lend me one. I just borrow until you die.

ORG 0x2668A

ORG 0x266B8
WORD 0x0201F148

ORG 0x266BE

ORG 0x266EC
WORD 0x0201F148

ORG 0x26778
WORD 0x0201F148

ORG 0x267F8
WORD 0x0201F148

ORG 0x26834
WORD 0x0201F148

ORG 0x268C4
WORD 0x0201F148

ORG 0x26F28
WORD 0x0201F148


Thank you so much, 7743! That’s really englighting about the Map IDs- I’ll look into it further. Also it was a nice and easy fix for the narrow font!

Have a lovely day!

I’m currently having an issue with my rom hack.
What I found is that after finishing Chapters 8/8x, a lot of units just proceed to leave the party (including Roy), and leave empty slots. Along with this, an enemy pops up on the Laus node, which should be impossible since I disabled monster spawns.
Any ideas why this would be caused?
Here’s the 7z report.
also how do I center things with the camera on the world map? I’ve been trying to have things centered by having the same x & y coord as the node but it’s too far right :c

After completing Chapter 8/8x, Roy, Marcus and some others proceed to leave the party, leaving you with ~5-6 units (these are all tested with ones you get at the start of each chapter).

This is because you are using LOAD3 incorrectly.
LOAD3 is a command used by the player unit to load the crowd.
It is not a command used against enemies or NPCs.

When loading enemies and NPCs, use LOAD2 instead of LOAD3.

When using LOAD3, it’s time to create a scene where the player takes his friends and does something.
For example, a scene where a player gives a speech to his friends.
At this time, LOAD3 is used to load the units participating in the party as an audience.

The road to the next chapter is added and for some reason, an enemy pops up at the Laus node.

use this patch.

NAME.en=Toggle World Map Monster Skirmishes
INFO.en=Sets whether or not monsters will spawn on the world map.\r\n


I’m a bit confused at how the FE6 droppable items patch works. It says that in order to activate it for a unit, you have to set the bit flag of 0x40 to AI4. Where would that be?

This was because the translation resources were not set up well.
I’ll fix it.

Adding that patch will add a list to this Combobox.

Hello, I have a little problem with a route branch in chapter 9. Could any help me with this? Link of Report

PD: I forgot write this in the report, in any file or Back Up doesn’t works.

When you finish the chapter 9 and want to go the Route B, the game no load right the chapter appears a strange unit phase and strange graphics but with no any unit or any event, when you check the Route A this works right.

I’m not sure what the your question means, but are you talking about MapID 0xB?

I think StartEvent isn’t working because world map skirmishes are happening.
If you disable it in the Map Loading Process, it works fine.


1 Like

Hi, I tried uploading my own custom portrait into the game, but for some reason the eyes and mouth would not allign with the rest of the face, even when I tried using the X/Y buttons, they would move more then necessary.

I don’t know what I did wrong since the portrait image has the right dimensions and I followed the tutorial videos as best as I could.

Also sorry if this question is something that has being asked a million times before, but I’m very new to this and don’t know where else to ask.