FE-Builder - Disable level up

Hey : )

I wanted to know, if you can disable the level-up system alltogether for the FE-Builder?
for my project in progress, I dont require it, and it doesnt make sense as the adventure only lasts as few days/weeks, and I dont think anyone would get much stronger there, it also makes balancing easier for now

is there a way to do this? my emergency-solultion (if possible) would be to make every character level 20 in their entry-level, but that doesnt seem too fancy, so maybe there is another way to disable this

thanks for the responses in advance!

Set all enemies to grant 0 exp

It’s a checkbox in the character/class editor

Even easier would be just to have the exp routine always return 0

ORG $2C534 
asm("mov r0, #0")
asm("bx lr")
1 Like

The ASM fix is probably the way to go here, since enemies not granting EXP wouldn’t stop staffers or refreshers from gaining EXP.

1 Like

thanks for the replies!

but I have no idea how/where to code in the FE-Builder and also dont know what you mean with the ASM fix (still trying to learn the tool)

is there any reference I could read about?

Use the Set Unit Status Patch to write 255(0xFF) to Exp.
That will set Exp --, You can refuse any EXP.

This is because EXP for steal and dance must also be disabled.

1 Like

thanks for the quick responses, I m still lost though, got too many questions on how-to :grin:

I guess for now I ll just make everyone lvl 20 or something, I consider this as solved though, others with more knowledge than me could use these

ORG $2C534 // general exp formula 
SHORT 0x2000 0x4770 // mov r0, #0 & bx lr

ORG $2C676 // steal 

ORG $2C6CC // dance

ORG $2C6D2 // summon
  • copy my code into a .txt/.event file
  • use Insert EA

1 Like

ohh, nice, thanks for the detailed description :slight_smile: