Absolutely mystifying impossible to understand ITGV glitch

CharacterEventBothWays(0x2E, SthNoteBridge, Eliwood, 0x83)
CharacterEventBothWays(0x2E, SthNoteBridge, Lyn, 0x83)
CharacterEventBothWays(0x2E, SthNoteBridge, Heath, 0x83)
CharacterEventBothWays(0x2E, SthNoteBridge, Leila, 0x83)
// Basically 0x83 is the shiny thing on the ground that a character can interact with. which takes the char slot 0x83

UNIT 0x83 0x6E 0x00 Level(1, NPC, 0) [9,15] [9,15] [0x00] Guard
// this unit gets loaded after an event is done

ITGV MysNote7 // Cryptic Note item that uses the Emblem Seal icon
DISA 0x83

// this is the event that happens when you talk to the shiny thing. Simple enough, right?

or this

The item a character actually gets seems to be garbage. And I’ve tried literally everything to figure out why and how it would give garbage.

the fucked up thing is it was working normally, but after closing everything down and coming back to it, it started giving me a garbage item. Then I looked in my events and I realized I literally didn’t change anything. Then I spent a literal hour with @Primefusion and @Snow trying to figure out ways to fix the issue.
We ended up using every trick in the book to trouble shoot it. And eventually I used another character ID. That worked only for a bit, but then afterwards, what was supposed to happen, stopped happening and the garbage item giving began anew.

it gets even more fucked up for me. Because If I just go from this
CharacterEventBothWays(0x2E, SthNoteBridge, Eliwood, 0x83)
to this
CharacterEventBothWays(0x2E, SthNoteBridge, Eliwood, Lyn) //or whoever else on the map
i get the correct item.

so then I was like, okay. Fine. I won’t use character ID’s around there for a ITGV event. I’ll use like, Louise instead,

But again, no dice.

Prime and I even went in HxD to see if the game is misinterpreting the event. But again, nothing out of the ordinary.

Its the item is becoming garbage for reasons I don’t understand!??!!?!

ITGC, bro. ITGV might be tied specifically to the visit command, or more broadly to location events, in some fashion. That’s the only thing I can think of that might cause this sort of issue since you’re using ITGV with a talk event instead of a location event.

Either you gotta find a way to make it location based, or fix your current setup with IFCAs and ITGCs.

We tried that too, the literal exact same thing happened when we tried the same thing except with character 0x80 giving a ChestKey.

ITGC didn’t work, in fact, the event changes itself (we tried adding a TEX1 and a CURF on the active unit) would actually not register with the game and the glitchy event would constantly happen.
But yeah, ITGC didn’t work either for a bit.

And after testing, ITGV works for other units.

at this point, i just have this deep, deep feeling that something is seriously fucked up with my game.

@Primefusion used character ID 0x80 in TRTR as a test, with the exact same event and it worked for him

i think i figured it out?

I had a space after Note
this works
/#define MysNote1 0x9C//

/#define MysNote1 0x9C // but apparently that fucks it up.

not entirely sure but… don’t leave a space hanging after you define something??

still doesn’t explain why ChestKey was turning into garbage though… hnnnng