[FE9] Character Editor and Randomizer [v1.2]


#44

I seem to be having some sort of issue. I got the root folder, but I just can’t seem to even open the Editor/Randomizer

I feel like I may be missing an important file, but I’m not sure as to what


#45

I haven’t had a chance to try this out, but thanks for sharing it! I’ve always wanted to try a randomized run of FE9.

I had a small feature request too, just for something down the line: could you include a feature to do a reverse recruitment run? I know it’s necessarily a random feature but reverse recruitment runs are also popular and it’d be nice to have a one-click button to have a loadout that reversed the cast and ensured all the items, textures, events, and such were correctly reversed instead of the user having to do this.

Regardless though, thanks again, and good luck with your semester!


#46

I’m sorry, I don’t understand, do I have to run the batch file to get it to work? Windows warns me against it. I just don’t understand how to install the randomizer is all.


#47

The batch file just runs the command for running the executable, but if your Windows doesn’t trust it you can just type what the batch file does into a command line yourself:

cd “[directory of the randomizer]”
start bin/java.exe -m FE9Randomizer/contents.Main

Include the quotes but not the square brackets.
You can get the directory by just copying the address bar in windows explorer where you have the folder open.


#50

Okay, so i figured out how to extract the files out of the ISO file but the application isn’t seeing my Zmap folder? it extracted the Zmap but it’s not being picked up


#51

Suuuup
when i try to rebuild the root it says it misses the &&systemdata. I tried to redo the whole thing but it doesnt work.
THX!!!


#52

&&systemdata usually means you didn’t remember to mark “Also extract header, apploader, DOL, and TOC” in GCTool


#53

are you getting the “zmap contents missing” error? That one actually checks for \zmap\always\dispos.cmp, is that file in your folder? what folders are in the zmap folder?


#54

When I do the GCtool extract it would crash, don’t know why.
So i tried to just manually do the header, apploader and etc. I put them in &&systemdata, but the GCrebuilder is wanting a iso.hdr, and i don’t know what that is.


#55

I have dispos in my always folder


#56

I don’t know what i changed if I did anything at all but the randomizer was able to pick it up today ¯_(ツ)_/¯


#57

alright thanks it works now

thanks for the randomizer its much appreciated


#58

Is the GC-tool I’m meant to use what I found after a Google search on GBATEMP.net? Honestly, if someone could provide one I’d love a video tutorial of how to patch becasue this all seems very confusing.


#59

Hi just a quick question from someone who is new to modding of any kind: How do I apply changes to a save file that is already in progress? I’ve been making my way through the game with custom edits to characters and the idea was to just fix problems as the occur, but it seems character attributes want to stay the same even when I apply changes. For example, I realized that the thief class doesn’t come with lockpicking attached to the class, so I tried to change my thief Rhys’ serenity skill to lockpicking, but when I load up the game and save file from the point I was at, the changes are completely unapplied, even though I know the changes have been made to the base rom.


#60

If it is anything like GBA modding, the changes won’t take affect if the unit has already joined your party. In order to make changes, you have to make them before a unit is first loaded into the game - e.g. at the start of the chapter before they are loaded onto the map etc.


#61

As a rule, modifying things in the rom does not affect the save file. Rhys was loaded in with his default skill, and if you save your game, the game remembers he had his defaults, and ignores the changes you made. How else is the game supposed to remember he learned a skill with a skill scroll, say?


#62

Thanks!


#63

Hey, does anyone have a good list of the different unit models (“Textures”)?


#64

I’m super new to this, just downloaded GCTool and GCRebuilder to do this, and I can’t seem to rebuild my file? I was able to extract it and randomize everything, but it doesn’t seem to want to rebuild, any suggestions?


#65

What error is the rebuilder giving you? If it is &&systemdata missing, you didn’t mark the necessary option in GCTool. If the rebuild button is greyed out, did you open the proper root folder, and save it to an iso? If you are trying to overwrite one, maybe try making a new one instead?