[FE7] Potential FEditor Adv Bug? [SOLVED]


I’ve just begun editing the text while hacking FE 7 using FEditor,
and whenever I change any of the text, then save it and try to open the
ROM, the following happens: the game will run smoothly until it reaches
edited text, then freezes before displaying it.

For example, at input index 0813 in the FE 7 ROM, I make this change:


Are you awake?[A][X]


Am I awake?[A][X]

I’m using the VisualBoy Advance Emulator, and turned on logging of
‘illegal byte read’ and ‘undefined instruction’ from the tools, and it’s
printing a lot of the following message

Does anyone know what I’m doing wrong? I attempted to dump the text contents, make this same change, then insert the modified text back in, but it gives a similar error. I’ve also tried making smaller changes (only 1 character difference) and get the same error.

Hextator’s made it clear that FEditor Adv should be idiot proof, so I’m wondering if this error is from an OS difference. I’m running Windows 7 Professional through Bootcamp on a Macbook Pro, with the latest version of FEditor. My Java version is 1.8.0_91. Has anyone else tried ROM hacking through a Bootcamp Windows OS?

Thanks very much in advance, and sorry if this error has already been addressed!


No. No, it most definitely is not idiot-proof. Hextator’s opinions are, shall we say, not widely-appreciated in this community.

Now, as to fixing your problem. If you’re bound and determined to use it, try opening your rom in Feditor, save it, and close it. Then reopen and do your text edits. Usually, that makes things not break as much.

If you’re trying to do a hack (or at least, something more than just changing a few bits of text here and there), it might be worth looking into this. Yes, it takes a bit more time and effort to get used to, but it’s less likely to do whatever caused your issue.


If it’s still not working for no reason, I seem to recall the game crashing if you edit the “Are you awake?” text without using custom events.

I hit like on this post because it is such a well written-out question and it is very clear you have tried to fix the problem yourself


I think tequila’s right – it may be that the autopatches(namely, the anti-huffman) weren’t applied.

… maybe.

1 Like

Thank you, @Tequila and @Crazycolorz5 ! This solved the problem. For anyone else reading this who might have the same error, from my experimentation it seems like you only need to do that once, then the rest of the editing is unrestricted, as I just figured out from this test:

@Alusq I just tested editing the very first text and it seems to work after the initial open->apply->save->close sequence.

@Agro thanks! I figure these troubleshooting questions should be as informative as possible so that people in the future can learn from them as well :]

1 Like