FE_Builder_GBA


#1658

I don’t understand what is it I need to do?


#1659

You need to have Eirika joined in the party at prologue.
Please look at the modified ups patch that I posted to discord.


#1660

Sorry for the dumb question but what do I do with the ups file


#1661

I fixed that event to work properly.
I presented the example in the ups.

You do not know how to use ups?
Please D&D ups file to FEBuilderGBA.exe.
You can check what I modified.

I changed the start end of the prologue and added eirika to the party.
This problem is not a problem of ch1.

It is a problem that is occurring because ch0 (prologue) does not make eirika a join.


#1662

I fixed the issue in another way… I made my main character unit replace Erika. And the issue is fixed.


#1663

I’m currently having an issue with my FEBuilder.
For some reason, I opened FEBuilder and the text wasn’t showing up. I opened my rom and the entire editor wasn’t showing any text. I very confused on why this happend, and would like some help.
Normally I would create a report, but I cannot see the text and I don’t know what to do otherwise.


#1664

hmm. Was the translation file broken?
(FEBuilderGBA\config\translate\en.txt was broken?)

Please re-download FEBuilderGBA , again.
Still not resolving the problem?

If you can not solve the problem after re-downloading Latest version,
please tell me about your environment.

What OS are you using?
Windows10? Windows8? Windows7? or Wine@Linux? Wine@Mac OS?

And, What language do you use OS?

I want to check another one.
Did you change the Color setting with Menu->Option->Setting?
Has the rendering color of the character string been the same as the fore color and background color?

The setting of FEBuilderGBA is recorded in the following file.
FEBuilderGBA\config\config.xml

If you erase this config file and start FEBuilderGBA, it works with the default setting.


#1665

Erasing the config file worked for me.
Thank you for your help!


#1667

Hi, new to RomHacking (been at it about a month now).

Is there a way to change the palettes for player / enemy / NPC units on the map, using FEBuilder? Instead of blue/red/green. I’m working on FE8 if it’s relevant.


#1668

(non helpful comment alert) What colors were you thinking just curious?


#1669

The unit icon palette can be changed from SystemIcon.
However, I recommend that you do not change it unless there is a special reason.





#1670

Thank you kindly 7743!

@The_Snek_Lord I was thinking of maybe changing the player palette so it contrasts with more map tiles, so at this juncture I’m not sure which color.


#1671

Hi guys, I’m having a issue with a modified FE 8 Rom: after suspending and resuming a chapter, all player and ally units are erased. This seems to happen in every chapter. Got any ideas what could be causing this? Lint doesn’t report any errors.


#1672

I believe you will have to report the issue. best to make a .ups patch zip it and reach out to 7743 either here or on discord for assistance.


#1673

Already did that. I just hoped that maybe another person experienced a similar problem and found a fix.


#1674

I replied to you with discord.
It is because you destroyed the class expansion patch between August 29, 2018 - September 3, 2018.


#1675

I get this error from time to time. I can’t click on the center of the map…


#1676

I Fixed this bug in ver 20180915.08.


#1677

Thank you, it works now.


#1678

FELint of FEBuilderGBA finds problems and gives warnings.
This function can also be used from the command line.

start /w FEBuilderGBA.exe --lint FE_Hack.gba

When this command is executed, FELint check is executed for FE_Hack.gba.

Also, you can see if there is an error in the return value.
0 has no problem.
Other is the case when there was something wrong.

start /w FEBuilderGBA.exe --lint FE_Hack.gba
if %ERRORLEVEL% neq 0 echo "FOUND ERROR!"