FE_Builder_GBA


#1516

The update solved my problem of the Modern Character Growth patch. Thanks


#1517

Hello! I’m still fairly new to hacking and just made my account for FEU! I applied the skills patch to a FE8rom I’ve been hacking, and all works well when I start a new game. But if I continue from a save file that has already been started, I’m at chapter 14, it seems to scamble everyone’s class skills.
Everyone’s personal skills are fine. Is there anyway around this, is this a known glitch or did I just mess something up?


#1518

Probably just the skill patch that messes with old save files. You probably have to start over.


#1519

I want to reproduce that state, please send me report. 7z.
It can be created from MENU -> File -> Create Report Issue.

Upload the created file somewhere and tell me the link.


#1520

@7743 Is it possible for me to create hidden items / desert treasure with FEBuilder?


#1521

How do I remove the path split after chapter 8?


#1522

Since there was a bug, please use ver 20180802.22 or later.

Treasures of the desert can be created by “Range Condition” of “Alwyas Condition”.
Please add an area to “Alwyas Condition”.
Then select “Range Condition”.

Please set the flag.
If you do not do it, you will be able to pick up treasure again and again.
Please use an empty temporary flag area such as 0x10.

Specify coordinates.
This time we will set up on the other side.

Click New Event.

You can write your own event from the beginning, but it is a hassle.
The treasure of the desert is registered in the template, so please use it.

Please check the event(click the Event).

By default, 0x88 Master Seal can be picked up.
Double click and change to your favorite item.

Please start the game and check the operation.
Since items are picked up randomly, please let wait the unit several times.
(I picked it up the item at the second turn.)


#1523

It is easy to turn off the root branch, but afterwards your modification will cause problems.
The root branch is in this subroutine of the 0x38 Castle Frelia on Start Event.

Branching is implemented in this ASM.
You either fix the results of this routine,
You should modify the event.

But there are things to be done with care.
That is, you need to enter the correct value in “Editon”.

0202BCF0	@ChapterData	Area of the stage.	{U}
@ChapterData@1B	byte	  Editon Prologe=0x1,Eirika=0x2,Ephraim=0x3

That is, it is recorded in 1 byte of 0x0202BCF0 + 0x1B = 0x202BD0B.

In this branch event result, the edited data is confirmed.
Until then, Prologe = 0x1.

In the latter stage (Ch 17 River of Regrets or later), the event is subroutineized.
At that time, referring to the edited data, the following writing style is frequently done.

if (0x202BD0B == Eirika){ } else { }

If you forget to edit the edited data, it will behave oddly.


#1524

Thanks


#1525

Quick Question, Previous to me using Febuilder I had My Class list repointed. Febuilder does know the new adress, but not the size, It only shows 100 classes, but I have 134 working classes. How do I make Febuilder Know the True Size of my class table?
ROM is FE7US


#1526

Make sure that the ID (+ 0x04) of the 100th class table is not 0.
To determine how many data there are, decide by searching the table.
Clear termination data is not defined for FE.
Even if it reads data, if it is data that does not make sense, it is recognized as termination data.
In the case of classes, ID (+ 0x04) is evaluated.
The first data is ID == 0, but after that it should increase according to the number of data.
It is recognized as invalid data that this data is 0.

        , (int i, uint addr) =>
        {//読込最大値検索
            if (i == 0)
            {
                return true;
            }
            uint no = Program.ROM.u8(addr + 4);
            return (no != 0);
        }

#1527

So, I’m not sure if i did something wrong or what because I applied the new apparently not buggy class expansion patch but my class list isn’t expanded.

So I don’t know what to do.


#1528

Please create support.7z on Menu -> File -> Create Report Issue, and send it to me.
With support.7z, I can reproduce your problem.


#1529

When I apply Display All 8 Weapon Ranks patch and/or Limit Weapon Rank Display Patch I am no longer able to put the cursor over the weapon type. Like so

pic after applying patch


#1530

It seems to be a limitation of that patch.
There is no workaround yet.


#1531

Ok, thanks for the fast response as always.


#1532

I try to input thai language but not working -*-
plz help


#1533

There was a problem in “Double Maximum Possible Stats (Breaks Saves)”.
As a fixed version, “Double Maximum Possible Stats ver 2 (Breaks Saves)” has been released,
so those who use this patch will recommend updating to a modified version.
This is a problem that occurred when porting “Breaks Saves” from FE8J to FE8U.

To update, after updating to FEBuilderGBA ver 20180809.01,
Uninstall “Double Maximum Possible Stats (Breaks Saves)”
and install “Double Maximum Possible Stats ver 2 (Breaks Saves)”.

I appreciate @Tequila who fixed bugs.


#1534

The thai language does not seem to work well.
I will investigate later.

What did you try to enter?

I do not know thai language, so I copied it from wikipedia.
Hello to สวัสดี

I tried to display this string on the screen.
However, it did not work well.

It seems It can not find the font.
Perhaps there is a bug in my implementation.
I will investigate later.


#1535

It was fixed with ver 20180809.08.

I had a simple mistake.

-if (0xE0 > moji[0])
+if (0xE0 >= moji[0])
{
}

Thai language UTF-8 code started just from 0xE0.
For that reason, we were unsuccessfully searching for fonts.

Please update the version of FEBuilderGBA and try again.
You should be able to import the font this time.