FE_Builder_GBA


#1256

I can give you the ROM, because there are too many wrong animations, there is no attack animation, there are some attacks that will continue to run the animation.
Please check the animation CC,CD,D1,DC,DE,D0,E2, and ZHE.


#1257

The connection:https://pan.baidu.com/s/1tmQfjhRAhEvX5ubdjWHRQA
password:cd53


#1258

Hi, I was trying to insert some unique animations into otherwise vanilla FE7, and I’m having trouble extending the list in the individual animations editor. When the list is extended, it copies the first entry (Lucius unpromoted) as usual, but all the new entries seem to be linked. That is, when one is changed, all of them change, including Lucius unpromoted. Here is an example where I tried to give Matthew a custom promoted animation:

https://mega.nz/#!qLRkABBA!iNDBRc7CT0I-XtNFRpthimeHElKMqnj4IUhKWQvSitc


#1259

I think I taught how to make ups last time. :frowning:
I will be angry next time you do the same.

Overall, I think that the animation is incorrect.
Where did you download this animation script?
Did you make it?

For example, animation ID: CC.

Motion of melee attack does not exist.
Wizards should define both range and melee.

I think that this motion is not a melee attack motion, it looks like motion when you do not have any items.
In this animation file, the order of definition of motion is incorrect.

There is absolutely no motion when you make an attack mistake.

 Motion of battle animation must be arranged in the following order.
    01=Melee Animation
    03=Melee Critical Animation
    05=Ranged Animation 
    06=Ranged Critical Animation
    07=Dodge Melee Attack
    08=Dodge Ranged Attack
    09=Equiped with Melee Weapon
    0A=standing motions?
    0B=Equiped with Ranged weapon
    0C=Attack Missed Animation
 
    //Chinese translation.
    01=攻击命中时的动作
    03=攻击必杀时的动作
    05=间接攻击的动作
    06=间接攻击必杀时的动作
    07=被攻击回避时的动作
    08=被间接攻击回避时的动作
    09=站立不动的动作
    0A=站立不动的动作?
    0B=间接时站立不动的动作
    0C=攻击失误时的动作

Animation ID: CD.

It is dangerous to use C47.
As explained here, C47 is a hard coded command.
If you want to shake the cloak, please make a loop using C01 hack.

There is no mismatch in this animation.
Also, it seems that some images are broken.

Animation ID: D1.
An animation with a sickle like ruwy.

I could not find a problem with this animation.

Animation ID: DC.
I could not find a problem with this animation.

However, it is another cause that attacks are not hit by motion.
UnitID:1F 阿尔托莉雅 is Class ID:7 圣骑士 (Paladin)
The reason why her attack does not hit is because her weapon level is wrong.

Dark magic is selected as the weapon level of UnitID.
And the class is a paladin where swords and spears can be used.

This kind of phenomenon occurs when you create a class that can use both weapons and magic at the same time.
You can not use weapons and magic at the same time unless you apply a patch that makes it available at the same time.
In FE, range attacks are always selected for units possessing magic.

But the weapon she has is steel sword. There is no indirect motion in this weapon.
Therefore, it does not operate properly.

If she erases the dark magic and sets the weapon level of the sword and spear, the problem is solved.



#1260

Thank you.

If possible, will not you name the ACSII code just next time instead of Chinese folders?
In Japanese windows, I can not recognize some Chinese file names, so I need to unrar it on Linux.
If the file names are all ACSII code, there should be no problem.

FEBuilderGBA also became a problem as it used to contain Japanese filenames before.
Therefore, I changed all Japanese filenames to ACSII code file names.


#1261

Fixed in Version: 20180521.06.
For duplicate individual animation, a separate button is displayed.

You can separate animation data by pressing this button.


#1262

Since Lint’s error message was incorrect, it was fixed in Version: 20180521.07.

Lint was telling you the wrong message.

This is the correct message.

I want the ID of item ID: D8 to be D8.
The ID must always be in the order of arrangement.

It will fix it as follows.
ID 00 -> D8

Always match the order and ID displayed in the list box.


#1263

Can you understand the joke written in readme.txt of FEBuilderGBA?

名前の由来は、 某LANDのアレからです。
The origin of the name is from 某LAND.
这个名字的起源是来自 某LAND。

某LAND pronounces bo: land.

某LAND -> bo: land -> Borland
so, This is about Borland.

Borland was developing RAD tools such as Delphi and C++ Builder.
In the past, it was an excellent development environment comparable to Microsoft’s VC ++.
Developers who made Delphi and C ++ Builder moved to Microsoft and developed C#.

The name of FEBuilder’s “builder” name comes from here.


#1264

Amazing thank you! It works great


#1265

I posted the file.
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA#a826589e


#1266

Thank you, I will use your suggestion in the future


#1267

Thank you very much for your reply, I didn’t think he can lead to bugs, secondly, I’m sorry about the ups patch, I appreciate your explanation, but I still don’t understand his meaning, he is difficult to me.
The animation of the sickle is that he seems to be similar to the “狂王” animation that the import will cause the crash, and I think it can be solved with the “adv”.
Thank you very much!


#1268

Hey man, we are eternally in your debt, you always help us and made this amazing tool, thanks a lot for helping us noobs all the time


#1269

, but I still don’t understand his meaning, he is difficult to me.

Which explanation is difficult?
Please write a little more concretely.

Is it difficult to make UPS Patch?
I made a manual.

[中文]如何制作UPS补丁,自适应​​方法
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA/如何制作UPS补丁,自适应​​方法_ZH

[日本語]UPSパッチの作り方、適応方法
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA/UPSパッチの作り方、適応方法

[English]How to make UPS patch, adaptation method
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA/How%20to%20make%20UPS%20patch%2C%20adaptation%20method_EN


#1270

7743 Sir, I want to be a prop, similar to the “holy water” used in a certain round after blessing in certain attributes, I try to give a prop ability to add value, then the effect of the coupled with holy water, but you can’t use, is to let him on feb implementation?


#1271

It is difficult to add items that can be “used”.

Unfortunately, it is not possible to use it only by choosing the effect when using the item with the item structure.
It is because there is a discrimination as to whether the item is available.

For example, if HP is not decreasing, you can not use Vulnerary.
If you want to grow the status to the upper limit value, you can not use because you do not need to use stat booster.
Promotion Item can not be used if Promotion can not be done.

In other words, it is necessary to examine the state of the unit and determine whether or not that item can be used.

In this way, first of all, it is judged whether or not the item can be used.
If available, the item will be displayed in the menu.

To determine if an item is available, ASM is used.
From FEBuilderGBA you can access it from “Item Use Effect”.

Item Use Effect screen specifies the ASM function for determining whether items can be used, ASM functions to be called when using items, and so on.

In this table, specify the ASM function for that item.
By default, it covers only a part of the table, so expand the table so that it can cover the entire item table.

Next, set up conditions that your items are available.
If there is no problem with the same judgment routine as the existing item, copying the address(pointer) of the routine .

By reading so far, you may be expecting.
That is right.
If you want to create items that differ in behavior from existing items, you need to write yourself the judgment routine ASM and effect routine ASM.


#1272

Oh, that’s a pity. I don’t think I can do it. Thank you for your reply.


#1273

One quick question about the music importing, i just imported a song from FE8 to FE7, the question is, Where does Febuilder paste it? I ask this so i don´t overwrite it by accident or the song itself overtwrites something else on my hack.


#1274

i just imported a song from FE8 to FE7, the question is,

How did you import songs?
s file
Or midi
Or Reading from another ROM
Or imported using sappy etc?

Where does Febuilder paste it?

It tries to paste it to the area specified by the user.
If the space is insufficient, search for the free area such as the end of the ROM and paste it.

This rule is the same as battle animation and images.

I ask this so i don’t overwrite it by accident or the song itself overtwrites something else on my hack.

How can I reproduce the problem?

Can you present the necessary data to reproduce?
I need detailed information such as ups, details about the music data in question, the address you instructed to write in, song ID etc.


#1275

There is no glitch yet, but i imported The Demon King Roar from FE8 to FE7 directly vía Febuilder, as you know, you only pick a place in the table, but as i remember i don’t get to say where it is pasted. I replaced the 0x28 Song with the 0x37b roar, but it don´t know where it is, It works fine so far, but i want to know where Febuilder pasted it, so i don’t overwrite it.