FE_Builder_GBA


#586

I think that it is affected by map tile animation.
Please do it in places without like river map tile animation.

CG has similar restrictions.
It will be strange to do it in a place with map tile animation.


#587

Hi, I can’t manage to find how to put a ballista. Is it with events ?


#588

ballista is at the Trap of the Event.
Like damage floor, poison gas, eggs, create as a kind of trap.


#589

It’s still a little wrong :no_mouth:


#590


#591

Sorry, I do not know.
However, I think that there was a tile animation on the map chip of that castle to make the fire of the fireplace shake.
I was darkening the screen before and after promotion.
Perhaps, it may be effective?

There is nothing but trial and error to do.


#592

Hi 7743 and thank you for your hard work on this tool.
We are translating FE6 from the existing fantranslated English version since it never got an official one (with another older tool that decompress huffman text and makes the game load it uncompressed and in ascii, but our tests also showed Shift-JIS can still be used)
We already translated almost all of the text except for the most important thing… Commands like “Attack” “End” “Item” “Trade” are nowhere to be found in ascii in the script, either with the older tool, your tool (with the text dump feature) and the rom with a hex editor.

Do you have any ideas how to find and edit that text? Thanks a lot :slight_smile:


#593

Text pointer for “Seize” unit command at $5C6F40, then add 0x24 to get to the other pointers in order. Last pointer should be at $5C7258
Same with “Unit”, starts at $5C72E8 and ends at $5C7378.
You can find this info using advanced editors>Menu Commands.


#594

7743, I found the error :slightly_smiling_face:


Add these, you can use it


#595

If you click Japanese name pointer,
You can directly edit null terminated character strings commonly used in C language.

Please change to your favorite character here.
If the font size exceeds the existing one, FEBuilderGBA will automatically repoint the pointer to the empty area.
After that, please click Write Button.




Of course, alphabetical fonts that display it in the game are necessary when it is made into one-byte alphanumeric characters.
Also, without using this function, you can change the character string with hex editor or manually rewrite the number of the pointer itself.


#596

thanks.
It loads BG images of black background and removes unnecessary tiles.
I would like to write it when I create FAQ and tutorial.

I want to make an FAQ for frequently asked questions.
“How to change the rapier of the prologue, where is Mulder?” etc.
There are frequently asked questions.

However, I have been busy lately, I have not made anything yet…


#597

Hi there,
I’d like to know how to change the pointer of animations.

I want to change the pointer from FFF8E0 to FFF8B0 but everytime it jumps back to FFF8E0.

Would somebody have the kindness to tell me what I’m doing wrong?


#598

Yeah, these windows just display the hex address and doesn’t allow you to edit it.
You have to change that in the Class editor in the animation pointer window.


#599

The animation pointer of FE is in the class setting.


#600

facepalm -.-
It seems I wasn’t able to see the wood for the trees…

Thanks you two.


#601

Dear Mr. 7743, why do you have such a problem? How do you solve it?


#602

I cannot extend the list for stat bonuses (for weapons). The button for it is just not there. Maybe a bug from a new version?


#603

Also something else about the skill system. When a unit gains a new skill it shows as follow:

Is there something i need to change or type manually?


#604

Please update.

The reason is that google translation broke OpenFileDialog.Filter.
I put it in an automatic test, so it should not happen anymore.


#605

I think that it will work .
I actually tried to give effect to rapier.
It is working properly.

For the actual setting method, please see this manual.
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA/Item_characteristics_EN#f908ac44

Does it work even if you do according to the instructions?
Please tell me what kind of error comes out.

I also tried it in English version(FE8U) just in case. I think that it is working.