FE_Builder_GBA -- If you have any questions, attach report7z

dear 7743
aera’s Magic separation patch Have a problem
SKL Exceed the upper limit when level up
FE8J FE8J1 %E6%8D%95%E8%8E%B71

I do not know.
Is it an existing bug?
This patch was created by aera
and I am not using it,
so I will ask those who are using it.

Although it is displayed that the parameter has been increased in LevelUp, the actual value has not been increased.
So I think that there is virtually no problem.

For some reason items CF, and D3 and beyond give random boosts to growths, and random debuffs after a battle.
Items D0, D1 and D2 work fine.

I don’t know if I setted up them wrong or if it is something else. I’ll send the report.

1 Like

I have the same problem, but I tested that items with the New Skill System in a clean rom and that debuff no appears, maybe that bug is because we update the skill systems and cause a double debuff in our rom.

For now I’m testing a old version of my rom, I try to uninstall the old version of skill system and install the new version without update option.

1 Like

I made an initial setting wizard function.
If WelcomeDialog is displayed without performing initial settings, the initial setting wizard will start.
The Initial Setup Wizard automatically downloads and configures the emulator, EA, sappy, debugger and ASM from the net.
You just complete the setup by pressing a button.


The problem has been reproduced.
Thank you for sending report7z.

It is safe to re-point the Item table after installing SkillSystems.
Conversely, if you re-point the Item table and then install SkillSystems, a bug occurs.

Updating SkillSystems causes problems because it will be installed after repointing the item table.

Perhaps the item table’s direct value is written somewhere.
FE8U 080177B0 (GetROMItemStructPtr)
This bug does not occur if the item table is obtained using this command.
Somewhere, I think the item table values are hard-coded.

I will explain here how to avoid hard coding item tables.

This problem takes time to resolve, as it is necessary to find out where in the SkillSystems the problem is occurring.

I solved the problem by changing the old pointer 0x8809B10 to the new and the buffs and debuffs are gone.

I’ll continue testing to see if everything is working fine.

Thanks for the help.

1 Like

FEBuilderGBA also wants to adopt this method.

However, the value of the pointer alone may cause an accidental explosion, so it needs to be done a little more…
By chance, code or image data may have the same value as a pointer.
If the population is large enough, miracles can occur on a daily basis.

This issue has been fixed in the latest version.
When installing the SkillSystems, if the item table is re-pointed, it will automatically be corrected to the new address.

Several other patches also depended on the item table, so I fixed it in a similar routine.
This will overcome the problems with re-pointing item tables.

1 Like

This problem has been fixed.


NAME=魔力分離パッチ 20180224(導入)
NAME.en=Magic separation patch 20180224(Install)


NAME=魔力分離パッチ 20190421(導入)
NAME.en=Magic separation patch 20190421(Install)

Please update FEBuilderGBA to the latest version.
Then go to the patch screen and select the old patch.

Click the Update button in the upper right, so click on it.
It is automatically updated to the latest version.

Of course, you can uninstall and install a new version.

thank you very much.

With the magic separation patch, is there a way to set weapons (like a sword) that use the characters magic stat to attack?

Hello. Wanted to ask something, but before, I want to say that thanks everyone for working on this program thingy. I’ve used it, and with some basic features (and skills and the like) it has been an incredible experience.

However, I have been having problems when it comes to more “advanced” things to do, mostly because I don’t really understand nothing about these pointers, and when trying to extend lists or something, it usually ends up doing bad things, and I don’t understand why.

So, one of my problem is this: On a clean ROM, with no modifications and no patches, I want to add the “Thief (F)” into Fire Emblem: The Sacred Stones. I was able to get the Sprites for the Non-moving and moving parts, but the battle sprites I can’t get them working.

So, anyone knows a step by step tutorial for this process? I tried using the “Lyn from Fire Emblem 7 to Fire Emblem 8”, however, they do so by replacing Eirika into Lyn. I want to do it from new, non used spaces emphasized textif possible.emphasized text If it is something not possible, then thank you. If possible too, if the tutorial includes every step (even from the ones I was able to get) that would be amazing.

Regardless if my question is answered or not, I will probably ask more things in the future. Thank you. If 7743 or anyone needs a less detailed or more detailed description, I will try my best.

when trying to extend lists or something, it usually ends up doing bad things

What specifically happens?
If you have problems, please send report7z.

I do not understand only by “bad things”.

Because there are various items in GBAFE, it is impossible to create a complete tutorial.
At first please change it little by little and check the operation.

Markyjoe made a video for commentary.

Or, try what is written in the manual.

I want to do it from new, non used spaces emphasized textif possible.

Specifically, where do you want to enter unit ID?
Depending on the place you want to enter unit ID, things to do will change.
Also, the unit that can be a player unit must be Unit ID: 0x45 or less.

What is it different from a regular magic sword?

magic separation patch is a patch of FE8J.
This is a patch that separates power and magic.(Author: aera)
I think that there is no relationship with magic sword.

1 Like

Yes, I watched the video you linked. It is really good, but naturally, for the harder things, there’s nothing I can do, as the video doesn’t explain it (but not like it should, explaining everything would probably be impossible).

I will read on how to send you those report things, I think it’s somewhere around here on how to create them, right? I will read on that.

I would like to set “Save if no error” to the default operation of “Save”.
This is because FELint can be executed in a background thread, so it can be determined almost instantaneously whether there is an error or not.
I would like to provide a safer mode.

If you do not like this behavior, please set Option’s “Simple Check at Overwite” to “0 = Do not check”.

Hey i want something really bad at my hack but it seems that its not on the event or unit placer so i was trying to edit glens death FE8

“Sacred Weapons” in the detail menu has been moved to Patch.



I found a problem with the Weapon Lock Ex, if you set up a large number of items (I setted up 225 weapon locks) the game slows down everytime when you select an unit.

I’m pretty sure the Weapon Lock Ex is the problem because I uninstalled the patch and the problem was gone.

Is there a way to implement @Venno’s array based weapon lock ?
It’s more convenient for me because I want to set a weapon lock for several weapons by class, the current system forces me to set a entry for each unit per weapon and that’s why I end up with a huge list. With an array the you can use the same entry for several classes or characters.

1 Like