Zahlman's Song editor crashing

Whenever I use Zahlman’s song editor, it seems to work fine until I use the dump command. It either tells me that my arguments are invalid, I do not have enough arguments, or it just stops working. Here is the crash log:

Any ideas?

Notice how rip 0x056C820 worked? That address is the location of the header of one of the songs. rip grabs data for a single song.

burn tries to grab all the audio samples in the ROM. It finds them by using the song array to locate every song, and then analyzes the songs to find their instruments, and then analyzes the instruments to find their samples (and removes duplicate addresses along the way). I don’t know where the song array is in the FE6 ROM (I’m assuming you’re using the old translation patch), or in any ROM other than FE7, really. Sorry. :frowning: I also don’t know for sure if FE6 actually has the equivalent data with the same structure (but I presume it does because of code reuse).

Anyway, what happened is that it tried to use the first word in that song’s header as if it were a pointer to a different song, which it isn’t. It failed in a way I don’t think I even considered at the time :slight_smile:

But yeah, all of this code is a few years old now, and written for an old version of Python. I’m not really maintaining it, although I keep telling myself to redo it properly one of these days.