What do you do with make hack.cmd?


#1

Hello everyone, I’m trying to learn to use EA with the help of the ultimate tutorial 2 and right now I´m in the buildfiles basics section trying to get make hack to do it’s thing, but the tutorial isn’t very specific with what to do with it.
For starters I changed “FE8_clean.gba” for “FELimpio.gba”; both instances of FE_Hack.gba for FE editado; changed the FE8 on Core A FE8 for FE7 and finally didn’t change ROM Buildfile.txt because my buildfile is named the same way. Apart of that I just copied and pasted the script of the ultimate tutorial 2.
I doubt it matters, but FELimpio and FE editado are spanish for clean FE and edited FE respectively.
I attempted to include make hack after the #incude eastdlib.event line, which didn’t work. Then I wrote the include command last, which also didn’t work. Both scripts look like this (except i swapped around the #include “MAKE HACK.cmd.txt”) :
#include eastdlib.event
ORG 0x1000000
#include “Hello World.txt”
#include “MAKE HACK.cmd.txt”

They both give me the same error:
Finished.
1 errors encountered:
File MAKE HACK.cmd.txt, Line 1, Column 4: Didn’t reach end, currently at MathOperator(%)

No data written to output.

I have attempted this both by editing the FE editado and FELimpio roms, both with the ROM in question still being clean.

By the way, MAKE HACK has that txt at the end because it is a text file and at least in my computer all text files seem to have one automatically. Maybe that’s why this isn’t working properly.

By the way 2, this is how my event assembling folder looks like:

My error is probably me not reading the instructions correctly, but I don’t see what I’m missing. Thank you very much in advance, and please tell me if the title is lacking.


#2

MAKE HACK should be .cmd, not .txt
You don’t include MAKE HACK in your buildfile, you run make hack (double click) and make hack is what makes EA read your buildfile.

It looks like you have extensions hidden, I recomend you change that


#3

Thanks a lot, now it works :slight_smile: