Weird sounding note fix? (Music)

If you’ve ever tried to do music in the GBA games, you might recognise this issue:
a note is too long and sounds kinda distorted and generally unpleasant.

Previously, I somehow managed to “fix” this by creating a new midi file and pasting over each track and instrument, but that doesn’t seem to work with my latest work.

So my question to the dear musicians of FEU:
What exactly causes this and is there a pemanent fix?

Like I said, I think it happens because of the length of the note and it doesn’t seem to happen with instruments that don’t “hang around” like the acoustic piano, but I’m not entirely sure.

1 Like

I remember having something similar before, I was told to get rid of any commands in Anvil or smth to get rid of modulation commands in the track event list.

Would you happen to know where in Anvil I can do this?

I believe it’s in Event List. It’s been a while since I did anything of the sort. Although if you open the .s file with notepad then you should be able to spot treat any MOD commands.

I’ll be sure to check it out next time I face this problem. Thanks a bunch. You greatly helped me pinpoint the cause of the problem, even if my current solution was just copying each individual note so no events are copied alongside it.

I can’t access the Google file without logging in, but I assume you’re referring to the problem of music sounding like a siren. This is because of modulation events, which are much more subtle on computers than they are on the GBA. Modulation can affect one of three things in most GBA games: pitch (default), volume, and panning. If you set the modulation to something very low like 1, for example, you can notice the pitch of the note wobbling ever so slightly, whereas the note will absolutely freak out if the modulation is set to 127 (the maximum). It can be used to great effect for instruments like violins or woodwinds, which naturally have that wavering sound when someone plays a long note on them, so you can achieve that effect by bumping up the modulation a little in the middle of a long note.

There are several different easy fixes for too high modulation in songs:

The first is just to remove all the modulation events in Anvil Studio or in the .s file, but I wouldn’t recommend this because you lose the neat effects on the notes’ pitches.

A second way, and the way I would recommend doing it, is to use midi2agb (NOT mid2agb) or midfix4agb, which are both Windows command prompt apps that you can specify certain options in. One of these options is modscale , which lets you scale down the modulation in the song to a reasonable amount. I would recommend starting with 0.05 (meaning modulation will range from 0 to 6 instead of 0 to 127) and going from there.

The third way, which is a sort of compromise that doesn’t require using the command prompt but also doesn’t delete the modulation entirely, is to open your .s file in Notepad and use find-and-replace to replace the MOD event label with LFOS (stands for “LFO speed”, basically the speed of the pitch changing will be altered rather than the depth). After that, add back a MOD event with a very low value (e.g. 1) to the beginning of every track that contains the new LFOS events. This will result in a very subtle effect that makes the song sound more like how it does in Anvil Studio.

Also, since I mentioned it earlier: if any curious souls want to mess around with modulation affecting volume or panning instead of pitch, use Edit ->Insert Midi Event in Anvil Studio, tick the “include all controller events” box, and select “Event: b016”. Set the value to 0/1/2 for pitch/volume/panning. It applies per track. Keep in mind that you’ll only hear the effect in-game and not in Anvil Studio. You can also manually add it to the .s file if you want, using the byte 0xC4 as the event name.