Skill Systems Bug?

I’m working with FE8 on FEBuilder and I’ve found a bug where skillsystems no longer gives units skills from levels they have already passed.

For example, if a unit is set to learn “Pivot” at level 1, the skill will not be present on the unit if the unit appears at level 1. The unit will have personal and class skills though.

Additionally if a unit is recruited at level 10, they will not have any skills from levels 1-10. Additionally 0 doesn’t work.

I’ve tried setting the skills to different levels (like 1,2,3,4 for example) and I’ve also tried setting the skills to the initial level. Nothing seems to work. I am not sure if this bug is exclusive to my rom or if it is present in skillsystems. I checked the skillsystems thread before writing this and saw nothing about it.

A report7z is available below:

If i am not mistaken, if you want a character or class to start with a skill no matter their level, you need to put the level of acquisition to 255

Unfortunately, that isn’t working either.

Units don’t have skills from earlier levels upon appearance.

You should write a little more explanation.

Who Unit?
Which map?
Which skill?

Now that you have created the new topics,
I would like to explain how to write a report.

When writing a bug report, the most important thing is reproducibility.
You need to describe how we can confirm that the problem is occurring.

Do you think we can read your report and reproduce the problem?
We can’t do it because you not write which unit and which skill.

So what should do?
In Ch1 (MapID 0x01 Escape!), Franz (UnitID: 0x04) that appears on turn 2, does not have Skill Triangle Adept (SkillID: 0x8E).

Written like this, it will be possible to reproduce the problem.

In addition, if you include the save data just before, it will be easier to reproduce.
and It will be a hint to solve if you describe what you tried and when this problem has occurred (was it working correctly before?).

Well, maybe you just haven’t reset.
For example, is the unit already at a party?

This is because Kyle (UnitID: 0x01) of Prologue (MapID: 0x0) sets the appearance level to 25 and plays New Game, and he has Skill Adept (SkillID: 0xA) correctly.
He will be properly loaded with all the skills he will acquire.

I apologize for not providing a better description of the problem or more details. So, for example, the unit “Raul”, id 0C, appears at level 1 with the skill axefaire.
Fire Emblem - The Sacred Stones
However, in FEBuilder under skills it shows that he should have Pivot.
I am not sure why Pivot would be excluded, but it appears to be a problem with each prepromoted unit in the game. Below is a save on Chapter 1 in which he appears. The resume data is on the turn in which he appeared.

It’s an issue with promoted units in the most recent build of skill systems. Right now the quickest way to fix it would be the turn off the “promoted unit” flag for that class and adjust their experience formula through some other means.

I believe this is intentional. They made prepromoted units considered as level 21.

It will work differently for enemy prepromotes / player units past around 4c as skills aren’t saved for these units, so it figures out which skills they would have gained when the unit is loaded.

You should set skills learned as level 255 for skills you want the class to learn automatically, not level 1.

Additionally, pretty sure if an entry in the list is 0, everything below that is ignored. So if a classes’ first skill is learned at level 0, they will have no skills.

@Sme wrote:

If a unit is loaded as promoted and has a character-specific level up skill theres no reason you can’t just make it 21 instead of 1
255 still works as the learn on load designator

There was a discussion about this in #febuilder_help on May 22nd in the feu discord.

I find that personal skills that are set to level 255 do not work even still. However I have confirmed it works with class skills.