Sappy and Usenti not working

I was trying to use sappy the other day, but it no longer loads(It used to work a while ago). When I double-click it, it shows the spinning icon thing, but then never loads up. I tried using different versions, which yields varying results. Sometimes, I can launch sappy and everything pulls up fine, but when I open any ROM, sappy immediately crashes. I tried launching as administrator, but nothing happens or it still crashes when I try to open a ROM. I tried different versions of sappy 2006 mod X, but I get the same result. I tried even using the French sappy, but it crashes upon opening the ROM.
Usenti refuses to work for me. Whenever I open/launch it, it just pulls it up, but crashes and stays in that crashed state until I close it out. It works on my friend’s computer(Windows 8), my alternate laptop(Windows 8), but not mine(Windows 10?).

Any ideas?

Maybe they are somehow not compatible with Windows 10 yet? After all Usenti worked on your Alt Computer.

But sappy used to work on my Windows 10, but not anymore.

Well, I am not sure about sappy. But I guess Usenti is incompatible with Windows 10.

I have Windows 10 on my laptop and I’m using Usenti on it right now. No problems that I can see. Maybe try redownloading it?

I have. I re-downloaded it multiple times and with different versions, but with the same results. It just crashes.

did you try this steps outlined here?

Yes. However, I do not receive a message about not having that file. It just crashes.