MAKEHACK problem [Solved]

Hi! So i’m just beginning to switch to the MAKEHACK method. Before trying it on FE7 I started with FE8.
But I need a little help there…
I just changed Eirika’s base HP in both Char editor and class editor
I ran the makehack after saving and running C2EA everything was written correctly in the Table installer of course.
but when I ran Makehack.cmd the hack just had the regular Eirika.

I saw at the begining that I had the
“echo is not recognized as an internal” problem when launching the cmd.

I tried to change the encoding of the cmd to ANSI and that worked.

But th main no writing problem is still here. The changes I made on eirika are not working.

I have few errors that i’m not able to solve myself too.

1 errors encountered:
File Battle Animation Editor.event, Line 4, Column 2: Didn’t reach end, currently at MathOperator(+)


1 warnings encountered:
.# ifdef’s are missing at the end

Here’s the complete thing.

D:\Perso\Paul\MAKEHACK FE8>´╗┐echo off
‘´╗┐echo’ n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

D:\Perso\Paul\MAKEHACK FE8>cd D:\Perso\Paul\MAKEHACK FE8\

D:\Perso\Paul\MAKEHACK FE8>echo on

D:\Perso\Paul\MAKEHACK FE8>copy FE8_clean.gba FE_Hack.gba
1 fichier(s) copié(s).

D:\Perso\Paul\MAKEHACK FE8>cd “D:\Perso\Paul\MAKEHACK FE8\Event Assembler”

D:\Perso\Paul\MAKEHACK FE8\Event Assembler>Core A FE8 “-output:D:\Perso\Paul\MAKEHACK FE8\FE_Hack.gba” “-input:D:\Perso\Paul\MAKEHACK FE8\ROM Buildfile.txt”
1 errors encountered:
File Battle Animation Editor.event, Line 4, Column 2: Didn’t reach end, currently at MathOperator(+)

No data written to output.

1 warnings encountered:
.#ifdef’s are missing at the end

D:\Perso\Paul\MAKEHACK FE8\Event Assembler>cd “D:\Perso\Paul\MAKEHACK FE8\ups”

D:\Perso\Paul\MAKEHACK FE8\ups>ups diff -b “D:\Perso\Paul\MAKEHACK FE8\FE8_clean.gba” -m “D:\Perso\Paul\MAKEHACK FE8\FE_Hack.gba” -o “D:\Perso\Paul\MAKEHACK FE8\”

D:\Perso\Paul\MAKEHACK FE8\ups>pause

uh. wanted this to be in spoilers but i only know the [spoiler=][/spoiler] code.
Thank you =)

What is in Battle Animation Editor’s CSV sheet?

There’s likely something there that the interpreter is having issues with (which would be why it has the specific error denoting the +).

Well I just tried to remove the entire animation folder. And he found a new error that wasn’t occuring before
1 errors encountered:
File FE8 Character Editor.event, Line 4, Column 16: Didn’t reach end, currently at Symbol(viewer)

And now that I put back the animation folder, it just doesn’t find the first error.

Only this new one.

So. I’ve got a little help to find the problem. That’s now solved.

It’s really specific because the problem was that my Modules where written with semicolons instead of commas
as separators. And so… MAKEHACK expects commas. (It came from the fact that my computer was set on a different language than english.)