[GBAFE(7)] Music Insertions

So, for a while now, I have been trying to insert some custom music into my FE 7 test hack. It shows up successfully in the song.gba… thing, so I follow the instructions from Blazer’s Ultimate Tutorial and do all the copy/writing stuff into the FE 7 ROM, re-write all the pointers. Then, using Nightmare, I change the offset of music 0x7A to point to my inserted song. After that, I head over to the chapter data editor in Nightmare and change the player phase theme to 0x7A, which is what I used as the music ID, but whenever the song is supposed to play, all I get is some dull, clicking sounds, which then causes all tile animations to freeze while essentially freezing the ROM infinitely, not progressing forward nor playing the song or crashing the ROM. It does the same thing if I set it to play on the enemy phase theme as well. Could I have some advice/help?
I can provide some more information or data if required.

Stop using Blazer’s method, start using mid2agb and Sappy

Is there a link to tutorials for what you suggested?

It is obvious that you made a mistake. That method is so complicated that it is no surprise to make one or two mistakes somewhere.


It’s a Pokemon-based tutorial, but everything is identical apart from the games and some offsets. Give that a go.

Or he could use Zahlman’s Song Editor, which is WAY easier. :smile:

zahlman’s song editor is inferior

It really is; one of these days I need to redo the whole thing. A lot of people found it a lot easier to get working than finding the right version of Sappy and getting it set up properly, tho.

1 Like

Yeah, the tutorial really helped! Thank you! Everything seems to be working fine for me now!

Another quick question to tack onto here while I am still here:
Is there a way to make certain units required in a chapter (FE7)?
Do supports not work in Lyn mode or am I just not being patient enough?
Is there also a way to make a phase theme? Like Friendship and Adventure? If I use a non-phase music for a phase music, after a battle/heal, the music just stops.

1 Like
  1. Look for the Character Forcer patch in Nintenlord’s Utilities
  2. Supports do not work in Lyn Mode
  3. I’ll let Agro answer this one since I only have a very vague idea of how to get overworld music to function.

You need to change the “priority” in the music editor to “Map theme” from “BGM”

Yeah, that worked, thank you @Primefusion and @Agro. I have another question yet again.
In FEditor Adv, when I try to insert a script to create a custom battle animation, I get the error, “That image uses too many tiles!” Could someone tell me what that means? I have not a clue.

Without seeing the frame in question, I couldn’t tell you. My guess is that the image gets processed and has too many tiles. The editor should halt on the frame in question, so I’d check that frame first.

Yeah, I just had a standing.png in the thing to figure out what the issue was. It seems as if all my frames were doing the same thing.
Here is the frame if anyone wants to have a look.

I don’t see anything glaring about this frame you posted, it’s small enough that FEditor should be able to process it. When you get the “Too many tiles” error, the white dialog box should have a line that says “Last path: C:\pathtoyourframe\problemframe.png” generically. The last frame it tried to process is the one you want to check out in this case.

Which happens to be the standing.png, in this case. I was wondering if there were extra layers hidden in the image or something. I checked the frame for layers, but ended up finding no other layers, so I still wonder what that error message means…

I know what the problem is lol. FEditor is very particular about the palette order in the top right corner. the top-right most pixel needs to be your transparent color (in your case the purple.) Since it’s not in the right position, FEditor thinks the entire area of your frame is the sprite, not the actual character in frame. Try adjusting your palette order and it should fix the problem :slight_smile:

1 Like

Wow, that worked! Thank you!

I knew it was going to be this without even taking a close look at the top-right :wink:

I’m ashamed I didn’t figure it out right away, given I’ve seen this beast raise it’s head before :stuck_out_tongue: